problems setup 3cx

Discussion in '3CX Phone System - General' started by shark95763, Aug 22, 2007.

  1. shark95763

    Joined:
    Aug 22, 2007
    Messages:
    22
    Likes Received:
    0
    Hi,

    I installed 3cx pbx on a win2k adv server.

    I added a extension 100


    Now I signed up at freenumber.nl for a voip-in number, and i connected that to a username and sip server. in my case i would say 100=username and sip server = my public ip where my 3cx server is installed on. (this machine is on public ip)

    but when i call my voip-in number, i see this in the server log:

    16:40:37.170 Endpoint::findSource [CM010001] Line configuration does not allow identification of the source of this call. Check Advanced Options for Gateways and Providers and match a field to a correct value from the following: Contact IP: '217.67.240.200'; From: '0031454009110'; To: '101'; Rline: '101'; Contact: '0031454009110'

    But i don't understand this.
    at the moment i got extension 101 setup (also a softphone connect to 101 and registered) i got no lines installed, cuz i only want to accept inbound calls on my voip-in number.. in this case my sip server should be my 3cx server who can help me?
     
  2. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    0
    Please try to enable "Use IP in 'Contact' to recognize source" by click Lines > Manage > Gateway > Other Options

    It maybe fixed your problem.
     
  3. shark95763

    Joined:
    Aug 22, 2007
    Messages:
    22
    Likes Received:
    0
    setup

    Hi,

    Yes i could try, but therefore i need to setup a LINE, but what if i don't have one?

    Because like the situation i explained, i think i don't have to setup one right?
     
  4. Mirzab

    Mirzab Member

    Joined:
    Jul 22, 2007
    Messages:
    400
    Likes Received:
    0
    Just to make sure I understand correctly:

    You wish to use 3CX for inbound calls only, not to make outbound calls.

    You DO NOT have anything under "Lines"

    I believe you have setup your inbound number as an Extension?

    If yes, don't. Setup as DID or VoIP provider, whichever best suits the config needed. You will have the option to select receive calls only.

    Until that is corrected no other troubleshooting would be useful.
     
  5. shark95763

    Joined:
    Aug 22, 2007
    Messages:
    22
    Likes Received:
    0
    setup

    HI,

    Well the freenumber.nl the only option i have to setup is to provide a Username and a Sip-server to forward the calls to.

    regards,

    Maikel
     
  6. shark95763

    Joined:
    Aug 22, 2007
    Messages:
    22
    Likes Received:
    0
    server

    it looks like the freenumber.nl setup works like a direct sip call sip:100@publicip.nl i have to setup a srv record in dns, this is no problem, but my server is behind a router, and on the router i opened port 5060 and 3478 sip and stun.

    But i think the srv record thing is not the problem, because the call gets to the 3cx server, but it looks like it doesn't allow something, only I don't know what.!?!?!?
     
  7. archie

    archie Well-Known Member
    3CX Staff

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    You need to set up a line for VoIP provider freenumber.nl
    Internal number of a line should not match extension number, let's say - 10000. Than you need to set up your account on freenumber.nl to direct your calls to that number (10000). If you can not do it, use option "Use IP in Contact" as it was suggested above.
     
  8. shark95763

    Joined:
    Aug 22, 2007
    Messages:
    22
    Likes Received:
    0
    server

    Ok I try to setup a voip provider.

    BUT there's no sip.freenumber.nl or something, so what do I have to fill in there? at free number.nl I only have the option to forward calls to like : sip:number@mydomain.com
     
  9. shark95763

    Joined:
    Aug 22, 2007
    Messages:
    22
    Likes Received:
    0
    server

    I think the Direct Sip call future is the thing I need (i think) as the freenumber only forwards the calls to a sip adress.
     
  10. archie

    archie Well-Known Member
    3CX Staff

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    1) I think you can try to fill just 'freenumber.nl'
    2) Direct SIP calls are supported by 3CX Phone System
     
  11. shark95763

    Joined:
    Aug 22, 2007
    Messages:
    22
    Likes Received:
    0
    server

    ok direct sip calls are accepted, I have setup srv records on my server like described on your internet site.

    But the way you described on the internet is if the server has got the public ip right? because my server is behind a router.

    What I did at the hosting company who manages the dns for my public domain name was: I created a (A) record to my public ip adres .So
    sip.domainname.com (A) to (public ip) 84.xx.xx.xx

    on my server i created a dns record domainname.com and created the _sip srv record like described. Is this configuration ok or is there something else i forgot, because the error message only complains about a line configuration while there's no line configuration setup?!!? :-S
     
  12. archie

    archie Well-Known Member
    3CX Staff

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    Host-part of To field should be your domain name for incoming direct SIP calls. In that case it will be routed to extension directly, but your extension should have SIP ID defined, and uesr-part of To should match it.
     
  13. shark95763

    Joined:
    Aug 22, 2007
    Messages:
    22
    Likes Received:
    0
    server

    Hi Archie,

    Thanks for the quick replys, but what you tell me above is a setting which I have to configure in the "lines" right, or am I wrong? where do i set these things? because i don't have to setup a line for freenumber.nl the thing is the call get forwarded to sipadres@mydomain.com and my 3cx server should forward this to this sip adress which would an extension I setup.
     
  14. archie

    archie Well-Known Member
    3CX Staff

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    You just can try both ways: direct SIP or VoIP line. If you want direct SIP - make sure that incoming invite has your-sipid@domainname.com in To header, and your extension has 'your-sipid' in 'Edit extension/ Other Options / SIP ID'
    IF you want VoIP line - you need it's internal number match user-part of To or Request Line of incoming invite
     
  15. shark95763

    Joined:
    Aug 22, 2007
    Messages:
    22
    Likes Received:
    0
    server

    when i use direct sip i still get this error: [CM010001] Line configuration does not allow identification of the source of this call. Check Advanced Options for Gateways and Providers and match a field to a correct value from the following: Contact IP: '217.67.240.200'; From: '0031454009110'; To: 'shark95763'; Rline: 'shark95763'; Contact: '0031454009110'

    for freenumber there is no way to setup a voip provider, so there's only the direct sip option for me. Also there's no option at freenumber.nl to change the TO header options.
     
  16. archie

    archie Well-Known Member
    3CX Staff

    Joined:
    Aug 18, 2006
    Messages:
    1,309
    Likes Received:
    0
    Sorry, I give up. Too busy with development of new version.
    May be someone else coudl help you more. Actually, i'm sure it is possible, it it takes too much time to find a way.
     
  17. shark95763

    Joined:
    Aug 22, 2007
    Messages:
    22
    Likes Received:
    0
    server

    Archie,

    Still thanks for your help and quick reply's.

    I solved it already the thing was in General Settings - Direct SIP ... at Local Domain i Put: sip.mydomain.com

    now i got it working
     

Share This Page