Problems using the tunnell

Discussion in 'Android' started by haywardi, Mar 17, 2013.

Thread Status:
Not open for further replies.
  1. haywardi

    Joined:
    Feb 27, 2011
    Messages:
    83
    Likes Received:
    0
    Device Info
    -------------------------------------------------------
    Phone Model: Samsung Galaxy Note II
    Firmware Version: 3.0.31-479347


    Hi,

    I've just loaded 3CX onto my android phone and have set it up to work on the internal LAN (and it works on the LAN), but I'm struggling with getting it to register and use outside.

    My situation perhaps isn't as straight forward as it might appear.

    My 3CX server is set-up behind a firewall. But because of constant hacking, I've limited the access to port 5060 to my SIP providers IP addresses only.

    Therefore I thought I needed to use the 3cx tunnel to create my connection. If I understand this correctly, the tunnel uses (by default) port 5090. I've therefore opened 5090 with TCP and UDP and pointed it to my 3CX server. I then added a firewall rule to pass immediately all traffic to port 5090 from the WAN.

    For the purpose of my testing, I tried two configs.

    The first was to set the out of office tick box whilst still within the reach of my lan. As expected it dropped the connection and attempted to re-establish. The display reads 'registering', then it gets to the message 'Tunnel connecting' and then just goes to 'not registered'

    The second attempt was to turn off wifi forcing the connection over 3g and try again, this had the same result.

    I've checked the server log and NOTHING is appearing as if the connection isn't even getting to 3cx.

    This I suspect means that there is a firewall problem, but I don't know where to look now.

    Is the problem caused by me tying down port 5060 so hard?

    All advise greatly appreciated.
    Iain
     
  2. haywardi

    Joined:
    Feb 27, 2011
    Messages:
    83
    Likes Received:
    0
    OOps should have added I'm using 3CX 10!
    Iain
     
  3. haywardi

    Joined:
    Feb 27, 2011
    Messages:
    83
    Likes Received:
    0
    OK forgot it, finger problems by me - really sorry!

    I forgot to add the local IP address of my 3cx server in the tunnel configuration...... :oops: :oops: :oops:
     
Thread Status:
Not open for further replies.