Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Problems with TLS

Discussion in '3CX Phone System - General' started by OlegDenisishin, Oct 28, 2011.

Thread Status:
Not open for further replies.
  1. OlegDenisishin

    Joined:
    Oct 27, 2011
    Messages:
    5
    Likes Received:
    0
    Hello.

    I'm evaluating 3CX Phone System and 3CX Softphone for Windows. I'm trying to setup TLS but it doesn't work. I've followed instructions from http://www.3cx.com/blog/voip-howto/secure-sip/ but server reports in its log:

    21:39:10.406 Exception thrown from Transportprocess: SecurityException getDomainCert failed @ .\ssl\TlsConnection.cxx:87
    21:39:10.406 Don't have certificate for domain 192.168.0.100

    Details about server configuration:
    Windows Server 2003, 3CX Phone System 10

    Does anybody know how I can solve the problem?
     
  2. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,825
    Likes Received:
    2
    On PBX side, you need to install certificate signed by the CA which is installed on the phone side as a trusted one.
    The certificate should be issued for the domain (IP address) of the PBX.

    P.S. please don't duplicate your message.
    http://www.3cx.com/forums/forum-rules-read-to-get-answers-93.html
    http://www.3cx.com/forums/pravila-foruma-kak-sokratit-vremja-mezhdu-voprosom-i-otvetom-18715.html
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. melody0201

    Joined:
    Nov 1, 2011
    Messages:
    1
    Likes Received:
    0

    Hello All;
    I met the same problem.
    Even set up the certication in 3CX server side and restart the 3CX pbx system, this issue still exist.
    Need get some help?
     
Thread Status:
Not open for further replies.