provisioning ext extension - Grandstream

Discussion in '3CX Phone System - General' started by farsight, Nov 4, 2009.

Thread Status:
Not open for further replies.
  1. farsight

    Joined:
    Sep 28, 2009
    Messages:
    43
    Likes Received:
    0
    Folks,

    In looking over the provisioning file for Grandstream GXP-2000, I see a variable "%%pbx_ip%%", which not surprisingly, is the internal IP for the PBX. What I need is the variable for the external IP. What is it?

    It appears there are three places where this is used: P237, P48 and P331. If I replace this one variable and save it as Grandstream GXP-2000E then I should be able to provision my external phones.

    Yes? No?

    Thanks!
     
  2. igor.snezhko

    igor.snezhko Active Member

    Joined:
    Jan 7, 2008
    Messages:
    667
    Likes Received:
    7
    You have to add a string at the end of template file with your settings. Search for section like "User Custom settings" and add you line here. The last value will win, i.e. , if at the start of the file p237 = 192.168.1.1 and at the end of the file p237 = 192.168.1.2, the phone will receive the last address 192.168.1.2
     
  3. farsight

    Joined:
    Sep 28, 2009
    Messages:
    43
    Likes Received:
    0
    Under custom parameters, I found two entries that are set to the ext IP. They are: MSEXTERNALADDRESS and CMEXTERNALADDRESS.

    I'll give one a try and report back.
     
  4. igor.snezhko

    igor.snezhko Active Member

    Joined:
    Jan 7, 2008
    Messages:
    667
    Likes Received:
    7
    Simply use your actual ext IP - not funny variables :)
     
  5. farsight

    Joined:
    Sep 28, 2009
    Messages:
    43
    Likes Received:
    0
    Nope - does work. The custom variable do not work in the provisioning templates.

    Specifically:

    An exception occurred EditExtension Error: Unknow variable '%%MSEXTERNALADDRESS%%' in template.
     
  6. farsight

    Joined:
    Sep 28, 2009
    Messages:
    43
    Likes Received:
    0
    We just took the %%pbx_ip%% out and replaced it with our public IP address.
     
Thread Status:
Not open for further replies.