Provisioning Grandstream phones causes router to lock up

Discussion in '3CX Phone System - General' started by birmingham, Jun 10, 2013.

Thread Status:
Not open for further replies.
  1. birmingham

    Joined:
    Oct 17, 2011
    Messages:
    10
    Likes Received:
    0
    We consistently have an issue when provisioning phones, on the local network, using 3CX Phone System Management Console v11.0.28976.849. It also occurs when a phone is powered off/on, which similarly causes the phone to boot and contact the 3CX server to provision itself.

    The problem is that provisioning phones instantly causes router lockup, which in turn results in internet outage and downtime for the phone system until we do a hard reset on the Draytek router. The phones are Grandstream GXP2110 (initially with firmware 1.0.5.15 and now with 1.0.5.24) and the router is Draytek Vigor 2920n with latest firmware 3.6.3.

    I realize that the likely culprit is the phone itself doing something weird, but I can't be the only one using 3CX software to provision a phone while using a Draytek router. So, hopefully someone here will know how to find a solution.
     
  2. kevin

    kevin Member

    Joined:
    Nov 23, 2006
    Messages:
    316
    Likes Received:
    1
    @birmingham

    When the phone boots up, it sends a MULTICAST request on the LAN - it *might* be this that causes the router to vomit.

    However, you should involve the router vendor's support on the matter.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. sigma1

    sigma1 Active Member

    Joined:
    Nov 20, 2009
    Messages:
    542
    Likes Received:
    1
    Add to the list of devices disliking the broadcast the Edgewater/Edgemark devices too.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. birmingham

    Joined:
    Oct 17, 2011
    Messages:
    10
    Likes Received:
    0
    Grandstream support suggested to log into the web GUI of the phone, and under Network -> Advanced Settings for the option Enable LLDP, check "Disabled". Tried it, but rebooting the phone even via the phone's web interface locked up the Draytek router again.
     
  5. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    752
    Likes Received:
    38
    Hi,

    Have you enable bandwidth limits, or limit the number of active connections for users?
    Please disable this.

    The latest firmware release is v3.6.4 (2013/06/05) which contain a lot of corrections (system crash) and improvements over the previous firmware release 3.6.3.
    Maybe it helps.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. birmingham

    Joined:
    Oct 17, 2011
    Messages:
    10
    Likes Received:
    0
    I had a dog and his name was...BINGO! The new firmware (looks like it was released just 9 days ago, or I might have noticed it) fixed the issue.
    Thanks!
     
Thread Status:
Not open for further replies.