Provisioning Issue

Discussion in '3CX Phone System - General' started by Bunce, Sep 19, 2012.

Thread Status:
Not open for further replies.
  1. Bunce

    Joined:
    Sep 19, 2012
    Messages:
    19
    Likes Received:
    0
    Seem to have an issue with the Plug’n’play auto provision..

    When initially setting up 3CX we ran into NAT issues and so temporarily placed the box on the net (public IP).

    After successfully getting the trunk to work – created extensions etc – all good.

    Moved it back behind NAT and everything is working fine – however it seems when doing an Auto-Provision via Plug’N’Play to a phone on the LAN, its sending the device the URL containg the external IP still – rather than internal..

    I deleted and recreated the extensions thinking that recreating the config files may help – but the config files themselves look to be OK.. Its just that the Plug’n’play process (eg ‘Assign to existing extension’ seems to be sending telling the device to go to the external IP to get the config file..

    If I manually tell the device to go to the internal IP – it works fine. Yealink 28 or 3cxPhone

    All the network and advanced config options I can find seem to be set correctly, but obviously something still believes its running off the external IP only..

    Any ideas? V11 – SP1

    Thanks,
    Andrew
     
  2. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,061
    Likes Received:
    56
    Go to the network tab under settings and then check and re-enter the proper IP addresses, where and if needed. Once done, then go to the advanced tab and custom parameters and check that DEFAULTLOCALIP The default local IP of the PBX XXXXXXXXX (your local IP) and that SIPDOMAIN SIP Domain Name XXXXXXXXX (your local IP).


    Restart the services and see if this helps.
     
Thread Status:
Not open for further replies.