Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Proxy authentication required

Discussion in '3CX Phone System - General' started by pavol.jurko, Sep 6, 2012.

Thread Status:
Not open for further replies.
  1. pavol.jurko

    Joined:
    Sep 6, 2012
    Messages:
    5
    Likes Received:
    0
    Hi guys,
    i have problem with incoming calls. In VoIP provider settings under Advanced is set option: "Do not require registration". If i make a call to registered extension from outside, its dropped after message (SIP Wireshark) - SIP/2.0 407 Proxy Authentication Required.
    Can anybody help me?

    My VOIP provider is Slovak Telecom (T-com)
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,077
    Likes Received:
    324
    I think that you'll need to provide a bit more information, and perhaps a 3CX log of one of the failed calls, to provide a clear picture of what is going on. You can "X" out part of any public IP's for security.

    When dealing with a VoIP provider trunk, it is 3CX that does, or does not do the registration. When dealing with an external extension, then it is that extension that must register with 3CX. If it is a problem reaching an external set (from outside and other extensions) then you may need to examine the registration status of that extension.
     
  3. mixig

    mixig Active Member

    Joined:
    Dec 13, 2011
    Messages:
    530
    Likes Received:
    12
    You can try this:

    Under Source ID under voip provider's main page check the box Source Identification by DID and then add all the DIDs that are there, after that try incoming call
     
  4. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,077
    Likes Received:
    324
    Mixig's post just reminded me...if your situation is similar. When receiving incoming calls from providers that you rare not registered to (similar to an incoming direct SIP call) you may need to put the IP that the call originates from, in the trunk setting in 3CX. I've found that this is usually necessary when using providers such as IPKall. More of a security feature in 3CX.
     
  5. pavol.jurko

    Joined:
    Sep 6, 2012
    Messages:
    5
    Likes Received:
    0
    Hi guys, i want to better specify my problem. Outgoing calls are working very good in directons (extension - extension, extension - other provider), so there is no problem.
    Incomming calls from between extension - extension works
    Incomming calls from other providers are not working. I am still getting message Unidentified incomming call.

    Here is log from 3CX:

    10.10.75.2 - IP address of VVN interface
    195.146.137.250 - IP of SIP server and SIP proxy
    445433112 - Outbound caller ID of my extension in 3CX (last 3 digits are internal extension numbers in 3CX)

    Code:
    07-09-2012 10:32:57.302	[CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    			INVITE sip:445433112@10.10.75.2:5060 SIP/2.0
    			Via: SIP/2.0/UDP 195.146.137.250:5060;branch=z9hG4bKntogeo30708g3ikm8741.1
    			Max-Forwards: 69
    			Contact: <sip:0911932764@195.146.137.250:5060;transport=udp>
    			To: "044 5433112"<sip:445433112@as>
    			From: <sip:0911932764@195.146.137.250;user=phone>;tag=1894278942-1347006784115-
    			Call-ID: BW103304115070912524804407@10.20.60.10
    			CSeq: 267268410 INVITE
    			Accept: application/media_control+xml, application/sdp, multipart/mixed
    			Allow: ACK, BYE, CANCEL, INFO, INVITE, OPTIONS, PRACK, REFER, NOTIFY
    			Supported: 100rel
    			Content-Length: 0
     
  6. pavol.jurko

    Joined:
    Sep 6, 2012
    Messages:
    5
    Likes Received:
    0
    In Verbose logging i see this:


    Code:
    07-09-2012 11:21:45.933	[CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    			INVITE sip:445433112@10.10.75.2:5060 SIP/2.0
    			Via: SIP/2.0/UDP 195.146.137.250:5060;branch=z9hG4bKg5mjhf1010dgphgo2080.1
    			Max-Forwards: 69
    			Contact: <sip:0911932764@195.146.137.250:5060;transport=udp>
    			To: "044 5433112"<sip:445433112@as>
    			From: <sip:0911932764@195.146.137.250;user=phone>;tag=1957503847-1347009712810-
    			Call-ID: BW112152810070912-1036432682@10.20.60.10
    			CSeq: 268732758 INVITE
    			Accept: application/media_control+xml, application/sdp, multipart/mixed
    			Allow: ACK, BYE, CANCEL, INFO, INVITE, OPTIONS, PRACK, REFER, NOTIFY
    			Supported: 100rel
    			Content-Length: 0
    07-09-2012 11:21:45.932	IPs do not match!
    07-09-2012 11:21:45.932	Compare IPs: incoming=195.146.137.250; external=0.0.0.0
    07-09-2012 11:21:45.932	IPs do not match!
    07-09-2012 11:21:45.932	Compare IPs: incoming=195.146.137.250; external=10.10.75.2
    07-09-2012 11:21:45.932	IPs do not match!
    07-09-2012 11:21:45.932	Compare IPs: incoming=195.146.137.250; external=0.0.0.0
    Why 3CX wants to compare IP address?
     
  7. pavol.jurko

    Joined:
    Sep 6, 2012
    Messages:
    5
    Likes Received:
    0
    Thanx mixig, issue was solved after changing this data.
    Thank you so much!
     
  8. mixig

    mixig Active Member

    Joined:
    Dec 13, 2011
    Messages:
    530
    Likes Received:
    12
    Hi,

    I'm glad that I helped ;)
     
  9. muneeb

    Joined:
    Jul 25, 2014
    Messages:
    1
    Likes Received:
    0
    I successfully added my Voip Provider for SIP Trunk.. the IP address is added.. THE DID number is pointed to my 3CX extension but yet I am not able to receive call on my 3cx phone.. on DID provider side it shows "407 Proxy Authentication Required" any ideA?
     
  10. c.holloway

    Joined:
    Oct 24, 2014
    Messages:
    43
    Likes Received:
    0
    Muneeb,

    I don't know if you ever got this sorted out but we had a similar problem. For us the issue was the inbound SIP port being used by the provider. We are running an instance of 3cx Cloud and hosting a number of phone systems internally. With every new instance you add, the required SIP port goes up; so instead of 5060, inbound DIDs for the second system need to be sent in on the port 6060. Once this is done, the calls should connect normally.
     
Thread Status:
Not open for further replies.