PSTN lines stay active on hang up

Discussion in '3CX Phone System - General' started by jduncan, Sep 3, 2007.

  1. jduncan

    Joined:
    Jul 26, 2007
    Messages:
    31
    Likes Received:
    0
    Hi all,

    Im using 3CX with a Grandstream GXP-4104 gateway. There are 3 PSTN lines connected to the gateway. An incoming call is transfered to the digital receptionist just fine and if an extension answers all is well. But if the caller decides to hang up, the PSTN line is left as "Line 1: busy, PSTN Incoming" on the gateway and in 3cx "10000 Line No: 1 00:14:30
    Status: Connected:". This remains like this even if you try to make a call, reboot the gateway, or 3cx itself. It is only cleared when i unplug the PSTN line from the gateway and plug it back in.

    "Enable Tone Disconnect = Yes" is set on the gateway configuration. Any ideas on what i can do to stop this from happening?
     
  2. josvic

    Joined:
    Apr 24, 2007
    Messages:
    51
    Likes Received:
    0
    I have sometimes the same issue... I use a SPA 3102.

    I think the problem is that the digital receptionist don't detect if any tone/noise is in the line.

    Any sugestions?
     
  3. nickybrg

    nickybrg Well-Known Member
    3CX Staff

    Joined:
    Jun 7, 2007
    Messages:
    1,627
    Likes Received:
    15
    Enable Tone Disconnect - Set to NO...

    Hi
    Try this on the 4104
    Enable current disconnect - YES -
    If Enabled use threshold 100 (Default)
    Enable Tone Disconnect - NO (default) Record your results and get back to us.
     
  4. tab

    tab

    Joined:
    Aug 10, 2007
    Messages:
    85
    Likes Received:
    0
    hi,
    I have an SPA3102 too. I spent a lot of time to set the disconnect tone (busy tone from pstn) fragment but since ok. You have to set disconnect tone detect to yes and accurate cadence of your pstn busy tone. SPA3102 runs perfectly.

    tab
     
  5. josvic

    Joined:
    Apr 24, 2007
    Messages:
    51
    Likes Received:
    0
    Thanks...

    Many of hours spent to this and are so a simple solution...

    Thanks again...
     
  6. jduncan

    Joined:
    Jul 26, 2007
    Messages:
    31
    Likes Received:
    0
    interesting

    Well, the default values did not work, which is why i tried to enable the tone disconnect option. Thanks anyway nickybrg.

    I understand what you are saying tab. But unfortunately i don't even know where to begin with changing these settings. Here's what I've got:

    Call Progress Tones
    (Syntax: ch x-y: f1=val@vol,f2=val@vol,c=on1/off1-on2/off2-on3/off3;[...])

    1. Dial Tone: ch1-4:f1=350@-11,f2=440@-11,c=0/0;
    2. Ringback Tone: ch1-4:f1=440@-11,f2=480@-11,c=200/400;
    3. Busy Tone: ch1-4:f1=480@-11,f2=620@-11,c=50/50;
    4. Reorder Tone: ch1-4:f1=480@-11,f2=620@-11,c=25/25;
    5. Confirmation Tone: ch1-4:f1=350@-11,f2=440@-11,c=10/10;

    i have and idea but i still cant really figure it out.
    f1=val is the dtmf frequency of the tone@the volume in db, f2=val is the second tone@the volume in db and c= is the length in ms?

    is this close?[/code]
     
  7. tab

    tab

    Joined:
    Aug 10, 2007
    Messages:
    85
    Likes Received:
    0
    The SPA format is quite different but each sections are recognizable except ch. SPA haven't got like this. I think c= f1/f2 lenght in 10ms. Otherwise I agree with you said.

    tab
     
  8. jduncan

    Joined:
    Jul 26, 2007
    Messages:
    31
    Likes Received:
    0
    Thanks tab. I think it may be correct as well. i have started playing with the settings but i have nothing to compare it against. the ch 1-4 are the 4 pstn channels. i am in Trinidad and Tobago, by the way. i am not sure what the phone system uses, but the busy tone sounds like two short identical ~200ms tones.

    Joel
     
  9. tab

    tab

    Joined:
    Aug 10, 2007
    Messages:
    85
    Likes Received:
    0
    See this:
    http://www.itu.int/ITU-T/inr/forms/files/tones-0203.pdf

    tab
     
  10. jduncan

    Joined:
    Jul 26, 2007
    Messages:
    31
    Likes Received:
    0
    Thanks alot for the link tab. I was able to confirm that those are the settings for this area and they are also the default settings of the 4104 so i did not need to make any changes, which means that the problem still exists. I tried a few different values and have not been successful since.
     
  11. LLangston

    Joined:
    Aug 27, 2007
    Messages:
    57
    Likes Received:
    0
    jd,
    We also have the grandstream 4104 gateway and use the grandstream phones with it. I have our gateway configured to 'Enable Current Disconnect = Yes with 100 threshold'; 'Enable Tone Disconnect = No';
    'Enable Polarity Reversal = No'; 'AC Termination Impedance = 600Ohm North America'(you may want to try the Global Setting on this one); and the 'Silence Timeout = ch1-4:60'. We have not had any trouble with disconnects hanging in the pstn lines. I hope this helps.
     
  12. jduncan

    Joined:
    Jul 26, 2007
    Messages:
    31
    Likes Received:
    0
    OK, i have tried those settings, still no luck. i tried calling from the cellular network as well with the same response. The gateway or 3cx never receives a disconnect signal or message.
     
  13. jlebeau

    Joined:
    May 22, 2007
    Messages:
    32
    Likes Received:
    0
    You may need to contact your PSTN provider and verify their disconnect settings.

    I have Verizon for my local telco and had the same problems with my Grandstream gateways. I contacted them and was told that the disconnect is 400 ms. After changing the setting to 400, it has cleared up the problem.
     
  14. jduncan

    Joined:
    Jul 26, 2007
    Messages:
    31
    Likes Received:
    0
    Hey guys, thanks for all the help. I found the solution though. I changed the re-order tone to match the disconnect tone values from 25/25 to 50/50 and it is working now.
     
  15. jduncan

    Joined:
    Jul 26, 2007
    Messages:
    31
    Likes Received:
    0
    Ok, my problem is not solved. I think that josvic may be right. It's the digital receptionist that is causing the issue. I have configured office hours so that the DR picks up the call from 8am-4pm and then it is set to ring all extensions in a ring group from then on. If an incoming call is hung up out of office hours all the phones stop ringing immediately. But if the DR answers and the call is hung up the line remains open. I think this is because the DR does not hang up the call from this end and keeps the line open. I can set the timeout to have no action nd it will hang up after the silence, but i want it to repeat the prompt after the timeout. Any ideas or suggestions?

    Thanks, JD
     
  16. mark_fad

    Joined:
    May 23, 2007
    Messages:
    13
    Likes Received:
    0
    Hi,

    I also have noticed a similar problem where the PSTN line is not disconnecting when a call is hung up. I also have a Linksys SPA-3102. I had a look at the link that tab posted regarding the frequencies however i have no idea of where to enter the information in the SPA-3102. In the PSTN Line tab there is a section PSTN Disconnect Detection. Is this where i am meant to set the disconnect tone? If so would someone be able to decipher what i am meant to put in the disconnect tone textbox. At the moment the setting is 480@-30,620@-30;4(.25/.25/1+2).

    Thanks

    Mark

    PS Im in Australia
     
  17. SY

    SY Well-Known Member
    3CX Staff

    Joined:
    Jan 26, 2007
    Messages:
    1,821
    Likes Received:
    1
    Hi Mark,

    The fastest way is to ask your telco. They must know everything related to signaling implemented in their network. Also, I think they even know how to configure options on SPA correctly. Anyway, if you will have information from telco, we will help you to configure SPA if you will have any problems

    Regards :)
     
  18. tab

    tab

    Joined:
    Aug 10, 2007
    Messages:
    85
    Likes Received:
    0
    I think you should try one frequency.
    For example: 480@-30,480@-30;4(.25/.25/1+2)
    My settings didn't work while was set up dual frequency. Although it sounds dual frequency.
     
  19. jduncan

    Joined:
    Jul 26, 2007
    Messages:
    31
    Likes Received:
    0
    I have actually tried playing around with these settings only to realize that it was not making a difference because i had the "current disconnect" option enabled so the line was hanging up regardless of the values. My issue was actually with the DR not hanging up when the pstn line was hung up. I have not disabled current disconnect because it is working as it should. I have a timeout set on the DR to hang up after 15 secs of user inactivity. It seems to be the only way out.

    Future feature request: How about a DR option to exit the system with the press of a key? And is it /will it be possible to use the "*" or "#" keys in the DR menus?

    Thanks, JD
     
  20. SY

    SY Well-Known Member
    3CX Staff

    Joined:
    Jan 26, 2007
    Messages:
    1,821
    Likes Received:
    1

    tab,

    Do you live in Australia?
    I'm completely sure that "asking the telco" is a fastest way to get help.

    jlebeau described such situation few post before!

    Regards
     

Share This Page