Random inbound calls are not answerable Issue.

Discussion in '3CX Phone System - General' started by KB-Dustin, Jul 12, 2012.

Thread Status:
Not open for further replies.
  1. KB-Dustin

    Joined:
    Apr 26, 2011
    Messages:
    6
    Likes Received:
    0
    Im running 3CX 9.15781, sadly nolonger on support contract.

    I have had some issues recently with inbound calls. I have 3 POTs Lines connected to a Patton_4114 and all my phones are Yealink (SIP-T26P) Inbound calls get routed to a Ring Group.

    Recently we have had an issue where random calls (now upto almost 40% of the time) any phone in the Ring Group picks up the phone and the Caller ID on the phone switches to the Incoming calls ID (normal) but there is no one on the other end of the phone.
    The result on the inbound callers side the phone just continues to ring as if no one had answered it.

    Its difficult to trouble shoot as calling in by Cell phone from the phones I have tried has resulted in 100% success pickups, but then an outside call comes in (cell or land line) and the issue is present.

    This is a log from a recent call that was answered as described above.

    15:25:53.139 [MS210003] C:5044.1:Answer provided. Connection(transcoding mode[unsecure]):192.168.1.100:7290(7291)
    15:25:53.091 [MS210001] C:5044.14:Answer received. RTP connection[unsecure]: 192.168.1.208:11796(11797)
    15:25:53.071 Remote SDP is set for legC:5044.14
    15:25:52.195 [CM505001]: Ext.109: Device info: Device Identified: [Man: Yealink;Mod: T26;Rev: General] Capabilities:[reinvite, no-replaces, unable-no-sdp, no-recvonly] UserAgent: [Yealink SIP-T26P 6.60.0.110] PBX contact: [sip:109@192.168.1.100:5060]
    15:25:52.195 [CM503002]: Call(5044): Alerting sip:109@192.168.1.209:5062
    15:25:52.030 [CM505001]: Ext.108: Device info: Device Identified: [Man: Yealink;Mod: T26;Rev: General] Capabilities:[reinvite, no-replaces, unable-no-sdp, no-recvonly] UserAgent: [Yealink SIP-T26P 6.60.0.110] PBX contact: [sip:108@192.168.1.100:5060]
    15:25:52.030 [CM503002]: Call(5044): Alerting sip:108@192.168.1.208:5062
    15:25:51.971 [CM505001]: Ext.107: Device info: Device Identified: [Man: Yealink;Mod: T26;Rev: General] Capabilities:[reinvite, no-replaces, unable-no-sdp, no-recvonly] UserAgent: [Yealink SIP-T26P 6.60.0.110] PBX contact: [sip:107@192.168.1.100:5060]


    any help or insight would be greatly appreciated.

    Thank you
     
  2. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,083
    Likes Received:
    61
    Do you have verbose logging enabled? This shows only going to the extensions, but not the source nor to the ring group and is less than 1.5 seconds.
     
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,848
    Likes Received:
    299
    What Codecs are you using? Is it consistent throughout (sets and gateway?) This is why I ask...

     
  4. KB-Dustin

    Joined:
    Apr 26, 2011
    Messages:
    6
    Likes Received:
    0
    Verbose logging is enabled. Looks like I didnt copy enough of the event. Was hard to follow there was some call volume going on at that time. I will repost a new log.


    leejor, thanks for pointing that out.. I was using 2 diffrent codecs for some reason, I have eliminated this issue and now using same codec on all devices and no longer see this message. But didnt eliminate the Issue I was having.
     
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,848
    Likes Received:
    299
    It sounds like the off-hook from the set, is not being passed on to the gateway. If this were happening with internal calls, then i would suggest looking to the sets as, perhaps, having an issue. Since it appears to be only trunk calls (correct?), then I would concentrate efforts on the gateway.

    See if you can isolate the problem to one particular line. If the fourth port is spare, replace the "bad" one if you can determine that only one is having the issue.

    If you need to, make use of Wireshark to confirm that 3CX is sending the "answer" SIP message onto the gateway (and it is ignoring it), when the set answers.

    Check that the gateway has the latest firmware. Even if it does, a "factory reset", (sometimes even just a power down and up) might make a difference.

    You may just have one bad line/port, or the gateway may need to be replaced (worse case scenario), but give it a few good kicks before you go that far.
     
  6. KB-Dustin

    Joined:
    Apr 26, 2011
    Messages:
    6
    Likes Received:
    0
    leejor,
    Thanks for pointing me in the right direction.

    I think I resolved my issues with a few changes.
    - Changed my Patton to only allow 1 codec (I only use 1 anyhow)
    - Changed Response preferred codec to this codec (before it was none)
    - Wrote changes to startup-config
    - rebooted patton (uptime was pushing 200days anyhow)
    - reloaded all services on my 3CX server.

    Issue seams to be resolved.
     
Thread Status:
Not open for further replies.