Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Rapidvox SIP configuration

Discussion in '3CX Phone System - General' started by fish72, Mar 5, 2011.

Thread Status:
Not open for further replies.
  1. fish72

    Joined:
    Mar 5, 2011
    Messages:
    3
    Likes Received:
    0
    Hello,

    I would be thankful if someone can please guide me how to configure 3CX to be used with Rapidvox service.
    I managed to configure Rapidvox on many softphone clients BUT 3CX.
    It seems to me that I don't know where to put the sip domain address (sip.rapidvox.com). Tried it in any possible box, but could'nt get connected to the server.
    Rapidvox basic SIP settings are :

    Host/Proxy/Domain: sip.rapidvox.com
    Port: 5060
    Username: username
    Auth Username: username
    Password: password
    Caller ID: YourCallerIDNumber
    Number: YourCallerIDNumber

    Thank you
     
  2. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    Add a new Voip provider and choose Generic Voip Provider and give it a name. Click next

    In the address box put sip.rapidvox.com, leave the defaults and click next.

    In the external number put your calleridnumber

    In the authname put your username and then the password

    Choose where you want incoming calls to route to and you will also need an outbound rule, use the default if you dont have one (3cx needs at least one outbound rule to make outgoing calls).

    After you save it you can edit it for source id and dids as necessary. See the manual for the full details.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. fish72

    Joined:
    Mar 5, 2011
    Messages:
    3
    Likes Received:
    0
    Hello Mark,

    I'm sorry, but there seems to be some misunderstanding.
    I'm talking about 3CXphone version 5, And there aren't any boxes with the names that you've mentioned (Address box, Auth name)
    I'm attaching a picture of the setup screen :
    http://www.mediafire.com/i/?paz4c31ax4cg92j

    Thank you.
     
  4. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    ahh, this is the 3cx pbx forum, there is a 3cx softphone forum too, but no matter we can do it here.

    In the account name put RapidVox (it is only for you so put what you want)
    In the callerid put your caller id number
    In the Extension put your caller id number
    In the user name put your username and password in the password box.

    Then click on I am out of the office (external ip) and put sip.rapidvox.com
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. fish72

    Joined:
    Mar 5, 2011
    Messages:
    3
    Likes Received:
    0
    Dear Mark,

    Thank you for your kind help. The configuration you suggested didn't work, But I managed to make it work by filling these essentail details :

    Extension : (Rapidvox username)
    ID : (Rapidvox username)
    Password : (Rapidvox password)
    I am out of the office - External IP : sip.rapidvox.com

    Thanks again for your help. I will suggest post these settings at rapidvox site.
     
  6. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    Glad you have it working.

    It looks like rapid vox are also checking the extension number for the user name but at least you have it working, and yes please post it to help others.

    Now you will also be able to download the 3cx phone for android or iphone (if you have one of those phones) and set it up too.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.