Recurrent problem-license lost after rebootWin 7**NETWORK

Discussion in '3CX Phone System - General' started by igor.snezhko, May 31, 2011.

Thread Status:
Not open for further replies.
  1. igor.snezhko

    igor.snezhko Active Member

    Joined:
    Jan 7, 2008
    Messages:
    668
    Likes Received:
    7
    Hi!

    I have very annoying problem with several customers. 3CX license information completely lost after machine reboot.

    These customers all using Windows 7 and static IP address.

    This become a real headache! I have no clue what is a problem, why license info loosing after reboot.

    Please help!
     
  2. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    Re: Recurrent problem - license info lost after reboot. Win

    Hi, can you disable any Anti-Virus software, make sure it wont enable it self on reboot.

    test and confrim if you still get the issue, i wonder, if your AV software is removing the licence file
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. cfive

    cfive Member

    Joined:
    Aug 20, 2009
    Messages:
    284
    Likes Received:
    6
    Re: Recurrent problem - license info lost after reboot. Win

    Is it actually "lost", though?

    I see the key dissapear from the screen, but the installation remains licensed.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. igor.snezhko

    igor.snezhko Active Member

    Joined:
    Jan 7, 2008
    Messages:
    668
    Likes Received:
    7
    Re: Recurrent problem - license info lost after reboot. Win

    No, license become FREE. I can each time reenter license info. I have no idea why this happens AT EVERY customer that use Windows 7.
     
  5. louis2609

    Joined:
    Jun 1, 2011
    Messages:
    2
    Likes Received:
    0
    Re: Recurrent problem - license info lost after reboot. Win

    This is my problem, so i hope you can help me now, i am going to format my laptop ( win 7 64 bit )
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. igor.snezhko

    igor.snezhko Active Member

    Joined:
    Jan 7, 2008
    Messages:
    668
    Likes Received:
    7
    Re: Recurrent problem - license info lost after reboot. Win

    No, do not format. This is 3CX problem, that need URGENT fix.
     
  7. igor.snezhko

    igor.snezhko Active Member

    Joined:
    Jan 7, 2008
    Messages:
    668
    Likes Received:
    7
    Re: Recurrent problem - license info lost after reboot. Win

    louis2609 , are you using English, or some localized Windows version?
     
  8. dennisw

    Joined:
    Jun 1, 2011
    Messages:
    2
    Likes Received:
    0
    Re: Recurrent problem - license info lost after reboot. Win

    Are you using an administrator account ?

    Try running the software as an admin, and see if that changes the situation.

    I think that 3CX tries to write the key in the registry or in a path on the computer. If you do not use an admin account, Windows 7 won't allow this.
     
  9. igor.snezhko

    igor.snezhko Active Member

    Joined:
    Jan 7, 2008
    Messages:
    668
    Likes Received:
    7
    Re: Recurrent problem - license info lost after reboot. Win

    Yes, as administrator. UAC turned off also.
     
  10. igor.snezhko

    igor.snezhko Active Member

    Joined:
    Jan 7, 2008
    Messages:
    668
    Likes Received:
    7
    Re: Recurrent problem - license info lost after reboot. Win

    I have connected to working 3CX system via TeamViewer. Really, license is lost, but the license info still appear at 3CX License. I see that after reboot, all "commercial" services not running (fax, conference, parking)

    Only after entering license info and restarting, 3CX come to work.
     
  11. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,129
    Likes Received:
    153
    Re: Recurrent problem - license info lost after reboot. Win

    There is no evident problem in the 3CX Licence.

    However what I can say is that the erp last week was down for maintenance at specific times. So if a reboot occurred at that time, the erp would not be available and at restart the licence would be lost.

    Can we check this?

    First to confirm whether what I am saying is correct do the following:

    Confirm that you have the pbx licenced./
    Access https://erp.3cx.com. If a login page comes up it means erp is up.

    Then restart the machine or the services - what ever you want.

    If the pbx comes unlicensed contact me immediately. If not you have your answer and you were unlucky that at the time of restart, the erp was under maintenance.

    We have to distinguish problems like these. This is something that can break only if there is a bug or id there is no internet or erp is down. (or firewall block)

    If you have a build that at one point had licence activation ok, then 3CX software itself cannot be blamed unless we make an update with a bug. So other factors must be considered.

    Also if this is a bug, a whole havoc would arise within the 3CX community not just 3-4 people. Also if we had a bug we would not leave this for long and guarantee a global fix within a couple of hours. Rest assured.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,129
    Likes Received:
    153
    Re: Recurrent problem - license info lost after reboot. Win

    Everyone's licence is activated now correct?

    I can assume this was the problem.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. igor.snezhko

    igor.snezhko Active Member

    Joined:
    Jan 7, 2008
    Messages:
    668
    Likes Received:
    7
    Re: Recurrent problem-license lost after rebootWin 7**NETWOR

    No. I found a possible problem.

    The problem, as I said, appear only on Windows 7. The common peculiarity of these customers is using of Oktell SIP GSM Gateway. This software gateway use USB Huawei GSM Voice Modems for GSM network connectivity.

    These modems appears as network card in Windows.

    When Windows 7 starting, it seems, that 3CX Phone System service starts before SIP GSM Service (or before modem driver). So, 3CX not see these modems (network cards),

    Because 3CX licensing mechanism use network information, but modems are absent, the license goes away... :eek: :oops: :lol: :x :twisted: :mrgreen:

    The evident solution is to delay startup of 3CX Phone System. So I set 3CX Database Service, that a first starting service to Automatic (Delayed Start).

    Now I testing this solution.
     
  14. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,825
    Likes Received:
    2
    Re: Recurrent problem-license lost after rebootWin 7**NETWOR

    :) 3CX Phone System should wait until SIP GSM Service will start...
    Are you joking?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. igor.snezhko

    igor.snezhko Active Member

    Joined:
    Jan 7, 2008
    Messages:
    668
    Likes Received:
    7
    Re: Recurrent problem-license lost after rebootWin 7**NETWOR

    Yes. Currently I testing this statement.
     
  16. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,129
    Likes Received:
    153
    Re: Recurrent problem-license lost after rebootWin 7**NETWOR

    You should title the posts properly because we thought this was a valid post.

    Yes Of course - we will implement delayed startup of 3CX in the next coming version - I will also send instructions to 3CX Phone System to go and make you a coffee as well until you test your statements. How do you want it? Black or white?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. multi1

    Joined:
    Jan 27, 2009
    Messages:
    15
    Likes Received:
    0
    Re: Recurrent problem-license lost after rebootWin 7**NETWOR

    and this is the mac address problem i told you about a few posts ago
     
  18. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,129
    Likes Received:
    153
    Re: Recurrent problem-license lost after rebootWin 7**NETWOR

    What is the mac address problem you reproduce? Please specify clearly on this with proper technical details. We are not aware of any mac address problems. What we are aware is that if the mac address of the machine changes or a new mac address is detected on the machine, then the current licence activation is rejected and you will need to reactivate again. This is one of the factors of how the licence activation works to prevent fraudulent licences.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  19. archie

    archie Well-Known Member
    3CX Support

    Joined:
    Aug 18, 2006
    Messages:
    1,299
    Likes Received:
    0
    Re: Recurrent problem-license lost after rebootWin 7**NETWOR

    Let me clarify everything.

    First, Igor clearly described the problem: if Win7 has a SIP GSM installed - it has its own network interfaces (with MAC, IP and everything) added after GSM driver/service booted. It seems that GSM service starts _after_ 3CX PBX in normal conditions. That means, PBX will not have GSM MACs at the moment it validates license. So it finds it to be invalid (because on the time of activation those GSM MACs were present and included in license info).

    So, simplest way to fix that is to make sure that GSM MACs are already in system when 3CX SIP server starts. I think it should be possible by manually adding dependency of 3CX SIP server on GSM service. Or, just delay start of 3CX SIP server. What's wrong with it?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.