Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

registrar host <***> is not mine!

Discussion in '3CX Phone System - General' started by Chrisiesmit93, Feb 26, 2014.

Thread Status:
Not open for further replies.
  1. Chrisiesmit93

    Joined:
    Feb 26, 2014
    Messages:
    6
    Likes Received:
    0
    Hello, I have a problem with my 3CX server (version 12):

    When I want to register an phone with the 3CX software on it, outside my house / LAN, it can't connect to the server.
    3CX error log shows me the following error: registrar host <sip:mad:voip.wjasmit.nl:5060> is not mine!
    If I use my external IP (94.212.212.135), I see the same error.

    3CX is running on Windows Server 2008 R2, which has as hostname: voip.wjasmit.nl, DNS is also working good, the server is behind a NAT firewall (port 5060 and RTP one's are opened correctly).
    Telephones are working good inside the LAN network as long as I'm using the server ip (192.168.5.245), if I use the DNS name voip.wjasmit.nl INSIDE my LAN network, I get the same error as above :S

    Does anyone know if I am doing something wrong, or have the solution for my problem?


    Chris.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,082
    Likes Received:
    324
    Did you put voip.wjasmit.nl in to 3CX as the Domain Name? Although using the public IP address usually works so there may be something else at play here.
     
  3. Chrisiesmit93

    Joined:
    Feb 26, 2014
    Messages:
    6
    Likes Received:
    0
    Did you mean if I put the DNS-name in the OS (Windows Server 2008 R2), or inside 3CX itself.
    If I must put the DNS name inside 3CX software, does someone know how to do this?
     
  4. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    814
    Likes Received:
    49
    Go to Settings >> Advanced >> Local SIP Domain
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Chrisiesmit93

    Joined:
    Feb 26, 2014
    Messages:
    6
    Likes Received:
    0
    THANKS, that was the option I was missing, internal network can now connect succesfully to 3CX.
    Phones outside my network (WAN) are not working yet :(

    Error log shows the following information:
    Code:
    27-feb-2014 22:30:30.441   [CM504002]: Endpoint Extn:102: a contact is unregistered. Contact(s): [sip:102@188.207.68.158:13415 / 102,sip:102@188.207.68.158:13426 / 102,sip:102@188.207.68.158:13429 / 102,sip:102@192.168.1.2:49196 / 102,sip:102@192.168.2.2:50795 / 102,sip:102@188.207.68.158:13434 / 102,sip:102@188.207.68.158:13430 / 102]
    27-feb-2014 22:29:05.463   [CM504001]: Endpoint Extn:102: new contact is registered. Contact(s): [sip:102@188.207.68.158:13415 / 102,sip:102@188.207.68.158:13426 / 102,sip:102@188.207.68.158:13429 / 102,sip:102@192.168.1.2:49196 / 102,sip:102@192.168.2.2:50795 / 102,sip:102@188.207.68.158:13434 / 102,sip:102@188.207.68.158:13402 / 102,sip:102@188.207.68.158:13430 / 102]
    27-feb-2014 22:28:56.983   [CM504001]: Endpoint Extn:102: new contact is registered. Contact(s): [sip:102@188.207.68.158:13415 / 102,sip:102@188.207.68.158:13426 / 102,sip:102@188.207.68.158:13429 / 102,sip:102@192.168.1.2:49196 / 102,sip:102@192.168.2.2:50795 / 102,sip:102@188.207.68.158:13402 / 102,sip:102@188.207.68.158:13430 / 102]
    27-feb-2014 22:28:55.375   [CM504001]: Endpoint Extn:102: new contact is registered. Contact(s): [sip:102@188.207.68.158:13415 / 102,sip:102@188.207.68.158:13426 / 102,sip:102@188.207.68.158:13429 / 102,sip:102@192.168.1.2:49196 / 102,sip:102@192.168.2.2:50795 / 102,sip:102@188.207.68.158:13402 / 102]
    27-feb-2014 22:28:45.353   [CM504001]: Endpoint Extn:102: new contact is registered. Contact(s): [sip:102@188.207.68.158:13415 / 102,sip:102@192.168.2.2:36683 / 102,sip:102@188.207.68.158:13426 / 102,sip:102@192.168.1.2:49196 / 102,sip:102@192.168.2.2:50795 / 102,sip:102@188.207.68.158:13402 / 102]
    27-feb-2014 22:28:35.362   [CM504001]: Endpoint Extn:102: new contact is registered. Contact(s): [sip:102@188.207.68.158:13415 / 102,sip:102@192.168.2.2:36683 / 102,sip:102@192.168.1.2:49196 / 102,sip:102@192.168.2.2:50795 / 102,sip:102@188.207.68.158:13402 / 102]
    Could it be a problem with my firewall? If I run the firewall checker I get for every port the message:
    Code:
    Testing SIP Port 5060 using STUN server: stun.3cx.com:3478
    Resolving STUN server stun.3cx.com ... Resolved to: [198.50.247.220]
    [Test1] Reachability test ... Resolved Public IP: 94.212.212.135:18886
    STUN server stun.3cx.com has second address 198.50.247.219:3479
    [Test2] One on One Port Forwarding ... FAILED.
    No response received or port mapping is closed. Firewall check failed. This configuration is not supported
    Seems like my provider (Ziggo) is blocking port 5060, because firewall (pfSense) has rules for SIP AND RTP ports (which are also failing...)
     
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,082
    Likes Received:
    324
    Well, it's telling you that it is (probably) not going to work the way it is currently configured, which you seem to have discovered. What sort of router are you using? Someone else, familiar with the make/model, may have some configuration suggestions. Is your router set to do port substitution?
     
  7. Chrisiesmit93

    Joined:
    Feb 26, 2014
    Messages:
    6
    Likes Received:
    0
    I am using pfSense (a software router) as firewall, I have changed some options and now the 3CX firewall checker is all green! :D
    The last problem is that the 3CX mobile app still can't connect over internet. :cry:

    3CX log shows me a contact is registered:
    Code:
    Endpoint Extn:102: new contact is registered. Contact(s): [sip:102@92.69.239.182:22579 / 102]
    but the 3CX app (and the builtin android SIP client) can't register / connect to 3CX... (while 3CX say's it's connected :S)


    NOTE:
    If you use pfSense as firewall use the howto from the following site: https://www.summitusa.com/support/i...ranslation-in-pfsense-port-forwarding-for-3cx
     
  8. Chrisiesmit93

    Joined:
    Feb 26, 2014
    Messages:
    6
    Likes Received:
    0
    Does someone know a solution for my last problem?
     
  9. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,086
    Likes Received:
    64
    1st, make sure that the extension that either app will be associated with is checked in the 3CX system as being allowed to be used outside the LAN. You might also check the security settings in the 3CX system just to be certain that the device is not blacklisted. Also, ensure that the tunnel is allowed and set-up and if needed, put into play on each softphone.

    I am guessing that the issue is that while the device may register, voice streams are not passing the firewall. The tunnel may overcome this issue.
     
  10. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,086
    Likes Received:
    64
    1st, make sure that the extension that either app will be associated with is checked in the 3CX system as being allowed to be used outside the LAN. You might also check the security settings in the 3CX system just to be certain that the device is not blacklisted. Also, ensure that the tunnel is allowed and set-up and if needed, put into play on each softphone.

    I am guessing that the issue is that while the device may register, voice streams are not passing the firewall. The tunnel may overcome this issue.
     
  11. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,082
    Likes Received:
    324
    Are you sure it's not the Presence information that you are going by? (that requires the opening/forwarding of port 5000)

    If 3CX show registered then I would suspect that it is.
     
Thread Status:
Not open for further replies.