Registring hardware SIP phone takes over 5 minutes

Discussion in '3CX Phone System - General' started by wjafri, Oct 30, 2007.

  1. wjafri

    Joined:
    Oct 24, 2007
    Messages:
    3
    Likes Received:
    0
    I just got Dlink DPH C160s VOIP SIP phones to connect to 3cx.

    The phones connect ot 3cx, but the registration takes over 5 minutes.

    Second issue is that the phones are suppose to reregister after 3600 seconds, but they don't. I can't dial the other extension if the phones unregistered and then registered again on its own.

    Does it take that long to register a hardware phone? 3cx soft phone registers initially in a matter of seconds only.

    All the help would be greatly appreciated.
     
  2. miraportuga

    miraportuga Member

    Joined:
    Aug 7, 2007
    Messages:
    297
    Likes Received:
    0
    Sounds like a phone firmware failure....or a missconfiguration. wait for other answers thoug, someone might have that phone....

    Cheers
     
  3. nickybrg

    nickybrg Well-Known Member
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    1,716
    Likes Received:
    34
    Just as you stated a phone registration takes from 1-2 seconds. If you manually unplug the phone and re connect it to the power mains does it still take long to register?

    I'd say that you have a device issue. This device is not in the list of 3CX supported devices so the help we can provide is limited. However try upgrading the firmware, resetting configuration to factory default, change network ports on switch maybe the ports have trouble, see the logs and check for a sort of conflict in IP addressing?

    you said
    You have more than one? They are all giving you trouble?

    Regards
     
  4. wjafri

    Joined:
    Oct 24, 2007
    Messages:
    3
    Likes Received:
    0
    I have 2 phones and they both are giving me the same issue.

    Even when I unplug the phone and plug them back in on a different port, the issue is still the same...

    It has the latest firmware on it. I will check log files to see where the problem is...

    Considering that the phone works on a standard SIP protocal, shouldn't all SIP phones work with 3cx?
     

Share This Page