Remote Connections: Not Registered

Discussion in '3CX Phone System - General' started by testit, Nov 28, 2011.

Thread Status:
Not open for further replies.
  1. testit

    Joined:
    Jan 20, 2011
    Messages:
    4
    Likes Received:
    0
    Hello,
    I've installed 3CX on my new Windows Server (2008 R2 x64). I'm using 1&1 (a German provider) as VOIP provider. For testing ive installed 3cx on my home PC with the same settings and everything works fine.

    On my Server 3cx don't want to connect to my voip provider. Similiar which provider i use it dont connects, if I click on "Refresh Registration" nothing happens - Status: Not Registered, Register Sent -, Register OK -, Last Failed Register -.

    Thank you for your help ;)
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,872
    Likes Received:
    304
    It's usually one of three things..

    1. You're not reaching the provider. Network issue/setting error
    2. You're reaching the provider but they aren't getting back through to 3CX. Network issue, they have been given the wrong IP.(STUN setting?)
    3. You settings (password/username/IP you are registering with), are incorrect (provider is getting registration attempt but is refusing it)

    First (if you haven't already done so), run the 3CX firewall checker and be sure that everything looks good. If you are using the URL of you provider, try using their IP, see if that makes a difference. Can you ping your provider from the PC running 3CX?
     
  3. testit

    Joined:
    Jan 20, 2011
    Messages:
    4
    Likes Received:
    0
    Thanks for your answer ;).
    1.) How can i test this?
    2.) How can i test this? I use the normal 3cx stun server, settings aren't changed!
    3.) It have to be correct, because i used the same settings (username, password, sip host) for testing on my PC and there it works.

    The firewall tester dont show any issue (exit code 0) it shows the same things like on my pc. For testing I deactivated the whole Windows Firewall and it didn't worked too.
    Using the ip adress nothing changed and I can ping the provider adress.

    I tested everything, but wonder that nothing happens in 3cx if i click the refresh registration button. No error message no error log entry - nothing. Don't know what to do.

    -----
    I've installed the 3cx phone on my server and tested the connection to my provider. If I register me through the phone program (not the 3cx phone system!) everything works and i can call my home telephone ... (so i dont think that theres any problem with firewall or something like that)
     
  4. testit

    Joined:
    Jan 20, 2011
    Messages:
    4
    Likes Received:
    0
    OK
    Thanks for your help ;)
    After hours of searching and trying I found a thread in another forum (http://www.ip-phone-forum.de/showthread.php?t=208907&page=2 -> GERMAN) where the 3cx Support declared that stun won't work with Plesk.

    I deactivated STUN and used my normal server ip ;).

    -----------------
    But now i have another problem :( ... If i call my number there isnt an incoming call.
    If i register it with 3cx phone everything works fine but not in the phone system ... (only thing that works is outgoing calls ;))
     
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,872
    Likes Received:
    304
    And that may be related to you deactivating STUN. You may be registering an incorrect IP with them (internal, private IP?) giving them no correct way to reach you. Fixing one issue may have caused another.
     
  6. testit

    Joined:
    Jan 20, 2011
    Messages:
    4
    Likes Received:
    0
    Ive used public IP and typed in the static IP of my server which i also use to connect via remote desktop.
    If I open this IP in the browser I can see my homepage too so it must be the correct ip - right?

    ----
    OK now it realy works ;) I just changed from public ip to internal in the voip provider settings ...
     
Thread Status:
Not open for further replies.