Remote Extension Cannot Answer Incoming Calls

Discussion in '3CX Phone System - General' started by gibraltarit, Oct 21, 2010.

Thread Status:
Not open for further replies.
  1. gibraltarit

    Joined:
    Oct 21, 2010
    Messages:
    3
    Likes Received:
    0
    Hi,

    Background
    We've been setting up a new 3CX installation and for the best part it's been an easy, hastle free experience. We have a Patton 4114 4-port PSTN device, a gradwell VoIP trunk, 12 Snom extensions and they can all communicate in and out nicely on all routes...

    The problem
    We have one remote extension. It rings on an incoming call but we cannot answer the call.
    • The phone model is a Snom 300 with latest firmware
    • The 3CX server is a commercial (Small Business) Edition
    • Outbound calls work fine with audio both ways working (RTP good)
    • All port are forwarded correctly to the 3CX server at the head office (passes 3CX firewall check)
    • We have followed the various 3CX how-tos and the settings seem to be correct
    http://www.3cx.com/blog/voip-howto/remote-extensions/
    http://www.3cx.com/blog/docs/provisioni ... extension/ - UPDATED LINK

    Heres the verbose log during an incoming call:
    14:27:56.473 [CM503008]: Call(3): Call is terminated
    14:27:51.192 [CM503007]: Call(3): Device joined: sip:123@127.0.0.1:40600;rinstance=96514bfee704fc7e
    14:27:51.192 [CM505001]: Ext.123: Device info: Device Identified: [Man: 3CX Ltd.;Mod: Voice Mail Menu;Rev: General] Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CX Voice Mail Menu] PBX contact: [sip:123@127.0.0.1:5060]
    14:27:51.192 [CM503002]: Call(3): Alerting sip:123@127.0.0.1:40600;rinstance=96514bfee704fc7e
    14:27:51.051 [CM503025]: Call(3): Calling Ext:Ext.123@[Dev:sip:123@127.0.0.1:40600;rinstance=96514bfee704fc7e]
    14:27:50.989 [CM503005]: Call(3): Forwarding: Ext:Ext.123@[Dev:sip:123@127.0.0.1:40600;rinstance=96514bfee704fc7e]
    14:27:50.989 [CM503003]: Call(3): Call to sip:230@xx.xx.xx.xx:5060 has failed; Cause: 408 Request Timeout; internal
    14:27:36.177 Currently active calls - 1: [3]
    14:27:18.942 [CM503025]: Call(3): Calling Ext:Ext.230@[Dev:sip:230@yy.yy.yy.yy:2051;line=1x1dbl4f]
    14:27:18.755 [CM503004]: Call(3): Route 1: Ext:Ext.230@[Dev:sip:230@yy.yy.yy.yy:2051;line=1x1dbl4f]
    14:27:18.755 [CM503010]: Making route(s) to <sip:230@127.0.0.1:5060>
    14:27:09.864 [CM503007]: Call(3): Device joined: sip:800@127.0.0.1:40600;rinstance=e134a1dc9a4d2db9
    14:27:09.849 [CM503007]: Call(3): Device joined: sip:10007@192.168.1.102:5064

    Where xx.xx.xx.xx is the public IP of the 3CX server and yy.yy.yy.yy is the public IP at the remote site.

    Any help would be greatly appreciated!
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,878
    Likes Received:
    307
    Did you set up Ext 230 to make use of STUN?

    When the remote extension first registers, does it do so with the public IP and port 2051? Is port 2051 used by any other device on the remote LAN?

    It seems odd that the set is using that port, the defaults are usually 5060 and then counting up.

    Could the remote router/firewall be set up to block messages to port 2051?
     
  3. RichardCrabb1

    RichardCrabb1 New Member

    Joined:
    Mar 7, 2009
    Messages:
    196
    Likes Received:
    0
    RPORT needs to be enabled and nat keep alives (SNOM should do the keep alives). Also, ensure that any SIP ALG on the router is turned off. Sometimes it is not easy to find nor obvious. This tries to impose its own solution and conflicts with the STUN solution. Let us know what kind of router that you are using? You might need to use wireshark to see whether any packets attemp to get through to the phone for an incoming call.

    Richard
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. gibraltarit

    Joined:
    Oct 21, 2010
    Messages:
    3
    Likes Received:
    0
    Many thanks for your responses!

    Yep we're using stun.3cx.com. We've also tried a raft of other stun servers with the same result.
    The listening port the Snom registers is arbitray. This is the case for both the remote site and the phones at the head office. On the server the phone registers with the public IP and port 2051 in this case yy.yy.yy.yy:2051. I've set this up with nothing else on the remote network, even put it on the DMZ and the problem persists. Should/how do I force the phone to use 5060? The registar port refers to the 3cx server port, not the phone client!

    I haven't seen any option on the snom or the 3CX server for RPORT, where is it supposed to be? I've got the keepalive interval at 15s (tried others too). There aren't any SIP options on the router unfortunately. The routers we've tried are a Zyxel P660 and now a linksys WAG54G. We've factory reset them to make sure there weren't any lingering settings interfering. I've thought about wiresharking it but I allready know packets are getting through to it given that the phone actually rings! Also the RTP packets are working both ways during an outgoing call (two way audio).
     
  5. gibraltarit

    Joined:
    Oct 21, 2010
    Messages:
    3
    Likes Received:
    0
    From http://www.3cx.com/sip-phones/snom.html

    Darn and blast. Anyone know if this information is current? The PC at the remote site is a thin terminal so the proxy manager isn't really an option... :|
     
Thread Status:
Not open for further replies.