Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Remote Extension not registered

Discussion in '3CX Phone System - General' started by hfournier, May 10, 2012.

Thread Status:
Not open for further replies.
  1. hfournier

    Joined:
    Feb 24, 2012
    Messages:
    38
    Likes Received:
    0
    I've got a GXP1450 with me at my home office and I'm trying to connect it to my client's 3CX.

    I provisioned the phone onsite and followed the instructions here:
    http://www.3cx.com/blog/voip-howto/remote-extensions/

    However, the phone will not register. I captured the "Interenet Sessions" from my router (DIR-655) and got the following after booting the phone:
    Code:
    Local               NAT                   Internet             Protocol State Dir Priority Time Out Counter
    192.168.0.196:33509 xxx.xxx.xxx.xxx:33509 178.238.134.190:3478 UDP      -     Out 128      290      2/11
    192.168.0.196:36578 xxx.xxx.xxx.xxx:36578 208.69.56.110:123    UDP      -     Out 128      278      3/17
    192.168.0.196:41483 xxx.xxx.xxx.xxx:41483 64.59.168.13:53      UDP      -     Out 128      8        4/18
    192.168.0.196:34805 xxx.xxx.xxx.xxx:34805 178.238.134.190:3478 UDP      -     Out 128      254      5/24
    192.168.0.196:11638 xxx.xxx.xxx.xxx:11638 178.238.134.190:3478 UDP      -     Out 128      218      6/26
    192.168.0.196:5060  xxx.xxx.xxx.xxx:5060  224.0.1.75:5060      UDP      -     Out 141      247      7/28
    192.168.0.196:29691 xxx.xxx.xxx.xxx:29691 178.238.134.190:3479 UDP      -     In  128      214      8/29
    192.168.0.196:29691 xxx.xxx.xxx.xxx:29691 178.238.134.189:3478 UDP      -     Out 128      214      9/30
    192.168.0.196:29691 xxx.xxx.xxx.xxx:29691 178.238.134.190:3478 UDP      -     Out 128      214      10/33
    192.168.0.196:59473 xxx.xxx.xxx.xxx:49245 173.254.235.79:443   TCP      CL    Out 128      150      25/35
    
    where xxx.xxx.xxx.xxx is my public facing IP.

    The STUN server on the phone is set to stun3.3cx.com (178.238.134.190).

    The phone does not register and apparently makes no attempt at communicating with my client's SIP Server. And, I'm not sure what 224.0.1.75:5060 is doing, but that's not the SIP servers IP.

    I ran the firewall checker on the 3CX server and everything passed.

    I've also tried connecting the phone directly to my modem, but still no go.
     
  2. misstake2012

    Joined:
    May 23, 2011
    Messages:
    40
    Likes Received:
    1
    check in extension's parameters - Other tab - Disallow this ext register outside the LAN
     
  3. mixig

    mixig Active Member

    Joined:
    Dec 13, 2011
    Messages:
    530
    Likes Received:
    12
    can you check the ip address for sip server in your phone, if you first provisioned your phone locally at 3cx side, it has local ip address of 3cx, maybe is that a reason to not see internet sessions at the router (it is local/private ip)...

    224.0.1.75=multicast IP address
     
  4. hfournier

    Joined:
    Feb 24, 2012
    Messages:
    38
    Likes Received:
    0
    Thanks for your comments, but both those items are covered in the article (see link in previous post) that I followed to configure the phone, so neither are an issue in this case.
     
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,105
    Likes Received:
    329
    Is the set registering to the server as an IP or a URL?
     
  6. hfournier

    Joined:
    Feb 24, 2012
    Messages:
    38
    Likes Received:
    0
    As an IP, like xxx.xxx.xxx.xxx:5060, which is what they showed in the example in the article. So, no DNS issues.

    FYI, I'm not seeing any traffic on the receiving firewall from my IP on port 5060 or 5090. The only traffic I see is on 5060 from/to the VoIP provider. So it's not even trying to register. Looks like it can't get passed STUN.

    Also, I had STUN turned off on the server (using port forwarding), but tried turning it on case it was needed on server as well as client, but no difference.
     
  7. misstake2012

    Joined:
    May 23, 2011
    Messages:
    40
    Likes Received:
    1
    Check port forwarding on your home router. Port 5060 must be forward.
    Try to connect 3CX Phone softphone to 3CX Phone System via tunnel - 5090.
    Try to use SIP Proxy Manager for your IP Phone.
    maybe this things helps you
     
  8. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,105
    Likes Received:
    329
    Assuming that your VoIP provider is connecting to 3CX using port 5060, and the fact that you are not seeing any sign of a registration attempt from the remote set...I have to assume...

    The remote set is not sending, or not able to send, registration to the correct public IP, Something, firewall, router, at the remote end is preventing this.

    You could try moving the set to a different, remote location, if that is possible, just to test. If that worked, then it would point to the remote router as being the issue. You could try resetting the phone, and starting fresh, with its settings.
     
  9. hfournier

    Joined:
    Feb 24, 2012
    Messages:
    38
    Likes Received:
    0
    Problem solved!

    I did two things, so I'm not sure if they were both required or just one to fix the problem.

    I set the Outbound Proxy on the phone to be the same as the SIP Server. It was set to the internal 3CX server IP, not the external public IP. This was not mentioned in the config remote extension article.

    I port forwarded 5060 through my router to the phone as suggested by misstake2012. I hadn't previously tried this because I thought the whole point of using STUN was that you did not have to do port forwarding on remote routers.

    Thank you all.
     
  10. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,569
    Likes Received:
    302
    Argh! Doesn't help me at all.
    My phone is registered and makes outbound calls via the VOIP Line and internal calls.
    When anyone tries to call the remote extension - it rings on the remote end - and they pick up - but the caller display shows calling still - (never get an actual ring). The person on the remote end hangs up. Then it rings again from the same extension. Except they already hung up.

    I could post all sorts of screen shots - but I'm not sure it would help anyone :(
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. misstake2012

    Joined:
    May 23, 2011
    Messages:
    40
    Likes Received:
    1
    I think that problem was in port forwarding
     
  12. misstake2012

    Joined:
    May 23, 2011
    Messages:
    40
    Likes Received:
    1
    It will be rigth way if you create a new forum's request and describe again that happening and show logs ands show screenshots
     
  13. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,569
    Likes Received:
    302
    Finally changed transport on phone from udp to tcp.
    It can receive calls now but still not transfer calls or put them on hold.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. hfournier

    Joined:
    Feb 24, 2012
    Messages:
    38
    Likes Received:
    0
    I can confirm that port forwarding 5060 to the phone was NOT required for the remote extension to work. The above mentioned instructions should be edited to include the Outbound Proxy modification.
     
Thread Status:
Not open for further replies.