Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Remote extension not sending sound...

Discussion in '3CX Phone System - General' started by sms_newb, Jun 8, 2011.

Thread Status:
Not open for further replies.
  1. sms_newb

    Joined:
    Jun 8, 2011
    Messages:
    14
    Likes Received:
    0
    Ive set up a 3CX PBX server in our office that went together fairly easily, ive auto provisioned 3 Grandstream GXP 1450 phones and sent one of them to a remote worker, with the intention that we can communicate with each other via the voip phones. The extensions worked fine communicating with each other within the LAN, but when the hardphone is external I can not hear any sound coming through.

    So the external phone can hear me, but I (in PBX LAN) can not hear the external extension.

    What could be causing this? Is the router at the remote end blocking outgoing sound? Or the router at this end blocking incoming sound?

    15:25:00.204 [CM503008]: Call(77): Call is terminated
    15:24:53.080 [CM503007]: Call(77): Device joined: sip:14@109.152.128.32:64092;user=phone
    15:24:53.077 [CM503007]: Call(77): Device joined: sip:13@192.168.1.73:5060;user=phone
    15:24:50.468 [CM505001]: Ext.14: Device info: Device Identified: [Man: Grandstream;Mod: GXP Series;Rev: General] Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Grandstream GXP1450 1.0.1.66] PBX contact: [sip:14@217.37.xx.xx:5060]
    15:24:50.467 [CM503002]: Call(77): Alerting sip:14@109.152.128.32:64092;user=phone
    15:24:50.232 [CM503025]: Call(77): Calling Ext:Ext.14@[Dev:sip:14@109.152.128.32:64092;user=phone]
    15:24:49.831 [CM503004]: Call(77): Route 1: Ext:Ext.14@[Dev:sip:14@109.152.128.32:64092;user=phone]
    15:24:49.829 [CM503010]: Making route(s) to <sip:14@217.37.xx.xx;user=phone>
    15:24:49.825 [CM505001]: Ext.13: Device info: Device Identified: [Man: Grandstream;Mod: GXP Series;Rev: General] Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Grandstream GXP1450 1.0.1.66] PBX contact: [sip:13@217.37.xx.xx:5060]
    15:24:49.821 [CM503001]: Call(77): Incoming call from Ext.13 to <sip:14@217.37.xx.xx;user=phone>
     
  2. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    sounds like either a firewall or phone config issue.

    can you run the 3CX Firewall checker and past the output here?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. sms_newb

    Joined:
    Jun 8, 2011
    Messages:
    14
    Likes Received:
    0
    Sure,

    3CX Firewall Checker, v1.0. Copyright (C) 3CX Ltd. All rights reserved.

    <15:39:45>: Phase 1, checking servers connection, please wait...
    <15:39:45>: Stun Checker service is reachable. Phase 1 check passed.
    <15:39:45>: Phase 2a, Check Port Forwarding to UDP SIP port, please wait...
    <15:39:46>: UDP SIP Port is set to 5060. Response received correctly with no translation. Phase 2a check passed.

    <15:39:46>: Phase 2b. Check Port Forwarding to TCP SIP port, please wait...
    <15:39:46>: TCP SIP Port is set to 5060. Response received correctly with no translation. Phase 2b check passed.

    <15:39:46>: Phase 3. Check Port Forwarding to TCP Tunnel port, please wait...
    <15:39:46>: TCP TUNNEL Port is set to 5090. Response received correctly with no translation. Phase 3 check passed.

    <15:39:46>: Phase 4. Check Port Forwarding to RTP external port range, please wait...
    <15:39:53>: UDP RTP Port 9000. Response received correctly with no translation. Phase 4-01 check passed.
    <15:39:53>: UDP RTP Port 9001. Response received correctly with no translation. Phase 4-02 check passed.
    <15:39:53>: UDP RTP Port 9002. Response received correctly with no translation. Phase 4-03 check passed.
    <15:39:53>: UDP RTP Port 9003. Response received correctly with no translation. Phase 4-04 check passed.
    <15:39:53>: UDP RTP Port 9004. Response received correctly with no translation. Phase 4-05 check passed.
    <15:39:53>: UDP RTP Port 9005. Response received correctly with no translation. Phase 4-06 check passed.
    <15:39:53>: UDP RTP Port 9006. Response received correctly with no translation. Phase 4-07 check passed.
    <15:39:53>: UDP RTP Port 9007. Response received correctly with no translation. Phase 4-08 check passed.
    <15:39:53>: UDP RTP Port 9008. Response received correctly with no translation. Phase 4-09 check passed.
    <15:39:53>: UDP RTP Port 9009. Response received correctly with no translation. Phase 4-10 check passed.
    <15:39:53>: UDP RTP Port 9010. Response received correctly with no translation. Phase 4-11 check passed.
    <15:39:53>: UDP RTP Port 9011. Response received correctly with no translation. Phase 4-12 check passed.
    <15:39:53>: UDP RTP Port 9012. Response received correctly with no translation. Phase 4-13 check passed.
    <15:39:53>: UDP RTP Port 9013. Response received correctly with no translation. Phase 4-14 check passed.
    <15:39:53>: UDP RTP Port 9014. Response received correctly with no translation. Phase 4-15 check passed.
    <15:39:53>: UDP RTP Port 9015. Response received correctly with no translation. Phase 4-16 check passed.
    <15:39:53>: UDP RTP Port 9016. Response received correctly with no translation. Phase 4-17 check passed.
    <15:39:53>: UDP RTP Port 9017. Response received correctly with no translation. Phase 4-18 check passed.
    <15:39:53>: UDP RTP Port 9018. Response received correctly with no translation. Phase 4-19 check passed.
    <15:39:53>: UDP RTP Port 9019. Response received correctly with no translation. Phase 4-20 check passed.
    <15:39:53>: UDP RTP Port 9020. Response received correctly with no translation. Phase 4-21 check passed.
    <15:39:53>: UDP RTP Port 9021. Response received correctly with no translation. Phase 4-22 check passed.
    <15:39:53>: UDP RTP Port 9022. Response received correctly with no translation. Phase 4-23 check passed.
    <15:39:53>: UDP RTP Port 9023. Response received correctly with no translation. Phase 4-24 check passed.
    <15:39:53>: UDP RTP Port 9024. Response received correctly with no translation. Phase 4-25 check passed.
    <15:39:53>: UDP RTP Port 9025. Response received correctly with no translation. Phase 4-26 check passed.
    <15:39:53>: UDP RTP Port 9026. Response received correctly with no translation. Phase 4-27 check passed.
    <15:39:53>: UDP RTP Port 9027. Response received correctly with no translation. Phase 4-28 check passed.
    <15:39:53>: UDP RTP Port 9028. Response received correctly with no translation. Phase 4-29 check passed.
    <15:39:53>: UDP RTP Port 9029. Response received correctly with no translation. Phase 4-30 check passed.
    <15:39:53>: UDP RTP Port 9030. Response received correctly with no translation. Phase 4-31 check passed.
    <15:39:53>: UDP RTP Port 9031. Response received correctly with no translation. Phase 4-32 check passed.
    <15:39:53>: UDP RTP Port 9032. Response received correctly with no translation. Phase 4-33 check passed.
    <15:39:53>: UDP RTP Port 9033. Response received correctly with no translation. Phase 4-34 check passed.
    <15:39:53>: UDP RTP Port 9034. Response received correctly with no translation. Phase 4-35 check passed.
    <15:39:53>: UDP RTP Port 9035. Response received correctly with no translation. Phase 4-36 check passed.
    <15:39:53>: UDP RTP Port 9036. Response received correctly with no translation. Phase 4-37 check passed.
    <15:39:53>: UDP RTP Port 9037. Response received correctly with no translation. Phase 4-38 check passed.
    <15:39:53>: UDP RTP Port 9038. Response received correctly with no translation. Phase 4-39 check passed.
    <15:39:53>: UDP RTP Port 9039. Response received correctly with no translation. Phase 4-40 check passed.
    <15:39:53>: UDP RTP Port 9040. Response received correctly with no translation. Phase 4-41 check passed.
    <15:39:53>: UDP RTP Port 9041. Response received correctly with no translation. Phase 4-42 check passed.
    <15:39:53>: UDP RTP Port 9042. Response received correctly with no translation. Phase 4-43 check passed.
    <15:39:53>: UDP RTP Port 9043. Response received correctly with no translation. Phase 4-44 check passed.
    <15:39:53>: UDP RTP Port 9044. Response received correctly with no translation. Phase 4-45 check passed.
    <15:39:53>: UDP RTP Port 9045. Response received correctly with no translation. Phase 4-46 check passed.
    <15:39:53>: UDP RTP Port 9046. Response received correctly with no translation. Phase 4-47 check passed.
    <15:39:53>: UDP RTP Port 9047. Response received correctly with no translation. Phase 4-48 check passed.
    <15:39:53>: UDP RTP Port 9048. Response received correctly with no translation. Phase 4-49 check passed.
    <15:39:53>: UDP RTP Port 9049. Response received correctly with no translation. Phase 4-50 check passed.


    Application exit code is 0
     
  4. sms_newb

    Joined:
    Jun 8, 2011
    Messages:
    14
    Likes Received:
    0
    Interestingly I can call the external extension using the 3CX Softphone and it works just fine - we can both hear each other.

    So must be a phone configuration thing with the phones inside the LAN.
     
  5. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    ok, can you do the following

    Open the 3CX Console, Go to >> Settings > Advanced Settings

    at the bottom, you will see a section "Logging Level" can you set this to Verbose. Restart 3CX Services

    Try a call again from one of the lan phones and then post the full 3CX log back here for us to see?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. sms_newb

    Joined:
    Jun 8, 2011
    Messages:
    14
    Likes Received:
    0
    Right, done that. Lots more info here:


    16:06:15.077 Currently active calls [none]

    16:06:05.261 [CM503008]: Call(2): Call is terminated
    16:06:01.631 Session 769 of leg C:2.1 is confirmed
    16:06:01.457 [CM503007]: Call(2): Device joined: sip:14@109.152.128.32:64092;user=phone
    16:06:01.453 [CM503007]: Call(2): Device joined: sip:13@192.168.1.73:5060;user=phone
    16:06:01.449 [MS210007] C:2.1:Answer provided. Connection(by pass mode): 109.152.128.32:5004(5005)
    16:06:01.445 [MS210001] C:2.2:Answer received. RTP connection[unsecure]: 109.152.128.32:5004(5005)
    16:06:01.442 Remote SDP is set for legC:2.2
    16:05:59.793 [CM505001]: Ext.14: Device info: Device Identified: [Man: Grandstream;Mod: GXP Series;Rev: General] Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Grandstream GXP1450 1.0.1.66] PBX contact: [sip:14@217.37.xx.xx:5060]
    16:05:59.793 [CM503002]: Call(2): Alerting sip:14@109.152.128.32:64092;user=phone
    16:05:59.540 [CM503025]: Call(2): Calling Ext:Ext.14@[Dev:sip:14@109.152.128.32:64092;user=phone]
    16:05:59.537 [MS210006] C:2.2:Offer provided. Connection(by pass mode): 192.168.1.73:5004(5005)
    16:05:59.154 [CM503004]: Call(2): Route 1: Ext:Ext.14@[Dev:sip:14@109.152.128.32:64092;user=phone]
    16:05:59.152 [CM503010]: Making route(s) to <sip:14@217.37.xx.xx;user=phone>
    16:05:59.151 [MS210000] C:2.1:Offer received. RTP connection: 192.168.1.73:5004(5005)
    16:05:59.149 Remote SDP is set for legC:2.1
    16:05:59.147 [CM505001]: Ext.13: Device info: Device Identified: [Man: Grandstream;Mod: GXP Series;Rev: General] Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Grandstream GXP1450 1.0.1.66] PBX contact: [sip:13@217.37.xx.xx:5060]
    16:05:59.143 [CM503001]: Call(2): Incoming call from Ext.13 to <sip:14@217.37.xx.xx;user=phone>
    16:05:59.132 [CM500002]: Info on incoming INVITE:
    INVITE sip:14@217.37.xx.xx;user=phone SIP/2.0
    Via: SIP/2.0/UDP 192.168.1.73:5060;branch=z9hG4bK1841902375;rport=5060
    Max-Forwards: 70
    Route: <sip:217.37.xx.xx:5060;lr>
    Contact: <sip:13@192.168.1.73:5060;user=phone>
    To: <sip:14@217.37.xx.xx;user=phone>
    From: <sip:13@217.37.51.xx;user=phone>;tag=49894860
    Call-ID: 281648864-5060-12@BJC.BGI.B.HD
    CSeq: 91 INVITE
    Accept: application/sdp, application/dtmf-relay
    Allow: INVITE, ACK, OPTIONS, CANCEL, BYE, SUBSCRIBE, NOTIFY, INFO, REFER, UPDATE, MESSAGE
    Proxy-Authorization: Digest username="13",realm="3CXPhoneSystem",nonce="414d535c040020d639:10a9e0bd3d761080f380c1a3a8f57f8a",uri="sip:14@217.37.xx.xx;user=phone",response="c550cd6db152eed09dd591d30555a381",algorithm=MD5
    Supported: replaces, path, timer
    User-Agent: Grandstream GXP1450 1.0.1.66
    Privacy: none
    P-Preferred-Identity: <sip:13@217.37.xx.xx;user=phone>
    Content-Length: 0

    16:05:43.075 Currently active calls [none]
     
  7. sms_newb

    Joined:
    Jun 8, 2011
    Messages:
    14
    Likes Received:
    0
    I'm now pretty certain its something to do with the phone configuration on the Grandstream GXP 1450 I have in the LAN. When i try to communicate from any softphone or hardphone outside the PBX LAN, i get the same problem as with other extensions calling to that phone in the LAN. The external phone can hear me, but the internal phone can't hear anything.
     
  8. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    ok. could you check the phone config and make sure you dont have any outbound proxy servers set?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. sms_newb

    Joined:
    Jun 8, 2011
    Messages:
    14
    Likes Received:
    0
    I have set the Outbound Proxy: 217.37.xx.xx:5060 - the pbx server.

    Is that right? Should there be anything in this?
     
  10. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    can you remove this to see if that resolves the issue
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. sms_newb

    Joined:
    Jun 8, 2011
    Messages:
    14
    Likes Received:
    0
    I removed the outbound proxy and updated the configuration on the phone, done a reboot on it. Has not solved the issue unfortunantly. Must be one of the other settings.
     
  12. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    are the phones using the latest version of the firmware?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. sms_newb

    Joined:
    Jun 8, 2011
    Messages:
    14
    Likes Received:
    0
    Yes the phones are using the latest firmware (1.1.66). Perhaps one of the other configuration settings is causing this? The factory reset on this phone is not a complete reset i've noticed so I cant get the phone back to its out-of-box state to re-provision from scratch. When I first set up the phone on the network it did not have this problem, but i was 'checking' a few other settings in the config and one of the things I changed must have stopped it receiving sound from external extensions.
     
  14. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    ok. within the 3CX Console,

    Goto >> Phones

    Select the phones and then select the "Reprovision Phones" wait about 30 seconds, then click reboot

    once completed, test again.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. sms_newb

    Joined:
    Jun 8, 2011
    Messages:
    14
    Likes Received:
    0
    Right, I reprovisioned the phone then done a reboot = no change. I noticed that the reprovisioning adds the pbx IP:5060 to the outgoing proxy. So i tried removing that, updating the config, and still no change.. :?:
     
  16. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    on the remote phone, can you set the stun server to stun.3cx.com save and reboot the phone. test and let me know
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. sms_newb

    Joined:
    Jun 8, 2011
    Messages:
    14
    Likes Received:
    0
    Aha, some progress. On the remote 3cx softphone, i checked the 'Use 3CX Tunnel'. That ungreyed the IP, password and 5080 port. Now I can have 2 way communications with the LAN phone using the remote extension!

    The next thing is to transfer that to the other remote Grandstream hardphones. There doesn't appear to be a checkbox similar to the 3CX tunnel on the softphone.

    Thanks David, will try that as well.
     
  18. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    just the stun will do the job, however you may get issues if you have more then 1 remote phone from the same remote location. in this instance, you may need to use the 3CX Proxy Server.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  19. sms_newb

    Joined:
    Jun 8, 2011
    Messages:
    14
    Likes Received:
    0
    There's only 1 phone at that remote location.

    I'm sure that will solve the problem. However im struggling to access the phone configuration page. I know the IP of the phone, but when im remotely connected to a computer in that network and drop the IP into Safari (Yes, its an Apple Mac), nothing happens. Also I can not get to the router configuration page. This might be better in an Apple Mac forum really.
     
  20. davidbenwell

    davidbenwell Active Member

    Joined:
    Apr 27, 2010
    Messages:
    704
    Likes Received:
    0
    I dont think its a Apple Mac issue, but actually a port forwarding issues on the remote router.

    Please do the following

    Port forward the following ports on your router to your IP Phone

    5060
    80

    also check to see what RTP UDP ports your phone is using and also forward theses.

    Better option to see if this is a firewall option would be to see if your router supports a DMZ Host, if so please enter the ip address of your IP remote phone, example 192.168.1.1

    apply and then test, if your audio then works, we need to look at your router and check the settings to see why its being blocked
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.