Remote Extension - Yealink T46G

Discussion in '3CX Phone System - General' started by caiotoledo, Jan 27, 2014.

Thread Status:
Not open for further replies.
  1. caiotoledo

    Joined:
    Jan 15, 2014
    Messages:
    19
    Likes Received:
    0
    Good Morning,

    I'm having some problems with Yealink T46G with 3CX Phone System.

    I put that IP phone with a remote extension, at first he registed and making and receiving calls.

    But when he makes a call, the call stands for exactly 30 seconds, all the times. That doesn't happen when he receive a call.

    I used wireshark to see what's going on, and i saw which the my PBX send a "OK SDP" and the Yealink don't respond, then after some tries my 3CX send a "BYE" and he respond, then the call it's finished.

    Anyone had this problem?
     
  2. lneblett

    lneblett Well-Known Member

    Joined:
    Sep 7, 2010
    Messages:
    2,061
    Likes Received:
    56
    Usually a firewall is getting in the way.

    Make certain that you have Rport on the Yealink enabled, you may also want to shorten the keep alive interval to 15 seconds or so and you might also consider, if possible, port forwarding at the remote site to the phone. It sounds like the UDP stream is being shutdown and then the system timeouts and disconnects.

    Without knowing more about how it is set-up (STUN, no STUN) etc., this is just a quick guess.
     
  3. caiotoledo

    Joined:
    Jan 15, 2014
    Messages:
    19
    Likes Received:
    0
    I followed this tutorial: http://www.3cx.com/blog/voip-howto/remote-extensions/

    With this tutorial i set on Accounts:
    Basic:
    SIP Server: (Public IP)
    SIP Server Port: 5060
    NAT Traversal: STUN
    STUN Server: (Public IP)
    STUN Server Port: 5060

    Advanced:
    UDP Keep-Alive Message: Enabled
    UDP Keep-Alive Interval: 15 (seconds)
    RPort: Enabled


    And i fowarded already some ports on the router to the Phone: 5060, 9000-9049 and 5090 (But we don't use the Tunnel port).

    In the section "Phones" on my Managment Console i saw this remote extension using the port "5162", but i already set the "Sip Local Port" as "5060".
     
  4. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    2,947
    Likes Received:
    179
    You say you set up the router to forward to the phone. If the phone is open the remote side - there is no need to forward firewall ports to the phone. This all needs to be done on the server side.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,357
    Likes Received:
    224
    Did you actually put the address/URL of a STUN server in here?
     
  6. cobaltit

    cobaltit Active Member

    Joined:
    Mar 22, 2012
    Messages:
    733
    Likes Received:
    112
    Also, make sure SIP ALG is turned off.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. bardissi

    bardissi Member

    Joined:
    Jan 31, 2012
    Messages:
    318
    Likes Received:
    0
    Did you make sure the 3CX firewall checker passes?
     
  8. caiotoledo

    Joined:
    Jan 15, 2014
    Messages:
    19
    Likes Received:
    0
    All configurations on my 3CX Phone System are ok. Because we already use remote extensions, my director has a IP Phone on his house and works very well (It's a GXP 1400).

    About the STUN Server, yes i put our Public IP on there. And all of my firewal checkers were pass.

    The SIP ALG was not disable on the router. I will do that and post if it's work well.

    Thanks for all help.
     
  9. caiotoledo

    Joined:
    Jan 15, 2014
    Messages:
    19
    Likes Received:
    0
    I found the problem.

    My NAT Transversal wasn't using UDP, it was using TCP, that's why all the problems.

    I didn't need to disable the SIP ALG.

    Thanks guys !
     
Thread Status:
Not open for further replies.