Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Remote Extensions with LAN IP

Discussion in '3CX Phone System - General' started by Tularis, Aug 21, 2014.

Thread Status:
Not open for further replies.
  1. Tularis

    Joined:
    Apr 12, 2010
    Messages:
    16
    Likes Received:
    0
    Hello,

    We have a 3CX Hosted PBX in the cloud, so all of our phones are "Remote Extensions".
    They have all be setup in STUN Mode.

    After replacing a router at one of the sites from a Cisco 800 to a Draytek 2830 the phones now register on the 3cx system with their LAN IP Address...

    "3CX Phone System > Phones"

    10.0.3.80:53230
    10.0.3.82:53054
    etc...

    External calls in seem to work, but users are unable to transfer calls and the phones do not receive any BLF config.
    The only thing that has changed is the router.

    The phones at the other site with another Cisco router all show a WAN ip address.

    131.113.26.5:42587
    131.113.26.5:46873
    etc...

    3CX v10.0.24018.2322 SP.6
    All phones are Grandstream GXP2110 [1.0.3.30]

    Any help would be great.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,117
    Likes Received:
    329
    If the sets are actually using STUN, then it sounds as if it's not working the way it should be. The past few versions of 3CX have not (for the most part) required the use STUN in the remote set. It would seem that some setting in the new router is not correct.

    Did you have a look at this? http://www.3cx.com/blog/docs/draytek-firewall-voip/
     
  3. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    815
    Likes Received:
    49
    Hi,

    What you can try is to switch off the router and phones.
    Wait a few seconds then switch on the router and wait until it is fully running, then switch on the phones one by one.
    Check if the phones are registered with their WAN IP address.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Tularis

    Joined:
    Apr 12, 2010
    Messages:
    16
    Likes Received:
    0
    Hello,

    Thanks for the information.

    One of the first things we did was a controlled reboot.

    This is a system we have inherited so I have been doing some digging around.
    The phones have been setup with a STUN server of "stun.freespeech.co.uk" and are registering on the LAN IP address.

    I did take a look at the draytek setup but as the 3CX server in hosted with a direct WAN IP I didn't think it was relevant.

    I have tried using stunserver.org in the STUN config but this didn't make any difference either.

    I'm really at a loss here...

    HOWEVER: When running the Remote Firewall / NAT Test utility I get this when it tries to do the "Echo Call Back"
    [With or Without STUN]

    ERROR: Callback test failed. Incoming call from the callback extension has not been received
    Possible causes:
    1. SIP ALG or a SIP Proxy has been detected between this computer/network and the target 3CX PhoneSystem. This will cause problems.
    SIP ALG needs to be disabled or the Proxy needs to be removed/fixed.
    Check the firewall's user manual on how to disable any running SIP ALG functionality or contact the firewall's support department.
    2. 3CX Phone System might have an incorrect configuration.
    Confirm that 3CX Phone System has a public Static IP Address - does not change and Not dynamic - changes.
    Confirm that the network interface is correctly configured by accessing the 3CX Management Console > Settings > Network Settings> Stun Server and that the public ip address is correctly entered.
    Disable Stun in this case and run the test again.
    3. Confirm that you have performed the 3CX Phone System Firewall checker and that the test passes completely.
    To do this access the 3CX Management Console and go to General Settings > Firewall Checker > Run Firewall Checker.
    4. The firewall of this network from where the 3CX firewall Checker is running is very unreliable and unable to remember port mappings and keep them open.
    At this stage it would be best to use 3CX Tunnel, 3CX Session Border Controller or try and switch to TCP Traffic instead of UDP as this will help keep the port mappings open.
     
Thread Status:
Not open for further replies.