Remote Extensions

Discussion in '3CX Phone System - General' started by haywardi, Mar 7, 2011.

Thread Status:
Not open for further replies.
  1. haywardi

    Joined:
    Feb 27, 2011
    Messages:
    83
    Likes Received:
    0
    Hi

    Can someone advised please.

    I'm trying to connect a physical SIP phone in a remote site to my PBX, but I can't get it to register.

    Firstly I'm using a fixed IP address.

    On my router I then set a static route to my PBX internal IP address for port 5090 (I also set a static route for port 5481 so I could administer the PBX when off site).

    At the remote site, I set the phones registration & proxy server to my public IP address and told it to use port 5090 as indicated in the documentation.

    But it wouldn't register.

    I then connected to the PBX (via port 5481) to check the server log. But there was no entry saying that it had even received a request to register the remote phone. At this point I would attached the server log, but as it says nothing I couldn't see the point.

    Now my question, it's probably something very simple that I've forgotten to do, but what is it?

    Any help gratefully received.

    Thanks in advance
    Iain
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,356
    Likes Received:
    224
    You should not be using port 5090 unless the remote phone is using the tunnel feature (3CX phone and 3CX SIP proxy). You can have that forwarded, in addition to the other ports, at the 3CX end in anticipation of using that feature. Normal SIP set up messages will use port 5060. The remote phone (if it is behind a router) should be set to use STUN or you will probably have audio problems. More on the additional ports that you will need to forward...http://www.3cx.com/blog/voip-howto/firewall-configuration-overview/
     
  3. haywardi

    Joined:
    Feb 27, 2011
    Messages:
    83
    Likes Received:
    0
    Hi Lee,

    Thanks for the pointer, think I may ave misinterpreted the set up instructions as I read that remote extensions needed 5090. My mistake!

    Will reconfigure tomorrow and try again.

    Thanks for the help.

    Iain
     
  4. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    As Leejor said - 5060 is the registration - 5090 is tunnel.

    Also be careful as some phones (such as some Linksys) like to have the internal and external ip when they are used as a remote extension.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. sigma1

    sigma1 Active Member

    Joined:
    Nov 20, 2009
    Messages:
    542
    Likes Received:
    1
    If you plan on using the 3CX Proxy Tunnel on a computer at the remote site, then port 5090 is perfect and you did well. I strongly encourage you to use this. If you plan on using a direct phone connection, make sure that port 5060 UDP is pointed to your PBX as well as 9000-9050 UDP. Are you using SIP trunks? is so you will have this in place already for them to work.

    Routers at remote locations can be a problem, the Proxy Tunnel is a quick fix but if you like a challenge please keep in mind:
    The remote router should support full cone NAT, make sure you use STUN, follow carefully the 3CX directions for the phone chosen. Some phones, such as the Cisco 504G have certain limitations as remote phones.

    PM me if you need any help as we do remote phones all day long.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,356
    Likes Received:
    224
    Which ones would that be? I've used a number of them and the only change I've ever made, when the ATA/Phone is used as a remote, is enabling STUN and letting it use DHCP rather than a fixed IP.
     
  7. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    I had a 3102, a PAP2T and an SPA942 all want it. Maybe it was older firmware as we don't play with them too much these days.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,356
    Likes Received:
    224
    I've used all 3 both remote and local. The FXO on the 3102 is best used when the 3102 has a public IP rather than behind a router, but I've never had to put the public IP in the devices. That's including an older SPA1001 and SPA3000
     
  9. sigma1

    sigma1 Active Member

    Joined:
    Nov 20, 2009
    Messages:
    542
    Likes Received:
    1
    Please correct me if I am wrong but a 3102 is a FXO/FXS adapter and NOT a phone. As Leejor stated, we used all of them and I have yet to find one that needs us to enter the public address manually. Stun works well (I will admit that some have DNS resolution issues and then you ned to use IP:pORT in the STUN field).Maybe you are talking about Polycom phones (no STUN feature but you could manually map public IP and ports).
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. haywardi

    Joined:
    Feb 27, 2011
    Messages:
    83
    Likes Received:
    0
    Hi Everybody,

    Thank you for your assistance.

    I eventuality found my problem and it was a mixture of

    A) The firewall not being set up properly. So Thank you Lee.

    B) I was using a DRAYTEK 2820IPPBX as my router (don't ask why I'm not using this as an IPPBX because I get very upset :) However, after setting up the fire wall as recommended, my remote phones still wouldn't connect. Then a brain wave (probably obvious for most people). The 2820 IPPBX also uses 5060 for SIP registrations.... So my phone were trying to register to port 5060 on the DRAYTEK not 3CX. A simple change to the 2820 to set its sip port to 6060 and a reboot and as if by magic, my remote phones started connecting......

    Once again, many thank to everybody who contributed and helped a poor newbie...

    Iain
     
Thread Status:
Not open for further replies.