Remote provisioning of Cisco SPA504G

Discussion in '3CX Phone System - General' started by aspect, Jul 24, 2017.

Thread Status:
Not open for further replies.
  1. aspect

    Joined:
    Dec 3, 2008
    Messages:
    9
    Likes Received:
    0
    Hi,

    We are moving a customer to a different hosted platform, currently they use Cisco spa504g handsets and are connected via a VPN and so are provisioned in LAN mode.

    We are struggling to provision these either by SBC or STUN.. the platform they are moving to doesn't support vpn implementation, the 3CX instance is v15.5 on Linux.

    The SBC is working fine and can provision other handsets but the Spa504G doesn't appear for PnP provisioning.

    STUN Provisioning also doesn't work.

    I can browse to the provisioning URL and view the XML so I know 3CX is generating the correct provisioning output and that these can be accessed.

    Any ideas folks?

    Thanks
     
  2. Telcreek

    Joined:
    Dec 30, 2016
    Messages:
    27
    Likes Received:
    2
    Hi. The Cisco SPAs are not listed as a supported phone for remote provisioning, SBC or STUN. It's my understanding that it's primarily because of an inflexible root certificate, since this is done over SSL only. I'd love to learn if that's not the only issue. I think you are stuck using either local again over a VPN, manually registering each or going with all new phones.
     
  3. aspect

    Joined:
    Dec 3, 2008
    Messages:
    9
    Likes Received:
    0
    That was pretty much 3CX's response too but I read something interesting here posted by choksw about provisioning end of live phones and the Spa 504Gs in particular.

    https://www.3cx.com/community/threads/spa-504g-and-v15-provisioning.46129/

    He suggested editing the nginx.conf file which will allow the handset to be provisioned remotely by including the WAN IP of the remote office.

    the problme I've got is the block he is suggesting to edit doesn't exist in our current implementation (V15.5 Debian).

    If anyone could shed any more light on this process I'm all ears though.
     
  4. Blair Shock

    Joined:
    Jul 26, 2017
    Messages:
    2
    Likes Received:
    0
    the nginx.conf is located in /var/lib/3cxpbx/Bin/nginx/conf

    The block you are looking for is here:

    server {
    add_header X-Frame-Options "SAMEORIGIN";
    listen 5000;
    server_name obfuscated.3cx.us;
    server_tokens off;

    access_log off;
    error_log /dev/null crit;

    allow 192.168.0.0/16;
    allow 172.16.0.0/12;

    Add your local ip address below the other 'allow' flags but before the deny all flag.
     
  5. aspect

    Joined:
    Dec 3, 2008
    Messages:
    9
    Likes Received:
    0
    Thanks for that, I've made the change. I'll try provisioning this again now.

    What is the nginx.conf settings for, does it dictate which LAN phones can be provisioned unsecurely to remote pbx instance by http instead of https? or have I got this wrong.

    Thanks,
    Tim
     
  6. aspect

    Joined:
    Dec 3, 2008
    Messages:
    9
    Likes Received:
    0
    The phone is now provisioning correctly and has picked up the relevant settings from the Extension but will not register, just states 'not registered' with orange lights on all the blf keys.

    Any ideas folks?
     
  7. boomschtick

    Joined:
    Sep 11, 2012
    Messages:
    51
    Likes Received:
    8
    I'd also love to be able to do this with the SPA525G2... :/
     
Thread Status:
Not open for further replies.