Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Routing SIP signaling message to a WAN emulator

Discussion in '3CX Phone System - General' started by abhishek, Mar 28, 2011.

Thread Status:
Not open for further replies.
  1. abhishek

    Joined:
    Mar 28, 2011
    Messages:
    1
    Likes Received:
    0
    Hello Everybody,

    I have implemented a set up where 3CX SIP client has to send SIP signaling messages to a WAN emulator. The WAN emulator (creates packet loss, delay etc) then forwards the signal to the SIP server. For this I added a route "route add 192.168.10.1 mask 255.255.255.255 192.168.20.4" in command prompt of windows machine where my SIP client is installed. Here 192.168.10.1 is my SIP server and 102.168.20.4 is my WAN emulator.

    I noticed that the SIP invite does not initiate when I add the above route. The SIP invite initiates after I remove the static route from windows machine. Ex: When I dial a remote extension "200" , the 3CX phone gives me an error "Destination not found" .
    I took a wire-shark trace and observed that I am receiving "SIP 404 not found error".Correct me if I am wrong but I guess there is problem with the SIP server(asterix).

    Can some one help on this. TO route SIP signaling messages through a emulator and then to the SIP server.
    Note: SIP clinet , router interface 1, and WAN emulator are connected to a switch. Router interface 2 is connected to SIP server.

    Any help on this is highly appreciated!!! Many Thanks

    Abhishek
     
Thread Status:
Not open for further replies.