Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

RTP Packets always set to true

Discussion in '3CX Phone System - General' started by TerryJoyce, Jul 15, 2011.

Thread Status:
Not open for further replies.
  1. TerryJoyce

    Joined:
    Apr 15, 2011
    Messages:
    11
    Likes Received:
    0
    Hello,

    I am having an issue with my SIP trunk service. They have said that the 3CX system is always sending every RTP event with the marker bit set to true. Is there any way to get 3CX to set the first marker as true and all subsequent packets as false?? Or is my SIP Supplier talking crap?? They are Broadvox.

    A bit of background is that when I am trying to dial into a service so the call connects then you type a set of numbers to a few locations the DTMF tones are not being picked up correctly and they say that this is the cause.

    Terry
     
  2. varietel

    Joined:
    Oct 29, 2010
    Messages:
    22
    Likes Received:
    0
    What kind of phone(s) are you using? Are you using any ATAs for connection? I had a similar experience using some old Polycom phones. The problem was not the SIP provider or the 3CX. If I understand the scenario from your description the Event Marker bit should be set to true.

    Regards,

    Roger Partovi
    Varietel Communications
    3CX Certified Partner
    801-889-1414
    roger@varietel.net
     
  3. TerryJoyce

    Joined:
    Apr 15, 2011
    Messages:
    11
    Likes Received:
    0
    I am using Cisco 500 series phones.

    Where do I set the event markers??
     
  4. varietel

    Joined:
    Oct 29, 2010
    Messages:
    22
    Likes Received:
    0
    I do not know of any place that you can set the event marker yourself. Based on the RFC being used by the phone it should be set properly. I am not familiar with Cisco 500s but in my case one dtmf capability in the sip.cfg file was not enabled for a model of Polycom that I was using. So it was working for making calls and sending dtmf after call connection (for use in IVRs) but it was not working for sending dtmf to activate an overhead pager. Can you check the config file for the Cisco 500? I did google search for Cisco 500 series dtmf and there are multiple posts for dtmf issues with these series of Cisco phones. Have you checked them to see if they are similar to your problems?

    Take care,

    Roger Partovi
    Varietel Communications
    Certified 3CX partner
    801-889-1414
    http://www.varietel.net
     
  5. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,825
    Likes Received:
    2

    Hi Terry,

    this type of question requires additional information and cannot be discussed using generic words/sentences.
    The problem has been described using definitions which are existing on the very low level of protocol stack, so the wireshark capture of the network traffic is required for investigation.

    Thanks

    P.S. Make a wireshark capture on the PBX host. Please don't post it on the forum because it may contain private information. Send it only using e-mail and only to the person you can trust.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.