Sangoma A200 4-port NBE 4 template in SP2

Discussion in '3CX Phone System - General' started by joshrose26, Jul 23, 2011.

Thread Status:
Not open for further replies.
  1. joshrose26

    Joined:
    Jul 18, 2011
    Messages:
    7
    Likes Received:
    0
    I'm having issues using this new template, whenever I try to restart the gateway after generating a new config file I get.

    XML file is not valid: GWRoutingRuleParser::parseXML; Parsing error: xml_rules_routing::parse() called on wrong xml node

    The NBE gateway manager also presents an error with the same language.

    I've been able to use the NBE 2 template to get the device to take incoming calls (still running NBE 4, as I can't find a download link anywhere to V2), but I must configure it to answer on first ring. The system works just fine configured this way with the exception of caller ID of course.

    I've tried comparing the old and new routing-rules.xml but can't seem to find what is causing the validation to fail.

    Not sure if anyone else has experienced this.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. Julien Nephtali

    Joined:
    Jun 7, 2010
    Messages:
    3
    Likes Received:
    0
    Hi Josh,

    I work at Sangoma.

    Can you open a ticket with our tech support at techdesk@sangoma.com.

    Please send us your /config and /log folder zipped and a copy of your old routing-rule file.

    Best Regards,

    Julien
     
  3. joshrose26

    Joined:
    Jul 18, 2011
    Messages:
    7
    Likes Received:
    0
    Julien,

    Thanks for your help!

    I've been working with a gentlemen named Ben today (super nice guy).

    I just zipped up the files you mentioned and replied with the ticket number in the email. (09887)

    The main issue I'm having now, is no matter how I configure it I can't get it to receive caller ID, if I configure the card to answer on first ring it works fine. If I have it answer after N rings (when N > 1) or wait until caller-ID the caller gets silence for 15 seconds before the call is dropped.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. joshrose26

    Joined:
    Jul 18, 2011
    Messages:
    7
    Likes Received:
    0
    Starting to feel a bit desperate.

    After spending considerable time on the phone with both 3CX and Sangoma.

    I reimaged my box with Windows Web Server 2008 32 bit and only loaded Netborder Express 4.1.4 and 3CX V10.

    I used the A200 4 Port PCI template (not the NBE 4 template) and get the same result. I'm unable to set the card to wait for caller ID. If I set it up to answer on the first ring the system works.

    My next step is to try a different server, not sure where to go from here.

    This is my first 3CX implementation so I'm a bit green, but I'm wondering if I'm going to have to roll back to asterisk or buy a different PSTN gateway device.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. joshrose26

    Joined:
    Jul 18, 2011
    Messages:
    7
    Likes Received:
    0
    It should be noted that Julien and Ben of Sangoma have been incredible in trying to figure out what is going on with our system.

    Not to be a blatant advertisement, but when someone gives me great support I like to share it!

    What we ended up having to do with our system was to disable battery polarity inversion in NBE.

    Configuration > PSTN config > call control > analog configurations > FXO-Config > Disconnect supervision info > uncheck Battery Polarity Inversion

    It worked like a champ!

    Hope this helps other folks! I can't thank Julien and crew at Sangoma enough for their help.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.