Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Sangoma A400 is not registered to 3CX

Discussion in '3CX Phone System - General' started by muhammed, Dec 31, 2012.

Thread Status:
Not open for further replies.
  1. muhammed

    Joined:
    Dec 31, 2012
    Messages:
    5
    Likes Received:
    0
    Hello All,

    I have Sangoma A400 4 FXO port with PCI. i installed netborder express, and istalled the drivers. in netborder express, my gateway is running. in 3cx, i created a gateway for my sangoma card. . my sangoma card in 3cx ; 4 port : 10000, 10001, 10002, 10003. and i created an extension for my sangoma phone number .phone number : 16, 17, 18, 19. for 10000 port, i routed it "connect to extension : 16". for 10001 port i routed it "connect to extension : 17". for 10002 port i routed it "connect to extension : 18".for 10003 port i routed it "connect to extension : 19". for the extension 16, i set up the authenticcatin ID: 10000 and password 123. for the others i set up the same. the problem is, my extensions are not registered. where is the error? why not registered.
     
  2. sigma1

    sigma1 Active Member

    Joined:
    Nov 20, 2009
    Messages:
    542
    Likes Received:
    1
    Wireshark is your friend (please post log and capture).
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,113
    Likes Received:
    329
    I must be missing something. You mention the Sangoma FXO (trunks), all well and good, but what are you using as extensions, the ones that are not registering?
     
  4. muhammed

    Joined:
    Dec 31, 2012
    Messages:
    5
    Likes Received:
    0
    In fact, i don't know the system very well. in te past i used a voip gateway, that is communicate with IP. I was creating extensions for it. for the sangoma, doesn't need the extension? if i don't need the extension, how can i see the communication with 3cx and sangoma?
     
  5. sigma1

    sigma1 Active Member

    Joined:
    Nov 20, 2009
    Messages:
    542
    Likes Received:
    1
    Each port does have an "extension" you are correct.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. muhammed

    Joined:
    Dec 31, 2012
    Messages:
    5
    Likes Received:
    0
    i foun something. after the created my sangoma gateway to 3cx, i generated the config file. i changed the name "routing-rule". i put it to "C:\Program Files\Netborder\Express\Gateway\config". after that. i restart tge my sangoma gateway. configuration synched is green and the gateway is running. Then i checked Configuration/Routing Rules in the gateway. when i click "Submit changes". there is an error that is " File not saved!XML file is not valid: GWRoutingRuleParser::parseXML; Parsing error: xml_rules_routing_rules::parse() called on wrong xml node" so, something is wrong. 3CX created wrong config file. why? what can i do? how can i solve?
     
  7. muhammed

    Joined:
    Dec 31, 2012
    Messages:
    5
    Likes Received:
    0
    this is still alive problem. please help me!!!
     
Thread Status:
Not open for further replies.