Scheduled restore not functioning properly on backup server

Discussion in '3CX Phone System - General' started by nenglish, Sep 22, 2016.

Thread Status:
Not open for further replies.
  1. nenglish

    Joined:
    Jul 21, 2016
    Messages:
    10
    Likes Received:
    2
    We have 3CX v14 SP3 set up in Failover mode with an active and passive server. Both servers are VM's with a host OS of Hyper-V Server 2012 R2 and guest OS Windows Server 2012 R2 (they reside on separate physical machines). The active server is scheduled to take a backup every night and then sends a copy to the passive server. The passive server is scheduled to restore itself using that backup every night. The first night everything worked great, then the next night the passive server did not restore. I checked the active server and the backup was successful, then I checked the passive server and the backup was sent successfully. The problem was the scheduled restore did not happen.

    After trying a few things I discovered that the passive server will only automatically restore itself one time when the settings are saved. On the second night (and every night thereafter) it will do nothing. I've got a workaround where I log into the passive server each morning and re-save the Restore Schedule settings (changing nothing, just click save). If I don't do this then the restores stop happening.

    I've searched the forums and the internet for people having a similar issue, but I haven't come across anything yet. If anyone has a solution I'd greatly appreciate it.
     
  2. nenglish

    Joined:
    Jul 21, 2016
    Messages:
    10
    Likes Received:
    2
    Just in case anyone else is having a similar problem you can use the RestoreCmd.exe that is located in C:\Program Files\3CX Phone System\Instance1\Bin (Default installation path for v14). The syntax you want is:

    RestoreCmd.exe --file="location of backup" --failover

    Throw that in a batch file and use task scheduler to have it run when you want.
     
Thread Status:
Not open for further replies.