Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

send voice mail notification by email

Discussion in '3CX Phone System - General' started by gonzo__007, Feb 3, 2009.

Thread Status:
Not open for further replies.
  1. gonzo__007

    Joined:
    Nov 11, 2008
    Messages:
    44
    Likes Received:
    0
    hi all,

    i'm trying to receive an e-mail when I have a voice mail.
    im using the e-mail account given by my ISP.
    let say my e-mail is joe@isp.com and pop3 and smtp servers are mail.isp.com

    In 3cx I set up the mail server options:
    mail server: mail.isp.com
    username: joe
    pass: joespass
    e-mail: joe@isp.com

    this way I guest that 3cx will use my e-mail account (joe@isp.com) to send me an e-mail to myself (joe@isp.com)

    but it does not work. is there something I did not understand ?

    thanks
     
  2. discovery1

    discovery1 Member

    Joined:
    Aug 4, 2008
    Messages:
    355
    Likes Received:
    0
    Does your ISP require authentication before sending email?
    Many ISP's do not - try changing the settings to not use authentication.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. gonzo__007

    Joined:
    Nov 11, 2008
    Messages:
    44
    Likes Received:
    0
    I tried without user/password and still not working.

    I'm looking at my firewall logs and I don't even have a log for a smtp connection... so I guest that 3cx does not even send it...
     
  4. gonzo__007

    Joined:
    Nov 11, 2008
    Messages:
    44
    Likes Received:
    0
    logs in 3cx are not giving lot of info...

    10:37:10.187 [CM504008]: Fax Service: registered as sip:888@10.7.254.3:5060 with contact sip:888@10.7.254.3:5100;user=phone

    10:34:47.187 [CM504004]: Registration succeeded for: 10000@unlimitel

    10:34:46.921 [CM504003]: Sent registration request for 10000@unlimitel

    10:34:33.578 [CM503008]: Call(4): Call is terminated

    10:34:33.578 [CM503008]: Call(4): Call is terminated

    10:34:19.390 [CM503007]: Call(4): Device joined: sip:999@127.0.0.1:40600;rinstance=8aec9e06835a2757

    10:34:19.375 [CM503007]: Call(4): Device joined: sip:514xxxxxx@209.217.98.194

    10:34:19.375 [CM505001]: Ext.999: Device info: Device Identified: [Man: 3CX Ltd.;Mod: 3CX IVR;Rev: General] Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [3CX IVR] Transport: [sip:127.0.0.1:5060]

    10:34:19.359 [CM503002]: Call(4): Alerting sip:999@127.0.0.1:40600;rinstance=8aec9e06835a2757

    10:34:18.859 [CM503004]: Call(4): Calling: Ext:Ext.999@[Dev:sip:999@127.0.0.1:40600;rinstance=8aec9e06835a2757]

    10:34:18.859 [CM503010]: Making route(s) to <sip:201@10.7.254.3:5060;user=vmail>

    10:34:18.859 [CM505003]: Provider:[unlimitel] Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [HMNet SIP 1.02] Transport: [sip:10.7.254.3:5060]

    10:34:18.843 [CM503001]: Call(4): Incoming call from 514xxxxxxx@(Ln.10000@unlimitel) to <sip:201@10.7.254.3:5060;user=vmail>

    10:34:17.812 [CM503012]: Inbound office hours rule (514xxxxxxx) for 10000 forwards to VM:201

    10:32:10.078 [CM504008]: Fax Service: registered as sip:888@10.7.254.3:5060 with contact sip:888@10.7.254.3:5100;user=phone

    10:31:48.062 [CM503008]: Call(3): Call is terminated
     
  5. discovery1

    discovery1 Member

    Joined:
    Aug 4, 2008
    Messages:
    355
    Likes Received:
    0
    Try to telnet from a command prompt to the isp mailserver to make sure port 25 is not blocked.
    telnet isp.com 25

    You should get a response if 25 is not blocked.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. gonzo__007

    Joined:
    Nov 11, 2008
    Messages:
    44
    Likes Received:
    0
    i'm able to send a mail using telnet

    telnet mail.myisp.com 25
    helo patato.com
    mail from:joe@patato.com
    rcpt to:me@myisp.com
    data
    subject: allo
    text line 1
    text line 2
    .

    and I receive it.

    when I send the mail in command line I see it in my firewall logs, but when I leave a voice mail, I have no smtp connections in the firewall logs.

    do I forget something to configure ?

    I did 2 changes:
    1: in my ext201 I select the option to send a notification for voice mail
    2: in general option, mail server tab, I put my smtp server and reply to address (witch is my e-mail adresse that my ISP gave me)

    I tried with and without user/password and same problem, no outbound smtp connection in firewall logs
     
  7. gonzo__007

    Joined:
    Nov 11, 2008
    Messages:
    44
    Likes Received:
    0
    my gold with this is to have a mail sent to my ISP e-mail address.

    then, have outlook express always open to receive those e-mail and forward them using a rules, to my hotmail account

    can it cause a problem to have outlook open ?

    I know both are using port 25 but when I do my testing outlook is closed.

    can it cause a problem to have a mail account configured even if outlook is closed ?
     
  8. Pentangle

    Pentangle Member

    Joined:
    Dec 6, 2007
    Messages:
    261
    Likes Received:
    0
    If you're relying upon Outlook Express rule forwarding to forward mail, and you've got Outlook Express closed, it's not going to forward anything. It's also not going to have received the email from the ISP until it's started and running.

    Why don't you just set the recipient email address of the voicemail to your hotmail address anyway?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. gonzo__007

    Joined:
    Nov 11, 2008
    Messages:
    44
    Likes Received:
    0
    I know that...
    i'm doing it step by step.
    first step is to receive an e-mail in my ISP account.

    when this will works, I will then try to forward to my hotmail account

    I don't do it directly with hotmail cuz it does not work. hotmail does reverse DNS for mails, and I have a dynamic IP at home and no domain, so no MX record....
    but my ISP have all that. so that wy I want 3cx to sent the e-mail to my ISP then I will forward it to my hotmail account

    anyway... 3cx does not send the email... how can I fix that ?

    thanks
     
  10. gonzo__007

    Joined:
    Nov 11, 2008
    Messages:
    44
    Likes Received:
    0
    also... it runs on windows XP sp3, firewall turned off
     
  11. Pentangle

    Pentangle Member

    Joined:
    Dec 6, 2007
    Messages:
    261
    Likes Received:
    0
    Get a copy of Wireshark and sniff the packets from that machine on port 25. That should tell you more about the process and any failure. I don't think the 3CX logs are adequate for troubleshooting the email side of things. All I can say is that my email delivery does work, so it's possible in v7 :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. gonzo__007

    Joined:
    Nov 11, 2008
    Messages:
    44
    Likes Received:
    0
    ok, I connect my ata, 3cx and a laptop on a 10mbps hub.
    I see trafic going from ata to 3cx when I place a call

    I create an ext with a rule that sends to voice mail when phone is not registred. I also set the ext to send a e-mail when a vmail is received.

    I saw nothing about smtp in wireshark.

    and please... how the hell do I set the filter to only show SMTP packet... I tried ip.proto == 53 to see dns request and nothing... I remove the filter and I can find dns request...

    thanks
     
  13. Cjay

    Cjay New Member

    Joined:
    Feb 24, 2007
    Messages:
    199
    Likes Received:
    3
    For SMTP it's as simple as 'port 25' in the Wireshark capture filter.
     
  14. Pentangle

    Pentangle Member

    Joined:
    Dec 6, 2007
    Messages:
    261
    Likes Received:
    0
    DNS isn't IP Protocol 53, it's a TCP or UDP session on port 53
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. gonzo__007

    Joined:
    Nov 11, 2008
    Messages:
    44
    Likes Received:
    0
    OK, I have been able to do a filter using "SMTP"
    I see my trafic in wireshark when sending a mail manually using telnet

    but nothing when I leave a voice mail

    help !!!
    I found the windows smtp service running. so I disable it. because it can cause conflict...
    any idea ?
     
  16. gonzo__007

    Joined:
    Nov 11, 2008
    Messages:
    44
    Likes Received:
    0
  17. Pentangle

    Pentangle Member

    Joined:
    Dec 6, 2007
    Messages:
    261
    Likes Received:
    0
    If you're not seeing port 25 traffic coming out of the server then no email session is even being started.

    First thing I would try is a backup and reinstall of the software and a check to make sure that port 25 was open.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  18. gonzo__007

    Joined:
    Nov 11, 2008
    Messages:
    44
    Likes Received:
    0
    ok, I will backup the config, uninstall 3cx, re install 3cx and restore config.

    port 25 is open in my firewall and allowed by my isp. im able to send an e-mail on command line (telnet mail.isp.com 25, helo, mail from:, rcpt to: data....)

    I will event try to re-install windows... just to make 100% sure....
     
Thread Status:
Not open for further replies.