Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Sending mail within 3CX

Discussion in '3CX Phone System - General' started by steve.davidson, Apr 27, 2015.

Thread Status:
Not open for further replies.
  1. steve.davidson

    Joined:
    Apr 2, 2015
    Messages:
    12
    Likes Received:
    0
    I've tried and failed to setup 3CX mailing [e.g. for 3CXPhone clients etc.]. I am running 3CX version 12.

    I have used the following:

    smtp.tools.sky.com
    on port 25
    with SSL/TSL ticked - Get the Error: Server does not support secure connection.
    with SSL/TLS un ticked - Get the Error: SMTP requires a secure connection....The server response was: 5.7.1 Authentication required.

    I've tried entering:
    smtp.tools.sky.com:465 [which is the correct port I use with Outlook]
    The sending email box in 3CX stays onscreen for ages and then, I get the Error: Failure sending mail. Unable to read data from the transport connection net_io_connectionclosed.

    I've also tried the above settings with smtp.live.com as well.

    Does anyone have any advice or could suggest an external smtp server that would work with port 25 and SSL/TLS. I'd rather not setup an internal smtp server.
     
  2. Leonidas 3CX

    3CX Support

    Joined:
    May 6, 2015
    Messages:
    12
    Likes Received:
    0
    Hello Steve,

    Please make sure that on your PBX management console under Settings>>General>>Mail server you have entered your username and password. The link below provides information regarding the issue you are facing:
    http://help.sky.com/articles/get-emails-on-your-windows-desktop-client

    Thank you,
    Leonidas
     
  3. steve.davidson

    Joined:
    Apr 2, 2015
    Messages:
    12
    Likes Received:
    0
    Thanks for the reply but, I've already got my sky account username and password in the PBX mail server section.

    The problem I have is that sky requires SSL so when I check this box in 3CX I need to specify the port as:

    smtp.tools.sky.com:465

    When I do this, 3CX hangs for ages when an email is sent and then returns the error identified in my initial thread. If I don't specify the SSL port [i.e. just use smpt.tool.sky.com] and un tick the SSL check box in 3CX, I get the "requires SSL connect" type error. All of the email accounts I use require SSL and therefore, I have to change the port in 3CX as described above. 3CX does not appear to like it when a port is specified. It appears to prefer to use the default mail port.

    Thus far, I've not been able to get any emails out of 3CX.
     
Thread Status:
Not open for further replies.