"sent by" field in invite message has wrong IP address

Discussion in '3CX Phone System - General' started by StewartLd, Jul 2, 2012.

Thread Status:
Not open for further replies.
  1. StewartLd

    Jul 2, 2012
    Likes Received:

    We've recently installed the 3CX system and are connecting to SIP trunks from a voip provider which authenticates outbound calls based on the IP address of the server. We've got a private static IP address on the server and use NAT and a STUN server. In most places in the messaging it now says the correct WAN IP but in the "sent by" field in the invite message it shows the server's lan address 192.1681.1.205. I've changed the IP address to present everywhere I can find in the 3CX but not sure how this particular field can be changed. A trace is below with the problem part it bold:

    Session Initiation Protocol
    Request-Line: INVITE sip:07833452145@81.xxx.xxx.130:5060 SIP/2.0
    Method: INVITE
    Request-URI: sip:07833452145@81.xxx.xxx.130:5060
    Request-URI User Part: 07833452145
    Request-URI Host Part: 81.xxx.xxx.130
    Request-URI Host Port: 5060
    [Resent Packet: False]
    Message Header
    Via: SIP/2.0/UDP;branch=z9hG4bK-d8754z-312ff9536938646d-1---d8754z-;rport
    Transport: UDP
    Sent-by Address:

    Sent-by port: 5060
    Branch: z9hG4bK-d8754z-312ff9536938646d-1---d8754z-
    RPort: rport
    Max-Forwards: 70
    Contact: <sip:2034354670@81.xxx.xxx.130:5060>
    Contact URI: sip:2034354670@81.xxx.xxx.130:5060
    Contact URI User Part: 2034354670
    Contact URI Host Part: 81.xxx.xxx.130
    Contact URI Host Port: 5060
    To: <sip:07833452145@>
    SIP to address: sip:07833452145@
    SIP to address User Part: 07833452145
    SIP to address Host Part:
    SIP to address Host Port: 5060
    From: "2034354670"<sip:2034354670@>;tag=6548ee63
    SIP Display info: "2034354670"
    SIP from address: sip:2034354670@
    SIP from address User Part: 2034354670
    SIP from address Host Part:
    SIP from address Host Port: 5060
    SIP from tag: 6548ee63

    81.xxx.xxx.130 is the correct external IP address of the server via NAT. is the static internal IP. is the voip provider's gateway.

    Any thoughts?


  2. craigreilly

    craigreilly Well-Known Member

    Feb 1, 2012
    Likes Received:
    Not sure where you have checked... but under VOIP Provider, Advanced - is registration settings.
    "Which IP to use in "Contact" field for registration.
    External (STUN)
    Specific: ______

    Also, Settings - Network - Public IP.

    I do not see Gamma as a current provider in the list in v11. But on the 3c site I found a document. I am not sure where this XML goes. Maybe the info inside will be helpful.
    http: //www.3cx.com/downloads/community/providers/gamma.pv.xml.zip - NO LONGER AVAILABLE
    I am assuming this is what you have already changed??

    On the "Port/Trunk Status" is the provider GREEN and Registered?
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. mixig

    mixig Member

    Dec 13, 2011
    Likes Received:
    Also check status messages for STUN in server activity log
  4. StewartLd

    Jul 2, 2012
    Likes Received:
    Thanks for your responses. Actually, looking at it more closely this morning with fresh eyes it seems that the IP address in the "from" field is actually the VOIP providers ip address (i.e. the same as the "to" address). I've got this adress in:

    VOIP provider>general>SIP Server or Hostname and the outbound proxy hostname on the same page.

    I've also got the correct "from" address set on VOIP provider>advanced>registration settings>spcified IP and settings>network>stun server>public IP to specify.

    I've tried with both the stun server on and off.

    I've no idea why it is putting the VOIP provide IP address in the from field...

    I'm very close to cancelling my account with the provider now and looking for one who authenticates by username and password...
  5. lneblett

    lneblett Well-Known Member

    Sep 7, 2010
    Likes Received:
    Here is the beginning of the link that Craig provided. It explains how to use the template that he linked to within this link.


    It may or may not help. There should really only be 3 IP addresses in use: 1) Your private IP which is the 3CX system, 2) Your public IP which is how the provider locates you and the firewall is set to port forward accordingly and 3) the provider IP. Proxies may be a different story. If the firewall is set correctly and passes the testing, then STUN should not be required; although some still prefer it.

    You did not indicate if a successful registration to the provider had been achieved. I think this is key so as to help understand where you are in the process.

    I am uncertain what generated the trace below. How the attributes are set in the credentials and registration details are what largely forms the SDP part of the messaging initially. As the systems negotiate, it is not uncommon for changes to occur to establish the connection. You likely can use wireshark and get a flow from the telephony portion to graphically see how the exchange between the systems (if any) is flowing which may then be used to further refine the troubleshooting aspect. You might also contact Gamma support and see if they have input to resolve; otherwise your best bet (assuming you want to change carriers) is to always use a supported carrier and failing that (due to cost, or other issues) ask on the forum for recommendations as to who others in your country (UK?) has had great success.
  6. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Jun 2, 2009
    Likes Received:
    if the provider checks this filed, then something is wrong already.
    there are 2 IPs they should check.
    1) the UDP from
    2) the Contact: <sip:2034354670@81.xxx.xxx.130:5060>
    any other filed is not right...
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. afinite

    Mar 11, 2012
    Likes Received:
    Did you get this sorted out?
    We're using the same VoIP provider and when we use the SIP ALG on our router, we get no reverse audio on outbound calls.

    I have turned this off now and am trying to get it working with using an ALG.
    I need to check, but I think Gamma telecom are returning 403 to me as the VIA header has our 3CX PBX's private IP in which I can't seem to replace.

    How did you get this resolved?
    Help most appreciated.
Thread Status:
Not open for further replies.