Server Error login v15.5 installed via express on google cloud

Discussion in '3CX Phone System - General' started by Frans Reijnen, Feb 5, 2018.

Thread Status:
Not open for further replies.
  1. Frans Reijnen

    Joined:
    Feb 5, 2018
    Messages:
    2
    Likes Received:
    0
    Hello,

    Yesterday evening I installed PBX with our license on google cloud platform via PBX Express. Then I configured a SIP trunk and some extensions.

    This morning I tried to login but I get a server error. The system is still running since calls are working.

    I found other posts related to this but no solution yet. How to solve this.

    Edit: I see it is version 15 instead of 15.5
     
    #1 Frans Reijnen, Feb 5, 2018
    Last edited: Feb 5, 2018
  2. Frans Reijnen

    Joined:
    Feb 5, 2018
    Messages:
    2
    Likes Received:
    0
    Restart of the VM in google cloud solved the problem.. but how is this happening?
     
  3. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,443
    Likes Received:
    282
    Hello @Frans Reijnen

    From the error i would assume that a service of the PBX stopped and you could not login.
    when the Vm was restarted the service started as well and you were able to log back in.
    The reason the service stopped will have to be investigated if it happens again. Please keep an eye on the system and report back if you face any further issues
     
  4. 3cxGoogle

    Joined:
    Feb 7, 2018
    Messages:
    2
    Likes Received:
    0
    I am experiencing the problem mentioned above using 3CX PBX Edition 15.5.6354.2 installed on Google Cloud Platform using https://pbxexpress.3cx.com/.

    The only fix I can offer at this time is to restart Google Cloud VM running 3CX (I need to restart daily). I will review my logs when I have a chance to try to find a fix which is better than daily VM restarts.

    Also please make sure you have manually configured Google Cloud Platform to use a static IP. 3CX will set you up with a dynamic IP using https://pbxexpress.3cx.com/ (as of of 2/7/18) and does not allow you to change your DNS A records in the 3CX Customer Portal.

    MANUALLY CONFIGURE STATIC IP IN GOOGLE CLOUD PLATFORM
    1. Go to the External IP addresses page in the GCP Console.
      GO TO THE EXTERNAL IP ADDRESSES PAGE

    2. In the Type column, change the address type to Static for the IP address you want to promote.
    3. Provide a name for the new static IP address and click Reserve.
     
  5. 3cxGoogle

    Joined:
    Feb 7, 2018
    Messages:
    2
    Likes Received:
    0
    It appears I have corrected this problem.

    Here's a list of tasks I performed:
    1) Upgraded Google Cloud machine from f1-micro (1 vCPU, 0.60GB) to g1-small (1 vCPU, 1.7 GB memory).
    2) Changed all default passwords. For my system this included extension passwords (Extensions > Authentication) and Admin Panel Password (Settings > Security > Credentials).
     
Thread Status:
Not open for further replies.