Services won't start after service pack upgrade

Discussion in '3CX Phone System - General' started by davmel, Oct 18, 2011.

Thread Status:
Not open for further replies.
  1. davmel

    Joined:
    Apr 26, 2010
    Messages:
    4
    Likes Received:
    0
    Whilst my installation of V10 works just fine without applying any service packs, as soon as I apply the SP 1.1 service pack and 3CX restarts, most of the services fail to start with the error:
    "System.InvalidOperationException: Cannot start service 3CXConferenceRoom on computer '.'. ---> System.ComponentModel.Win32Exception: The dependency service or group failed to start"

    What on earth is going on?? Why are the service packs killing my installation?
    I can't seem to find any explanation in the logs.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    10,752
    Likes Received:
    285
    Did you have 3CX running with success, previously (previous versions?). What type of system are you trying to install it on? Operating system, Processor, memory, etc.
     
  3. davmel

    Joined:
    Apr 26, 2010
    Messages:
    4
    Likes Received:
    0
    Yes, I had versions 8 and 9 (including service packs working fine before), but only the initial installed release of V10 works ok. As soon as I install any service pack on V10 most of the services won't start after 3CX restarts.

    Installation is on a Windows server 2008 R2 64 bit Foundation edition with SP1 installed and 8GB of memory on an Intel Xeon X3450 processor.
     
  4. LiscardGP

    Joined:
    Sep 29, 2011
    Messages:
    54
    Likes Received:
    0
    I had a similar problem after installing service packs, but I am running on low power dual core atom motherboard.

    Can you start the services manually?

    If so, I suggest you set all 3CX services to "Delayed start" from the windows management console services manager. I did this and it solved my start up problems. You just have to wait a few minutes longer, after rebooting, for the phone system to start working.

    Hope that helps.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. davmel

    Joined:
    Apr 26, 2010
    Messages:
    4
    Likes Received:
    0
    No, they just flat out refuse to start.

    I wish I knew what changes the first SP 1.1 upgrade makes because it clearly stuffs up the installation.
    I have no choice but to do a settings backup then uninstall completely and install again for it to work ok. I just have to put up with using the software without the fixes and improvements. It's a really stupid idea to not allow customers to download the latest version with service packs already included instead of having to manually update several times from within the software.
     
  6. Ricambi America

    Joined:
    Nov 10, 2007
    Messages:
    61
    Likes Received:
    0
    We had the same problem (or multiple problems) each time we tried to upgrade 3CX. We used to wait a few weeks after each software release, to see what new issues were being raised by the community. Once it seemed "quiet" here on the forum, we would do the upgrade. Sadly, we encountered drama after drama.

    We were licensed 3CX users from back around version 3, I think.... so quite a while. But 45 days ago, we just threw in the towel and gave up. We have switched to another full software based solution that installed flawlessly and has been working with 100% uptime (something we could never achieve with 3CX)

    I hope my post doesn't get censored. I'm not naming any competing products. I'll simply say that 3CX was too much on-going drama for an environment of 10 extensions (30% external), all this "proxy/tunnel" hullabaloo, teething trouble with Chrome browser, and the coup de grâce of Silverlight.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.