Setting outgoing Caller ID (MSN) on ISDN-Gateway

Discussion in '3CX Phone System - General' started by phuncity, Nov 20, 2007.

  1. phuncity

    Joined:
    Nov 20, 2007
    Messages:
    3
    Likes Received:
    0
    Hello! We're using the 3CX and a Patton 4552 VoIP-ISDN-Gateway. All outgoing calls are routed through the Patton (ISDN-Lines). We are now trying to define the outgoing Caller ID (MSN, subscriber ID) anywhere but it doesn't work. We didn't find any working solution in the Pattons Web-Config or 3CX - it always uses the default subscriber ID. In the 3CX-Config we can define an "outgoing caller ID number", but without any change in the shown outbound ID.
    Does anybody know where the settings for defining the outgoing subscriber IDs are located? And how the have to be set in order to work? Thanks a lot.
     
  2. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    0
    Please let us know the subscriber ID format.
    Which extension number mapped to subscriber ID?
    eg. 333 map to 123456 333
     
  3. phuncity

    Joined:
    Nov 20, 2007
    Messages:
    3
    Likes Received:
    0
    Hi, due to german standard ISDN-Lines, Internal Extension Numbers are completely different from the subscriber IDs. So there shall be many internal Extension Numbers (150,201,202,203,204...) place an outgoing call with subscriber ID 9407232 while others should use the subscriber ID 408442.
     
  4. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    0
    Please let me know your running 3CX version as well.
    Assume your default subscriber ID is 9407232
    Let's double confirm your issue. I guess all your out going calls to remote parties are show as 9407232 call in, right? If yes, please answer following mapping you will expected:

    150 => xxxxxxx
    201 => xxxxxxx
    202 => xxxxxxx
    203 => xxxxxxx
    204 => xxxxxxx

    If you using V31, the default calling party id should be same as your extension. There is no option at 3CX box for you to do the mapping. Therefore, the default calling party id will send to your Telco. As the calling party id mismatch your Telco's number range from your BRI line. So it will send the default ID 9407232 to all remote parties as caller ID. If your exactly issue like this, your Patton will help you to solve this issue.
     
  5. phuncity

    Joined:
    Nov 20, 2007
    Messages:
    3
    Likes Received:
    0
    Your're right - and I solved the problem! Thank you for your assistance. I tried so much yesterday but I didn't saw the mapping table ;-)
     
  6. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    0
    Good to hear your issue had been solved. The mapping table is at Patton gateway not at 3CX box. My problem is solved by this e164 calling number mapping. How about you?
     
  7. Niconutter

    Joined:
    Mar 28, 2008
    Messages:
    11
    Likes Received:
    0
    how you configure the outgoing call with the Matton 4552?

    Post example file.

    Thanks.
     
  8. 5qg4

    5qg4 Active Member

    Joined:
    Jan 31, 2007
    Messages:
    643
    Likes Received:
    0
    We are using 3CX “Generate config file” button to create the config file. If you still want the example config file for this device. Please refer to following URL:
    http://www.patton.com/voip/config_detail.asp?id=214
     

Share This Page