Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Setupconfig.xml not adding extensions/trunks

Discussion in '3CX Phone System - General' started by shedster99, Jan 8, 2018.

Thread Status:
Not open for further replies.
  1. shedster99

    Joined:
    Aug 3, 2009
    Messages:
    29
    Likes Received:
    0
    Evening all...have searched to no avail but I'm testing using an answer file based on the example on the 3CX website (https://www.3cx.com/wp-content/uploads/2016/11/setupconfig.xml) and placed it in the correct directory (C:\ProgramData\3CX\Data\setupconfig.xml)

    The pbxconfigtool picks this up and creates the PBX with the correct licence and operator extension etc but seems to totally ignore the extensions and the trunk in the .XML file.

    It does however pickup the outbound rules and creates this. I have looked in the log file and there's nothing apparent, no errors, nothing.

    Anyone else come across similar 'cos this would save me a loooooot of time ?

    Thanks in advance.
     
  2. shedster99

    Joined:
    Aug 3, 2009
    Messages:
    29
    Likes Received:
    0
  3. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,375
    Likes Received:
    84
    Can you paste the contents of the file you created? Without that it would be hard to help.

    Obviously leave out real names and trunk details as well as the license key, and any other personal data... Just need a sample file that exhibits the behavior you're describing.
     
  4. shedster99

    Joined:
    Aug 3, 2009
    Messages:
    29
    Likes Received:
    0
  5. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,375
    Likes Received:
    84
    Attached is a slightly revised version of the file. Change the extension of the file to .xml, I couldn't upload it otherwise, and try again.
    I think there might be a minor issue when placing the file in the C:\ProgramData\3CX\Data\ directory (extensions I aren't added), try loading it from the Web Config page and see.

    Let me know
     

    Attached Files:

  6. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,375
    Likes Received:
    84
    Just a small update, the issue that currently exists when placing the setupconfig.xml file into the directory will be resolved in the final release of V15.5 SP3.
     
  7. shedster99

    Joined:
    Aug 3, 2009
    Messages:
    29
    Likes Received:
    0
    Thanks Nick, just had time to test and your file works better insofar as the trunks are all good, inbound rules etc but the extensions still aren't.

    Look forward to SP3, thanks for the update.
     
Thread Status:
Not open for further replies.