Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Solved Shared Parking on Yealink T23G

Discussion in '3CX Phone System - General' started by Prometheus DBA, Sep 15, 2017.

Thread Status:
Not open for further replies.
  1. Prometheus DBA

    Joined:
    Mar 7, 2017
    Messages:
    54
    Likes Received:
    2
    Hi All,

    I'm a bit struggling with the shared parking option. My Yealink T23G has a couple programmable buttons and I want to use them for shared parking. I want one button to park a call, then when a call is parked that button must light up. I want to be able to use this same button to unpark a call.

    Can anyone tell me how to achief this?
     
  2. AndreasPo_3CX

    AndreasPo_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Aug 10, 2017
    Messages:
    138
    Likes Received:
    12
    Hello @Prometheus DBA ,

    what version of the PBX are you using? If you are on v15 and later, just go to extension->BLF and assign the shared parking you want on one of the phones BLFs. It will function as you described by default.
    -You receive a call
    -You press the shared parking BLF and this parks the call
    -The BLF changes state (green to red,lit up to blinking)
    -When you want to pickup the call, you just press that same BLF button to unpark the call.

    Hope this helps.
     
  3. Prometheus DBA

    Joined:
    Mar 7, 2017
    Messages:
    54
    Likes Received:
    2
    Hi Andreas,

    I use the latest version of 3CX and the latest version of the Yealink firmware. Autoprovision indeed does configure the buttons out-of-the-box, but when I try to put someone in SP1 the Yealink says, "Unavailable".
     
  4. AndreasPo_3CX

    AndreasPo_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Aug 10, 2017
    Messages:
    138
    Likes Received:
    12
    In order to troubleshoot further we might need to examine the activity log and see what is happening there.
    -Please set the PBX logging level to verbose (Dashboard->Activity Log->Settings) and restart all services to take effect.
    -Replicate the issue (make a call and try to park it)
    -Go back to Activity Log,filter by call
    -copy and paste the log into a text file and hide any public IPs or FQDN (sensitive information)
    -post the text file here so we can see what is going on.
     
  5. Prometheus DBA

    Joined:
    Mar 7, 2017
    Messages:
    54
    Likes Received:
    2
    This seems like the most important stuff, if you want I can upload the full log.

    09/15/2017 11:33:39 AM - SendMsg from <sip:*00SP1@my.3cx.server:5060>;tag=28653d43 to "User1"<sip:013@my.3cx.server:5060>;tag=66216113
    09/15/2017 11:33:39 AM - Call(C:57) is terminated
    09/15/2017 11:33:39 AM - [CM503020]: Call(C:57): Normal call termination. Call originator: Extn:013. Reason: Not found
    09/15/2017 11:33:39 AM - [CM503016]: Call(C:57): Attempt to reach <sip:*00SP1@my.3cx.server:5060> from Extn:013 has failed. Reason: Not Found
    09/15/2017 11:33:39 AM - [CM503014]: Call(C:57): No known route from Extn:013 to target: <sip:*00SP1@my.3cx.server:5060>
    09/15/2017 11:33:39 AM - Call(C:57): from Extn:013 to *00SP1 doesn't match any outbound rule. No outbound rule could be selected.
    09/15/2017 11:33:39 AM - [Flow] Target endpoint for *00SP1 can not be built!
    09/15/2017 11:33:39 AM - Looking for outbound rule: dialed = [*00SP1], processed: [*00SP1]; from-ext:
    09/15/2017 11:33:39 AM - [Flow] Building target endpoint to *00SP1 from "User1" <sip:013@my.3cx.server:5060>
    09/15/2017 11:33:39 AM - [CM503010]: Call(C:57): Making route(s) from Extn:013 to <sip:*00SP1@my.3cx.server:5060>
    09/15/2017 11:33:39 AM - Remote SDP is set for leg L:57.1[Extn:013]
    09/15/2017 11:33:39 AM - OnOffer from "User1"<sip:013@my.3cx.server:5060>;tag=66216113
    09/15/2017 11:33:39 AM - [CM505001]: Endpoint Extn:013: Device info: Device Not Identified: User Agent not matched; Capabilities:[reinvite, replaces, able-no-sdp, recvonly] UserAgent: [Yealink SIP-T23G 44.82.0.20] PBX contact: [sip:013@172.17.5.55:5060]
    09/15/2017 11:33:39 AM - Inbound DID: ''; Phonebook Name: ''
     
  6. AndreasPo_3CX

    AndreasPo_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Aug 10, 2017
    Messages:
    138
    Likes Received:
    12
    From the logs you sent i can see that the phone sends "*00SP1" instead of "SP1".
    If you go under Extensions->your extension->BLF , does the BFL you assigned look like this? (see screenshot below)
    upload_2017-9-15_13-45-9.png
     
  7. Prometheus DBA

    Joined:
    Mar 7, 2017
    Messages:
    54
    Likes Received:
    2
    This is exactly how it looks, sorry i cant upload the screenshot
     
  8. AndreasPo_3CX

    AndreasPo_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Aug 10, 2017
    Messages:
    138
    Likes Received:
    12
    I had a look at the logs again and i saw that you are using an unsupported firmware for that phone (44.82.0.20).
    Please try the following:
    -apply the latest supported firmware (44.81.0.110)
    -use the default template in case you are using a custom template for this phone
    -try shared parking again and see if the problem occurs.
     
  9. Prometheus DBA

    Joined:
    Mar 7, 2017
    Messages:
    54
    Likes Received:
    2
    Solution: apply the latest supported firmware (44.81.0.110)

    thank you for the support
     
  10. AndreasPo_3CX

    AndreasPo_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Aug 10, 2017
    Messages:
    138
    Likes Received:
    12
    Glad the issue was resolved!
     
Thread Status:
Not open for further replies.