SIP Invite - Outbound

Discussion in '3CX Phone System - General' started by David1921, Feb 5, 2018.

Thread Status:
Not open for further replies.
  1. David1921

    Joined:
    Feb 5, 2018
    Messages:
    6
    Likes Received:
    0
    Hello


    We are trying to set up a generic SIP provider, the Provider requires that the SIP outbound invite must have the from address as our 3cx server in order to do authentication. Currently the from address being sent is our outbound proxy address


    Is there anyway to change the from address manually to a specific IP?


    Thanks
     
  2. mariosM_3CX

    mariosM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Nov 1, 2017
    Messages:
    406
    Likes Received:
    38
    Hello @David1921

    Cannot guarantee that this will work, as we are not talking about a supported provider, but try changing the From : Host Part to "ContactUri" in the SIP trunk's Outbound Parameters.

    Hope this helps.
     
  3. David1921

    Joined:
    Feb 5, 2018
    Messages:
    6
    Likes Received:
    0
    Thanks MarioM_3CX

    I have tried this but it looks like it doesn't make a difference.
    The invite still sends the outbound proxy address instead, so I am out of ideas.

    The provider is Verizon so we can't actually ask them to authenticate on another parameter.
     
  4. mariosM_3CX

    mariosM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Nov 1, 2017
    Messages:
    406
    Likes Received:
    38
    If you try setting the From : Host Part to "Custom Field " and manually write the public ip of the PBX, is it working?
     
  5. David1921

    Joined:
    Feb 5, 2018
    Messages:
    6
    Likes Received:
    0
    No, it still sends the outbound proxy IP.
     
  6. IoannisM_3CX

    IoannisM_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Aug 10, 2017
    Messages:
    229
    Likes Received:
    18
    Hello @David1921

    as this will need some further investigation, can you please pm us a capture and your logs in verbose mode in order to see what exactly leaves from the PBX to your provider?
    Set the From : Host Part to "Custom Field " and manually write the public ip of the PBX as my colleague suggested and replicate the issue
     
  7. David1921

    Joined:
    Feb 5, 2018
    Messages:
    6
    Likes Received:
    0
    @ loannisM_3cx PM sent
     
  8. simply7

    Joined:
    Jan 4, 2016
    Messages:
    38
    Likes Received:
    18
    Restart the services after the change.
     
Thread Status:
Not open for further replies.