Solved SIP Provider through VPN

Discussion in '3CX Phone System - General' started by brisingr, Feb 21, 2018.

Thread Status:
Not open for further replies.
  1. brisingr

    Joined:
    Oct 11, 2016
    Messages:
    10
    Likes Received:
    0
    Hello,

    I am now facing a problem is that we have a line specific for sip through vpn to our sip provider which is not connected to internet.
    I use two network ports and set the default gateway to the internet one. Remain blank of the sip vpn one. I install 3cx on windows 10 so I use route table to force the sip provider ip go through vpn network. But when I use wiredshark to testify. Only the verify secession will go through vpn network. After 183 secession start RTP will all go through internet network. Should there has other setting I missed? Or I should change the parameters?

    Thanks for your help/
     

    Attached Files:

  2. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,443
    Likes Received:
    282
    Hello @brisingr

    Please find the guide with the supported network configurations here.
    Also navigate to your trunk settings / Options and under the option "Select which IP to use in 'Contact' (SIP) and 'Connection'(SDP) fields" use the IP of the network card the provider is connected to and see if that resolves your issue. 2018-02-21_16h34_34.png
     
    brisingr likes this.
  3. brisingr

    Joined:
    Oct 11, 2016
    Messages:
    10
    Likes Received:
    0
    Hello @YiannisH_3CX,

    Thanks a lot. Change the option works!
     
  4. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    4,443
    Likes Received:
    282
    Glad i could help :)
     
Thread Status:
Not open for further replies.