Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

SIP Trunk incoming OK, outgoing nothing

Discussion in '3CX Phone System - General' started by hfournier, May 11, 2012.

Thread Status:
Not open for further replies.
  1. hfournier

    Joined:
    Feb 24, 2012
    Messages:
    38
    Likes Received:
    0
    I'm finishing up my first 3CX installations and I'm down to my last two problems (I hope).

    I've configured a SIP Trunk provider (thinktel.ca) using the available template. The provider is registered and I can make incoming calls, but outgoing calls just go to dead air.

    Looks like the outgoing rule is working and routing the call properly to the SIP Trunk. The Server Activity Log shows:

    Code:
    11:13:33.856     [CM503008]: Call(25): Call is terminated
    11:13:30.899     Currently active calls - 1: [25]
    11:13:19.444     [CM503025]: Call(25): Calling VoIPline:2505551234@(Ln.10005@ThinkTel)@[Dev:sip:2505556789@208.xxx.17.52:5060]
    So it appears that the call is going out to the SIP Trunk provider, but then nothing happens. And my cell phone never rings. The user hung up after 3 seconds. So if I'm understanding the log properly, 3CX thinks the calls been made successfully.

    So I tried it again, but this time waited longer before hanging up. About 10 seconds after the "Currently active calls" line, I got:

    Code:
    [CM503003]: Call(28): Call to sip:2505551234@208.xxx.17.52:5060 has failed; Cause: 408 Request Timeout; internal
    Would the problem be with the SIP Trunk provider and not 3CX at this point? Authentication issue or something?

    FYI - I have a remote extension up and running in my home office and I can make/receive calls on it to/from other extensions at the Head Office (where 3CX is located).

    PS: Ran the firewall checker and everything is OK.
     
  2. leejor

    leejor Well-Known Member

    Joined:
    Jan 22, 2008
    Messages:
    11,079
    Likes Received:
    324
    It appears as if you are sending the 10 digits, but receiving no acknowledgement back, so 3CX is timing out.
    That could be a number of reasons.

    You are sending the request to the wrong "location" (IP/port)

    It's just not getting through the network, for some reason.

    The provider is not responding at all.

    The Provider is responding, but to the wrong IP (for some reason)
     
  3. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,545
    Likes Received:
    298
    may provider expects 11 digits?
    update outgoing rule to prepend a 1 to see if that helps?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. vipsnak

    Joined:
    Apr 23, 2012
    Messages:
    5
    Likes Received:
    0
    Hi
    change udp sip ports 5060 to other port secret ports
     
Thread Status:
Not open for further replies.