SIP Trunk Message Header sending local IP in Via: Field

Discussion in '3CX Phone System - General' started by commvisi, Apr 12, 2011.

Thread Status:
Not open for further replies.
  1. commvisi

    Joined:
    Aug 28, 2009
    Messages:
    17
    Likes Received:
    0
    Hi,

    We are having trouble connecting to a new SIP Provider and the problem appears to be that 3CX is sending our Internal IP in the Via: Field of the Invite Message Header.
    I have tried various settings and changes to Outbound Parameters for this proviser, but do not seem to be able to change this setting to our External IP.

    Packet Track is listed below. Internal IP of our 3CX server is 10.1.1.19

    Any help on this would be appreciated.

    Session Initiation Protocol
    Request-Line: REGISTER sip:(Provider IP):5060 SIP/2.0
    Method: REGISTER
    Resent Packet: False
    Message Header
    Via: SIP/2.0/UDP 10.1.1.19:5060;branch=z9hG4bK-d8754z-7609d943f51c726e-1---d8754z-;rport
    Max-Forwards: 70
    Contact: <sip:AuthID@(Our External IP):40664;rinstance=8f35cf72ed2bac26>
    Contact Binding: <sip: AuthID@(Our External IP):40664;rinstance=8f35cf72ed2bac26>
    URI: <sip: AuthID@(Our External IP):40664;rinstance=8f35cf72ed2bac26>
    SIP contact address: sip: AuthID@(Our External IP):40664
    To: <sip:AuthID@(Provider IP):5060>
    SIP to address: sip: AuthID@(Provider IP):5060
    From: <sip: AuthID@(Provider IP):5060>;tag=3f20a961
    SIP from address: sip: AuthID@(Provider IP):5060
    SIP tag: 3f20a961
    Call-ID: ZDg5ZmIwN2I4YjI0MzdlYTA1OWRmN2IwYzlkYzg2ZmQ.
    CSeq: 1 REGISTER
    Expires: 60
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REGISTER, SUBSCRIBE, NOTIFY, REFER, INFO, MESSAGE
    Supported: replaces
    User-Agent: 3CXPhoneSystem 9.0.15776.0
    Content-Length: 0

    Our SIP provider sees the following packet trace

    1 0.000000 (Our External IP)-> (Provider IP) SIP Request: REGISTER sip:(Provider IP):5060
    2 0.000209 (Provider IP) -> 10.1.1.19 SIP Status: 100 Trying (1 bindings)
    3 0.000263 (Provider IP) -> 10.1.1.19 SIP Status: 401 Unauthorized (0 bindings)
     
  2. smb1

    smb1 New Member

    Joined:
    Mar 18, 2009
    Messages:
    104
    Likes Received:
    0
    The problem is your router, not 3CX.

    Are you trying to use MyNetFone or Internode? This is a common problem with SIP trunks relying on IP authentication.

    Many mid-tier and even top grade routers do not handle the NAT process correctly for SIP headers.

    You should ensure you have any SIP helper or ALG functions disabled on your router. Failing that you need to either try and work out the issue with your router vendor or you may have to switch routers.

    Routers I have had success with are:
    Cisco 877
    Untangle (SIP Helper has to be enabled)
    Billion 7300 (not suitable for anything of 2-4 concurrent calls)
    Linksys WAG54G (SIP ALG DISABLED

    Routers I have had to give up on:
    Any Draytek
    Billion 7402 GXL

    Hope this helps.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.