Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Skype does not ask for allowing access

Discussion in '3CX Phone System - General' started by bolkar, Aug 20, 2010.

Thread Status:
Not open for further replies.
  1. bolkar

    Joined:
    Aug 5, 2010
    Messages:
    7
    Likes Received:
    0
    Hello,

    I recently installed the Skype gateway and it was working fine, except the terrible sound quality. Reading at the forums, I decided to add a master to see if it improves anything. However when I add the master account I was not able to get the skype popup to let me allow gateway to access skype.

    I uninstalled both the gateway and the skype and now when I add a skype port at the gateway and it starts the skype, it does not ask me if I want to allow gateway to connect skype (or whatever that is called). Now I totally lost the ability to create any Skype port at the gateway. If I close the skype the gateway shows the skype account however it does not go green, shows pending in definitely (obviously because it does not have access to skype).

    I tried uninstalling and installing many times nothing helps. I let is stay overnight thinking it may take some time, but nothing. Skype just stays there and the gateway windows shows "Connectings..." to skype account (on that little rectangle window that comes when you hit skype button on the gateway).

    Do you have any idea what prevents the gateway to ask for skype access?
     
  2. bolkar

    Joined:
    Aug 5, 2010
    Messages:
    7
    Likes Received:
    0
    I already have the Skype gateway defined, and it works fine. I don't have any problem in that part. My issue is Skype Gateway application does NOT make Skype to ask me to allow access. It just sits there reading connecting.
     
  3. dab

    dab

    Joined:
    Nov 1, 2009
    Messages:
    67
    Likes Received:
    1
    Did you install the "Business-Version" Skype MSI?
    If so uninstall and install the "Consumer-Version", the small setup which download the full client during installation.
    According to some info, only this version contains the necessary SDK components...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. flurk

    Joined:
    Sep 4, 2010
    Messages:
    19
    Likes Received:
    0
    Hello,

    I've wasted some time on making the skype gateway work. Elsewhere in this forum you can read about the cause of that.
    My experience is that sometimes you have to go through 3 cycles of starting skype / logging in / logging off / closing skype before it will detect and ask for permission for 3CX gateway to control the skype client.

    I hope this can help.

    greetings,
    Flurk
     
Thread Status:
Not open for further replies.