Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Skype for SIP

Discussion in '3CX Phone System - General' started by Jimboy Cabillo, Oct 5, 2010.

Thread Status:
Not open for further replies.
  1. Jimboy Cabillo

    Joined:
    Sep 24, 2010
    Messages:
    11
    Likes Received:
    0
    Ok, I am getting confused spending a whole day just to configure this Skype for SIP VoIP gateway.

    I have a fully working 3CX Phone System installed on a Windows XP machine. I had already tested that the phone system is working by setting up 3CX Gateway for Skype (http://www.3cx.com/voip-gateways/skype/) couple of weeks ago.

    My new job is to make this Skype for SIP working over the 3CX Phone System. I've reset all of the past 3CX Configuration and setup a new one.


    This is what I've done so far:

    •I'm using 3CX v.9!
    •Put the Windows XP machine where the 3CX Phone System was installed on a Public IP Address.
    •Configured my Polycom SoundPoint 320 SIP IP Phone and registered it to the 3CX Phone System with the extension number of 101. (http://www.3cx.com/sip-phones/polycom-soundpoint)
    •Setup a Skype Manager account and create a Skype SIP Profile including 1 Channel, Outgoing Calls, Caller ID & Incoming number/calls.
    •Successfully registered the Skype SIP Profile to my 3CX Phone System.

    Problem is, when I tried to call my Incoming number (or Caller ID, I don't know, I'm confused) provided by Skype using my landline I can only hear 2 ringing tones followed by a Disconnected tone on my landline phone but my SIP IP Phone with extension number of 101 did not rang at all. And when I use my SIP IP phone with extension number 101 to call a US-based cell phone, it immediately responses for a busy/disconnected tone.

    I had already got in touch with a Skype Chat Support and after couple of hours of our conversation, it only resulted that the real problem is within my end. They told me that they can also dial my Incoming number provided by Skype and heard it ringing on their side but after a couple of rings, the ringing also get disconnected.

    I have attachedthe most basic configuration that I've made on my 3CX Phone System & Polycom IP Phone.

    I'm getting this log when I tried to dial my Incoming number using my landline.
    --------------------------------------------------------------------------------------------
    12:29:20.265 Requests rate from IP 204.9.161.164 is too high! Blacklisted for 21 seconds
    12:29:20.265 [CM500002]: Unidentified incoming call. Review INVITE and adjust source identification:
    INVITE sip:13048810174@203.177.56.204:5060;rinstance=c8e92f5821d6c100;transport=udp SIP/2.0
    Via: SIP/2.0/UDP 204.9.161.164:5060;branch=z9hG4bK-775d7-4caaa965-f1c4014e-5b00bac4
    Max-Forwards: 30
    Contact: <sip:63024407586@204.9.161.164:5060;transport=udp>
    To: <sip:13048810174@sip.skype.com>
    From: <sip:63024407586@sip.skype.com>;tag=a4a109cc-13c4-4caaa965-f1c4014e-3ed741d7
    Call-ID: CXC-172-68089770-a4a109cc-13c4-4caaa965-f1c4014e-24ae8b71
    CSeq: 1 INVITE
    Allow: INVITE, ACK, CANCEL, OPTIONS, BYE
    User-Agent: SipGW 0.3.20
    P-Asserted-Identity: <sip:sip.skype.com>
    Content-Length: 0

    12:29:20.250 [CM302001]: Authorization system can not identify source of: SipReq: INVITE 13048810174@203.177.56.204:5060 tid=-775d7-4caaa965-f1c4014e-5b00bac4 cseq=INVITE contact=63024407586@204.9.161.164:5060 / 1 from(wire)
    ............................................................................................


    And this is what I'm getting when using my Polycom IP Phone to dial a US-based cell phone.
    --------------------------------------------------------------------------------------------
    12:36:16.406 [CM503020]: Normal call termination. Reason: Not available
    12:36:16.406 [CM503016]: Call(1): Attempt to reach <sip:0013046736492@203.177.56.204;user=phone> failed. Reason: Not Registered
    12:36:16.406 [CM503016]: Call(1): Attempt to reach <sip:0013046736492@203.177.56.204;user=phone> failed. Reason: Not Registered
    12:36:16.390 [CM503017]: Call(1): Target is not registered: Out.0013046736492{rule=Rule for Skype SIP}
    12:36:16.328 [CM503010]: Making route(s) to <sip:0013046736492@203.177.56.204;user=phone>
    12:36:16.312 [CM505001]: Ext.101: Device info: Device Identified: [Man: Polycom;Mod: SoundPoint IP Series;Rev: General] Capabilities:[reinvite, replaces, unable-no-sdp, no-recvonly] UserAgent: [PolycomSoundPointIP-SPIP_320-UA/2.1.2.0049] PBX contact: [sip:101@203.177.56.204:5060]
    12:36:16.296 [CM503001]: Call(1): Incoming call from Ext.101 to <sip:0013046736492@203.177.56.204;user=phone>
    ............................................................................................





    and for random reason, I'm getting this error on my log.
    --------------------------------------------------------------------------------------------
    12:53:15.890 Blacklisted (Too many failed auth)IP = 127.0.0.1:6060; Failed auth: 25; unauth: 26; auth: 25
    12:52:54.656 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=e078060004668e23 cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:52:33.140 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=e557423eff407733 cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:52:11.609 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=9c3da32f935de763 cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:51:50.093 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=42007a7b70178e15 cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:51:28.562 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=0d0ab717943ac72d cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:51:07.031 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=ec7b7b252c35d004 cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:50:45.515 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=5d2650220e38c655 cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:50:23.984 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=fb76d543b1198374 cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:50:02.453 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=ad23d31ad44b8d0e cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:49:40.937 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=9c201704321ab16f cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:49:19.406 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=5e5c8f48ed480a78 cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:48:57.890 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=f565776b9f137a78 cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:48:36.359 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=931294543112e553 cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:48:14.828 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=4605d115e336aa5e cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:47:53.312 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=f430c34e30013353 cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:47:31.781 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=511dd4756e338d21 cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:47:10.359 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=b571276659656a31 cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:46:48.828 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=fd1c784af4430031 cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:46:27.312 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=d86f8428593f9610 cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:46:05.781 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=3737b43d7561c921 cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:45:44.250 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=b0662e5dc21ccb4a cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:45:22.734 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=193f6f607e202929 cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:45:01.203 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=a7231c4fee37dc2c cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:44:39.671 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=4f10b577af7cb073 cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings
    12:44:18.156 [CM102001]: Authentication failed for SipReq: REGISTER 127.0.0.1:5060 tid=426e3e1a24404b4e cseq=REGISTER contact=10000@127.0.0.1:6060 / 2 from(wire); Reason: Credentials don't match, check that authorization-ID and password match the ones in extension settings


    Polycom SoundPoint IP320 SIP Line 1 Configuration from 3CX Site
    [​IMG]

    Extension 101 Configuration
    [​IMG]

    Skype for SIP VoIP Gateway/Trunk Configuration
    [​IMG]
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. RichardCrabb1

    RichardCrabb1 New Member

    Joined:
    Mar 7, 2009
    Messages:
    196
    Likes Received:
    0
    Hi Jimboy,
    Do you have source ID configured on the 3CX provider settings? You could try entering the DID number so that 3CX can identify what the call is for. I hope that helps.

    Kind regards
    Richard Crabb
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    It appears that your skype is not registered.

    Can you check the Port Status and see if it is showing green.

    And also check your ext 101 is registered.

    Not sure why you need to have your 3cx on a public dedicated ip on the xp machine.

    You also may have to change some of the default anti hacking settings, but leave it for the short term until you get the skype registered.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. Nick Galea

    Nick Galea Site Admin

    Joined:
    Jun 6, 2006
    Messages:
    1,971
    Likes Received:
    274
    I suggest ensuring using latest version 9 and use the Skype Connect product. This the business version of Skype that works with SIP and is supported by Skype. The Skype gateway product will be retired at some point soon.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. Jimboy Cabillo

    Joined:
    Sep 24, 2010
    Messages:
    11
    Likes Received:
    0
    @Richard Crabb

    That's what I'm also thinking, I really don't have an idea on what to do with that DID/DDI settings. Same with the Outbound and Inbound Rules.

    Maybe you guys can help me figure out this one.

    [​IMG]
    [​IMG]


    @Mark Shehan

    My Polycom IP Phone Extension (101) as well as the Skype for SIP Trunk were both registered and I am sure with it. Skype Connect also indicates that the SIP Profile was already registered on my PBX.


    @Nick Galea

    I believe I'm using v.9 as it already supports Skype for SIP Trunk. I do use Skype Connect and bought everything there that I might be needing.


    Thank you guys for the feedbacks,
    Jimboy
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    So you are guaranteeing that both the polycom and the skype connect are registered (Green lights on statuses).

    It is just your logs are saying otherwise.

    Can you make a call to and from the polyphone without going to skype? internal to internal or another voip provider?

    That will eliminate that part.

    Otherwise it would work for inbound as you have it.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. Jimboy Cabillo

    Joined:
    Sep 24, 2010
    Messages:
    11
    Likes Received:
    0
    @Mark Shehan

    I am a hundred percent sure that both my extension & VoIP provider are registered on my 3CX. I'd already talked to a Skype Chat Support and just pointed out that there's nothing wrong on their end.

    Last week, I tried the 3CX Gateway for Skype and it worked immediately and successfully just by following the steps as per 3CX. I also tried downloading 3CX Softphone and successfully dialed my Polycom IP Phone.

    This is what really happen when I dial on my IP Phone.

    When I dial a US-based number (+1 304 - 123 - 4567) it only resulted to a ring tone that is like it is disconnected or the number that I am dial is off.

    But when I dial my IP Phone with the Incoming number given by Skype Connect using my landline here in the office, I can hear it ringing on my landline phone twice but the IP Phone doesn't rang at all. And after that twice ringing, it suddenly gets disconnected.

    The Activity Log on my first post is appearing after my failed dialing.

    Hope you guys can help me with this, I really think it has something to do with the Incoming/Outgoing Rules.


    Thanks,
    Jimboy
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. abc123

    abc123 Active Member

    Joined:
    Nov 9, 2009
    Messages:
    712
    Likes Received:
    1
    I think we need to get a wireshark capture going on the 3cx machine to see where it is going wrong.

    Do you have it installed? If not, download it as it is free then run a capture while you make the incoming call. Then we can look at those logs.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.