skype outbound now failing

Discussion in '3CX Phone System - General' started by cogpartners, Apr 12, 2010.

Thread Status:
Not open for further replies.
  1. cogpartners

    Joined:
    Apr 12, 2010
    Messages:
    5
    Likes Received:
    0
    Skype Gateway Setup:

    This was working:
    10001 cog.partners with skype in main inbound (Master)
    10002 matt.girgenti with SkypeOut US/Canada Subscription
    10003 matt.girgenti with SkypeOut US/Canada Subscription
    10004 matt.girgenti with SkypeOut US/Canada Subscription

    Dialing Rules:
    if 10 digits, strip 0, append a 1
    turns aaa-bbb-cccc into 1-aaa-bbb-cccc

    This was working, except outboudn caller ID was 0000123456. I could not find anyway to get the outbound caller id to be the SkypeIn number (or any other # for that matter) so I hcanged to this:

    No Master
    10001 cog.partners with skype in main inbound AND SkypeOut US/Canada Subscription
    10002 cog.partners with skype in main inbound AND SkypeOut US/Canada Subscription
    10003 cog.partners with skype in main inbound AND SkypeOut US/Canada Subscription
    10004 matt.girgenti with SkypeOut US/Canada Subscription

    Now when I try to call out (using same dialing rules) I get an immediate fast busy signal and the log states: "failed. Reason: Temporarily Unavailable". I can still dial out if I route it to 10004, however any others fail. I did log into a skype client as cog.partners and made a call to my cell phone, so I know the outbound subscription is working.

    I placed another post earlier about the pros/cons of using the same skype account for multiple ports. I know skype allows multiple calls with one login so technically this should work fine, but there must be a reason for the "different skype account" instructions. That being said, if I have one main SkypeIn number, and I want that listed as the outbound caller id, how else could this be accomplished except by using the sam skype login for all/most ports?

    Suggestions?
     
  2. Montclairguy

    Joined:
    Feb 23, 2010
    Messages:
    68
    Likes Received:
    0
    From my tests, the caller ID is controlled by your Skype subscription account settings. I haven't been able to send out anything other than what's configured there (i.e. check your settings at skype.com)

    Regarding outbound calling, sounds like you may have "Allow outbound calls on this line" checked only for 10004, and unchecked for 10001, 10002, and 10003, in the PSTN section of the PBX setup.
     
  3. cogpartners

    Joined:
    Apr 12, 2010
    Messages:
    5
    Likes Received:
    0
    Thanks for the reply. I have fought the caller ID and this is certainly a huge downside to Skype. You can set it on the SIP trunks, but there is no subscription option on SIP Trunks. You pay per minute AND a connection fee. Suing the Skype gate way certainly makes more financial sense, however I can not get the outbound working correctly on the one account (cog.partners). Works fine using the Skype client, but not via the gateway. I removed all the ports and reconfigured them, including verifying the inbound/outbound calling were checked. I am leaning toward this is going to be a skype issue with the account itself.

    I am now having the common no DTMF issue on Skype, so at the moment, I am dropping the Skye gateway option and am using a SIP Trunk from voipvoip.com .. we'll see how that works. I did leave the Skype Gateway in place for forwarding calls to a skype user, although I am not sure how to do that from a physical phone :)

    Thanks again!!
     
  4. Montclairguy

    Joined:
    Feb 23, 2010
    Messages:
    68
    Likes Received:
    0
    Well, I did have a very odd issue with the PBX using the (now) unsupported Skype gateway product I'm using. The PBX refused to allow two out of the four lines to work properly, and it boiled down to some flakiness related to the extension numbering scheme in 3CX. Sounds completely ridiculous, but any inbound lines numbered above my outbound line refused to work at all. I'm curious if your issue is an extension of this bug. Do you have any credential failure messages in your 3CX logs?

    In any event, you should try (if not already) dumping the extra lines and accounts from the 3cx gateway, and just get one line working on the outbound account you want to use. If you get that going, then add the lines / accounts one at a time thereafter to nail down the problem.
     
Thread Status:
Not open for further replies.