Skypho VOIP : incoming calls no audio

Discussion in '3CX Phone System - General' started by aorlando, Jun 29, 2007.

  1. aorlando

    Joined:
    May 29, 2007
    Messages:
    27
    Likes Received:
    0
    My 3CX Pbx (3CX Phone System Version3.0.2328.0) is having following issues (I
     
  2. DaKhalli

    DaKhalli New Member

    Joined:
    Jun 2, 2007
    Messages:
    123
    Likes Received:
    0
    i suggest using the stunserver in the 3cx settings.

    also very important, if the phones are not located within the same network as your pbx, configure a stun server for them, even if you haveastatic ip it will solve the audio problems.

    if you still have problems, or want to try an approach without stun server, try binding the problematic extensions to the mediaserver.

    This shoulddo the trick, but maybe you need a combination of both solutions.
     
  3. 3CXsupport

    3CXsupport New Member
    3CX Staff

    Joined:
    Aug 21, 2006
    Messages:
    193
    Likes Received:
    0
    Hi aorlando,

    We have identified an issue that may emerge with certain providers.


    For that particular provider please use STUN resolved address. Please try it out and let us know if it fixes your issue.
     
  4. aorlando

    Joined:
    May 29, 2007
    Messages:
    27
    Likes Received:
    0
    Changing SKYPHO registration setting to use STUN SERVER

    I did 10 attempts in the last 10 minutes:

    2 times worked.. audio was present and bidirectional
    other 8 times.. no audio in any direction.

    I can't explain to myself this.

    P.S.

    I can't be sure about the time,
    but it seems that since the installation of the last beta (22 june)
    the SKYPHO Line appears always in Status: Not registered
    in spite of outgoing calls working and incoming calls ringing !!!

    I've already tried to delete the provider and to recreate.
    Nothing's changed.
     
  5. aorlando

    Joined:
    May 29, 2007
    Messages:
    27
    Likes Received:
    0
    Little correction about my first post:

    Redirecting the incoming call to VoiceMail, wav file containing registrations
    so audio is bidirectional.

    The problem borns during the redirection to the extension.
    On the PBX audio is bidirectional.

    It doesn't appear a problem of NAT because
    between Skypho incoming call and extension there is the PBX
    that works as media server so ..extensions must be only able
    to talk with PBX in their LAN in this configuration.
     
  6. aorlando

    Joined:
    May 29, 2007
    Messages:
    27
    Likes Received:
    0
    Does 3CX support need of a Skypho account to follow the problem
    with this provider ??

    I can do it.
     
  7. jits04

    Joined:
    May 2, 2007
    Messages:
    76
    Likes Received:
    0
    Ciao,

    dunque ti assicuro che Euteliavoip, ex shypho funziona bene. Tieni solo presente che con alcuni terminazioni telefoniche (tipo lo 0163) potresti avere dei problemi ultimamente. Ti consiglio di usare messagenet come secondo provider e impostare tali numerazioni su di esso. Costa anche meno visto che la tariffa
     
  8. aorlando

    Joined:
    May 29, 2007
    Messages:
    27
    Likes Received:
    0
    As I Explained in my last posts:

    3CX is installed on a Windows XP XP2 with firewall disabled,
    hardware firewall is installed to let pass all traffic from LAN to WAN
    and to redirect

    5060-5064 7000-7200 9000-9008 from WAN IP PUBLIC to the 3CX box.

    With VIRA VOIP Provider all works greatly : I can call out and receive
    calls

    with Skypho VOIP provider I have problems only receiving calls.

    It's about 18 months that I use Skypho with other hardware/software
    and I never had this kind of problems.

    Sincerely I don't know what can be happen in these last weeks:
    I've upgraded 3CX to the last version but firewall hardware configuration is not changed.

    Skypho providers is configured to 3CX to bind as media server:
    this means that should be enough to open ports 5060-5064 7000-7200 9000-9008.

    If 3CX Support confirms me that doesn't exist problem between Skypho provider
    and their PBX, tomorrow I'm going to format the Windows XP box to reinstall
    3CX.
     
  9. PedroGonzalez

    Joined:
    May 16, 2007
    Messages:
    1
    Likes Received:
    0
    for skypho try to open ports 8000-8500


    Pedro
     
  10. Anonymous

    Anonymous Guest

    Try to reduce your registration time. In general that is set to 240 i believe.

    What the problem might be with your 10 calls in 10 minutes is that the configuration did not pickup quick enought that your call was ended etc.

    Introducing a shorter re-registration time will force the configuration to check more frequently with the VSP and 3CX if all the devices are available to receive or to make calls.
     
  11. DaKhalli

    DaKhalli New Member

    Joined:
    Jun 2, 2007
    Messages:
    123
    Likes Received:
    0
     
  12. aorlando

    Joined:
    May 29, 2007
    Messages:
    27
    Likes Received:
    0
    Unluckly was already present port 3478 for STUN traffic in firewall:
    for this reason I didn't mention it.

    I tried to reduce registration time to 240: nothing's changed.

    P.S.
    It must be open in trasmission, not in receiving.

    Yesterday night I tried to configure another VOIP provider,
    MYWEBCALLS... with this provider registration works.

    I inserted another user account Skypho in 3CX and neither this works.

    Doesn't exist a deeper tool in 3CX to diagnose these kind of problems ??.
     

Share This Page