SMTP Email for Voicemail

Discussion in '3CX Phone System - General' started by ess, Jun 29, 2007.

  1. ess

    ess New Member

    Joined:
    Jun 8, 2007
    Messages:
    133
    Likes Received:
    0
    My server requires authentication in order to send mail, and I have the server, login, and password parameters setup accordingly. However, I receive and error when it tries to send an email.

    The error is Failed to connect to SMTP server mail.##############.com:25, response: '503 AUTH command used when not advertised', error: Invalid response after 'AUTH LOGIN'

    My server name is masked. I am not sure what this means. If anyone can enlighten me, please let me know. The smtp server is running through my web host.
     
  2. Anonymous

    Anonymous Guest

    is the mail server locally or remote.

    For example is 3cx on the same network or is the mail server hosted by an ISP?
     
  3. ess

    ess New Member

    Joined:
    Jun 8, 2007
    Messages:
    133
    Likes Received:
    0
    It is remote. I dont think i have to open any ports to the 3cx server because it is simply connecting like a mail client correct?
     
  4. Anonymous

    Anonymous Guest

    That is correct.

    Try two different ways.

    mail.##############.com:25 which you tried, but for reply address use your email address. The authentication (username and password) have to be your mail box login as the ISP gave you. Eg> ess@##############.com

    If that does not work remove the port the ":25" bit.

    Also make sure you have a valid email adress for your extension. This has to be the full email address the ISP gave you.

    Pretty much what you have to do is in the Voicemaile Settings under General you enter the exact same information as you would in outlook (or what ever mail client you use) for your account with the ISP.

    Somethimes they do a bit difficult if you specify the port they can see that as a direct "hack" attempt. But it is not a big thing
     
  5. ess

    ess New Member

    Joined:
    Jun 8, 2007
    Messages:
    133
    Likes Received:
    0
    The settings work in outlook and windows mail just fine. I don't see what could be going wrong. If anyone knows more about the smtp protocol and syntax for AUTH, let me know.

    -Tim
     
  6. ess

    ess New Member

    Joined:
    Jun 8, 2007
    Messages:
    133
    Likes Received:
    0
    I tried other email service provider's smtp settings and that doesn't work either.
     
  7. Anonymous

    Anonymous Guest

    Tim,

    Have you tried putting the same settings in 3CX as you have in outlook for the SMTP server?

    We (i run a hosing company on the side) do not really like un-authentitcated smtp traffic and want to use the most strict auth. we can get.

    So here are 3 settings you can try:

    mail.yourdomain.com:25
    mail.yourdomain.com
    IP of your mail.yourdomain.com

    If that does not work or either does not work let me know and Ill set you up on one of my mail servers so you can test if that works for you.
     
  8. dyntech

    dyntech New Member

    Joined:
    Mar 28, 2007
    Messages:
    160
    Likes Received:
    0
    Try using the outbound email server of your ISP. Most ISP's in the US ban port 25 if it is going to another SMTP server to stop Spam. The only way around this is to use their outbound SMTP server or use a different port.
     
  9. ess

    ess New Member

    Joined:
    Jun 8, 2007
    Messages:
    133
    Likes Received:
    0
    My web host (powweb) allows smtp traffic on port 587. This port returns the same error. I don't think it is a matter of connecting. I believe I am connecting to the server, however there is something wrong with the way 3cx is shaking hands with the smtp server.

    I don't know much about the protocols of the smtp server... Reading around I have found that perhaps the 3cx software needs to issue at EHLO command instead of a HELO, but then again I really don't know much about it.

    Thanks for looking into this guys, I appreciate it.

    And yes, I am using identical settings to Outlook that connects on the same PC.
     
  10. Alexander

    Joined:
    Nov 10, 2006
    Messages:
    73
    Likes Received:
    0
    503 error means "AUTH" command has been sent more than once during SMTP session.

    For the moment I can't imagine how it could happen except the situation when opening of SMTP port has been intercepted by some program; and this program inserted its own "AUTH" command into the SMTP session.
     
  11. Alexander

    Joined:
    Nov 10, 2006
    Messages:
    73
    Likes Received:
    0
    Please try to send without authorization (make the Username and Password fileds empty within General Settings/Voicemail settings)
     
  12. Alexander

    Joined:
    Nov 10, 2006
    Messages:
    73
    Likes Received:
    0
    Please also be sure that your SMTP server supports 'LOGIN' type of authentication.
     
  13. ess

    ess New Member

    Joined:
    Jun 8, 2007
    Messages:
    133
    Likes Received:
    0
    Leaving the user and pass fields blank results in the following:
    Failed to send SMTP message, response: '550-authsmtp09: Host 67.46.66.155: No unauthenticated relaying permitted to
    550 ###############.com', error: Invalid response after 'RCPT TO' (not 250)

    Perhaps the problem lies in my installation. When I upgraded to the beta, I simply installed over my previous copy. Could that be it? If it's not possible, I'd rather not uninstall/reinstall.

    As far as checking if the SMTP server supports the 'LOGIN' type of auth, I have tried with a few different providers. Getting support from any of them regarding their login procedures would be hopeless.

    Thanks for your help guys.
    -Tim
     
  14. Alexander

    Joined:
    Nov 10, 2006
    Messages:
    73
    Likes Received:
    0
    Hi Tim !

    Can you please tell me exactly what security parameters are defined within your Outlook account for accessing SMTP server ?
     
  15. ess

    ess New Member

    Joined:
    Jun 8, 2007
    Messages:
    133
    Likes Received:
    0
    I have outlook set to "Use the same login information as my POP3 Server". This is just a username/password. I am not using SPA or SSL at all. I have also tried different mail servers I have access to. Do you have a mail server that is proven to work that I could try?
     
  16. Anonymous

    Anonymous Guest

    Not sure if we have some confusing here..... ;-).

    3CX works independent of outlook.

    What is asked:

    SMTP server name: eg mail.yourdomain.com
    Username: ess@yourdomain.com
    Password: 12345

    use the same information you use to logon to your ISP mailserver and put them in 3CX.
     
  17. ess

    ess New Member

    Joined:
    Jun 8, 2007
    Messages:
    133
    Likes Received:
    0
    I know that they are different. I was merely responding to the previous post. Anyways, let me know if you have any ideas to get around this 503 error.
     
  18. Alexander

    Joined:
    Nov 10, 2006
    Messages:
    73
    Likes Received:
    0
    Hi Tim !

    Can you please send an empty e-mail to me (alexander@3cx.com), I'll send (as a response) a patch for testing. If you don't mind of course.

    Thanks for your help :)
     
  19. ess

    ess New Member

    Joined:
    Jun 8, 2007
    Messages:
    133
    Likes Received:
    0
    I sent the e-mail. Thanks for taking the time to follow up on this matter.
     
  20. ITWorks

    ITWorks New Member

    Joined:
    Apr 7, 2007
    Messages:
    121
    Likes Received:
    0
    SMTP SSL and authentication

    Did the patch work? I have a similar situation.
    Mark
     

Share This Page