SN4316 Generated Config

Discussion in '3CX Phone System - General' started by joebocop, Jul 17, 2014.

Thread Status:
Not open for further replies.
  1. joebocop

    Joined:
    Dec 12, 2013
    Messages:
    96
    Likes Received:
    0
    Hello,

    There seems to be an error in the "Generate Config File" functionality for the Patton SN4316 16x FXO device on 3CX Phone System 12.0.36097.670 SP6.

    For some reason, the 12th SIP interface port gets mapped to the third FXO interface:

    ..................
    interface sip IF_SIP_11
    bind context sip-gateway GW_SIP_11

    early-connect

    early-disconnect
    route call dest-interface IF_FXO_11
    remote 172.17.99.99 5060
    trust remote
    address-translation outgoing-call request-uri user-part fix 10014 host-part to-header target-param none
    address-translation incoming-call called-e164 request-uri

    interface sip IF_SIP_12
    bind context sip-gateway GW_SIP_3

    early-connect

    early-disconnect
    route call dest-interface IF_FXO_3
    remote 172.17.99.99 5060
    trust remote
    address-translation outgoing-call request-uri user-part fix 10006 host-part to-header target-param none
    address-translation incoming-call called-e164 request-uri

    interface sip IF_SIP_13
    bind context sip-gateway GW_SIP_13

    early-connect

    early-disconnect
    route call dest-interface IF_FXO_13
    remote 172.17.99.99 5060
    trust remote
    address-translation outgoing-call request-uri user-part fix 10016 host-part to-header target-param none
    address-translation incoming-call called-e164 request-uri
    ..............


    Making the change manually to be consistent with the 11th and 13th SIP interfaces solves the weirdness that this auto-generated config produces.

    Has anyone else seen this issue?! Took me a good few days to figure this out. Started with cabling... bad idea.
     
  2. pj3cx

    pj3cx Active Member

    Joined:
    Aug 1, 2013
    Messages:
    645
    Likes Received:
    1
    Thak you for the information, looks like a mistake in our template for this specific gateway.
    I've forwarded this to the relevant department.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.