Snom 320 f/w 8.7.3.25 & 3CX v12 SP2

Discussion in '3CX Phone System - General' started by Aitor, Nov 8, 2013.

Thread Status:
Not open for further replies.
  1. Aitor

    Joined:
    Nov 8, 2013
    Messages:
    2
    Likes Received:
    0
    Hi,

    I'm evaluating 3CX with a demo license and am trying it with a Snom 320 VOIP phone.

    I am able to provision the phone without having to muck about with DHCP and the phone works, at a basic level, but many of the features don't work. I haven't changed the phone template in 3CX at all. None of the buttons get mapped (e.g. BLF, voicemail, transfer) and the phone doesn't download the directory. The phone's http password isn't set either.

    The phone is running firmware version 8.7.3.25 and I'm wondering if this is the cause of the problems? Is there a known good version of the firmware that might cure the issues?

    To get the phone to work at all, this is what I had to do:

    1) Factory Reset - this was done via phone's web interface
    2) Assign phone to extension in 3CX
    3) Attempt to log in to the extension
    4) this wouldn't work until on the phone I manually changed the registrar to the 3CX ip address; otherwise it wanted to use domain (xxx.local) picked up from DHCP which is running on an existing Windows server.
    5) then the phone was registered and working
    6) changing anything (e.g. BLF values) in 3CX didn't change anything in the phone
    7) I can trigger a phone reboot from 3CX but "Reprovision Phones" doesn't do anything; "Reset & Reprovision" reboots the phone but doesn't fix the issues

    3CX is running in a Windows 2012 VM on a Windows 8.1 laptop. I'm also having issues with the 3CX windows softphone. iOS softphone works fine.

    Thanks for any help,

    Aitor
     
  2. Aitor

    Joined:
    Nov 8, 2013
    Messages:
    2
    Likes Received:
    0
    update: I downgraded the phone to 8.7.3.19 firmware, and reset & reprovisioned it - but no change
     
Thread Status:
Not open for further replies.