SNOM 320 Language Problem

Discussion in '3CX Phone System - General' started by Tahir, Jan 7, 2016.

Thread Status:
Not open for further replies.
  1. Tahir

    Joined:
    Dec 15, 2007
    Messages:
    11
    Likes Received:
    0
    Hi,

    I have Snom 320 which I have added to our 3CX installation, all was working well and it provisioned correctly however after about 20 minutes I noticed the phone display had changed, looking into it further it appears the language is not English. After logging into the Snom 320 webpage it shows 7 Thailand (Bangkok) at the very top yet everything else on the settings indicates English and I cannot for the life of me find a way to change this back to English, can anyone help?
     
  2. NickD_3CX

    NickD_3CX Support Team
    Staff Member 3CX Support

    Joined:
    Jun 2, 2014
    Messages:
    1,246
    Likes Received:
    61
    I would recommend doing the following:
    1) Re-downloading the templates from the Management Console -> Updates -> Phone Templates.
    2) Make sure the phone has a fairly new firmware, maybe something 8.7.3.x or newer and if you are on V14 3CX Phone System, the recommended firmware for this phone is now v8.7.5.35.
    3) Resetting the phone to Factory Defaults. On these phones this is done by pressing the *, volume up, *, volume down, #, keys on the phone. Instructions for this are here: http://wiki.snom.com/FAQ/How_can_I_set_the_phone_back_to_admin_mode_or_factory_defaults_respectively
    4) Reprovision the phone using PnP, not manually.
     
Thread Status:
Not open for further replies.