Dismiss Notice
We would like to remind you that we’re updating our login process for all 3CX forums whereby you will be able to login with the same credentials you use for the Partner or Customer Portal. Click here to read more.

Snom Firmware Issue and Questions

Discussion in '3CX Phone System - General' started by telis, Feb 16, 2017.

Thread Status:
Not open for further replies.
  1. telis

    telis New Member

    Joined:
    Aug 13, 2007
    Messages:
    158
    Likes Received:
    28
    Hi,

    I have a couple of questions about the SNOM firmware for the 710, 715, D710 and D715 and also the 760 and D765 firmware in relation to 3CX V15.

    http://wiki.snom.com/Firmware/ - on this site snom lists all their latest firmware with release notes. The thing is that almost all the the lastest firmware versions are listed as 8.7.5.35 but 3CX V15 upgrades the handsets to version 8.9.3.38 which isn't mentioned, apart from for the D375.

    Q 1. What is going on?

    Q 2. Does version 15 support snom firmware 8.7.5.35?

    The reason I ask is that there is snafu is call parking in 8.9.3.38 which I will go in to in a different thread.
     
  2. aberry

    aberry New Member

    Joined:
    Jan 13, 2015
    Messages:
    119
    Likes Received:
    7
    The snom wiki firmware updates for phone are very out of date. You can get access to new firmware files by creating a SNOM community account, and then requesting access to the firmware files.

    https://community.snom.com/

    Sometimes they will only send you firmware for phones if you create a ticket - for example if you want access to the UC edition firmwares for the models that have them.
     
  3. telis

    telis New Member

    Joined:
    Aug 13, 2007
    Messages:
    158
    Likes Received:
    28
    OK, thanks for the response @aberry . That's poor because that means I have no documentation or change list with which to troubleshoot my issue. I'll post something on their forum and see if they can give me anything.

    Any ideas if 8.7.5.35 is supported with V15?
     
  4. aberry

    aberry New Member

    Joined:
    Jan 13, 2015
    Messages:
    119
    Likes Received:
    7
    I have 715s running 8.9.3.38, but my D765s I had to manually upgrade to 8.9.3.50 to get BLF lights working. Here is the link they sent me:

    http://downloads.snom.com/interop/firmware/8.9.3.50/snomD765-8.9.3.50-SIP-r.bin

    I don't think I have seen a parking issue. It looks like they just added support for 8.9.3.57 as it is showing in my 3CX updates section, but I haven't tried to install or update to it yet. It may require the update to SP5.
     
  5. telis

    telis New Member

    Joined:
    Aug 13, 2007
    Messages:
    158
    Likes Received:
    28
    I'll post more tomorrow because I have to leave now but the parking issue is basically you can't park a call from a shared park BLF key when the phone is on the "enter number" screen and with 8.7.5.35 you could. It may be a configuration/template issue - I will triple check tomorrow but I don't think so.

    It confuses the users because it means if you are on a call and you press the park BLF button to park it and it parks fine, and after the call is parked you can press the same now flashing key to pick it up. But then the phone will be on the "enter number" screen and you can't re-park it until you press X first - when you try parking nothing happens. That pressing X step is not necessary with 8.7.5.35.

    Thanks for the link, my test handsets are 710's, I tried mangling it but then I get a 404.

    I'll start again tomorrow.
     
  6. aberry

    aberry New Member

    Joined:
    Jan 13, 2015
    Messages:
    119
    Likes Received:
    7
    Yeah, sounds like a firmware / operational bug. Good luck - likely if you create a ticket they will send you a link within a couple days, that's the only solution I could find.
     
  7. telis

    telis New Member

    Joined:
    Aug 13, 2007
    Messages:
    158
    Likes Received:
    28
    So I made a ticket with snom and they sent me, pretty promptly, 8.9.3.59.102. And it fixed the parking bug!!!

    Sadly it broke the voicemail notifications. More testing is needed.

    I'm surprised 3CX or one of the V15 beta testers did not pick up on the parking issue. I'm also surprised that snom seem to have completely ditched their release cadence and release wiki. What is going on?
     
  8. telis

    telis New Member

    Joined:
    Aug 13, 2007
    Messages:
    158
    Likes Received:
    28
    Actually I broke the VM notifications - 8.9.3.59.102 does work.
     
  9. aberry

    aberry New Member

    Joined:
    Jan 13, 2015
    Messages:
    119
    Likes Received:
    7
    good to hear - I agree the wiki being seemingly abandoned is very disappointing.
     
  10. telis

    telis New Member

    Joined:
    Aug 13, 2007
    Messages:
    158
    Likes Received:
    28
    I have to report that the new version of the snom firmware is out now and the wiki now seems to be very much updated.

    http://wiki.snom.com/Category:Firmware

    http://wiki.snom.com/Firmware/V8_9_3_60

    I'll install the updates on my test system and then live systems since I'm on an updated beat firmware anyway. Hopefully 3CX will make the new firmware available via the updates feature at some point after testing since there are quite a few bug fixes available especially in call parking.

    It's nice to see that things look to be back on track in snom-land :)
     
  11. Mark@EvoIT

    Joined:
    Mar 16, 2017
    Messages:
    27
    Likes Received:
    2
    Is it just me or does 3CX though working perfect on 8.9.3.60 complain in the dashboard that "Not Support Firmware 8.9.3.60" for my Snom D715 handsets. Never noticed it before checking, on the latest update for 3CX (15.5.3849.1).

    Thanks all!

    Well what do you know though Snom doesn't like it looks like 3CX lists a Maintenance release 8.9.3.66. I know I never saw the red highlighting before saying "Not Supported" on those handsets, possibly since release of 8.9.3.66 they are pushing to update?
     
    #11 Mark@EvoIT, Sep 19, 2017
    Last edited: Sep 19, 2017
  12. YiannisH_3CX

    YiannisH_3CX Support Team
    Staff Member 3CX Support

    Joined:
    May 10, 2016
    Messages:
    7,400
    Likes Received:
    535
    The management console will mark the phones as not supported when the phones are running a firmware different that the one supported for your version of PBX. For version 15.5.3849.1 the supported version is 8.9.3.66. If you are on a previous version the phones will be marked as not supported.
     
  13. Mich

    Joined:
    Jan 16, 2013
    Messages:
    3
    Likes Received:
    0
    Can you run auto provisioning with D715s on 3cx V14 ? It's not picking up my custom template and I'd upgraded the phone to the latest firmware 8.9.3.60 before I did programming and having trouble getting it to take the template properly - I was wondering if that firmware works properly with V14 or not ? I will try downgrading it to a lower version and test it that way but wondered if anyone here knew off hand ?
     
  14. StefanW

    StefanW Head of Customer Support and Training
    Staff Member 3CX Support

    Joined:
    Jun 2, 2009
    Messages:
    1,222
    Likes Received:
    93
    custom templates and v14 are both out of the scope. For many needs to make custom template V15.5 has now a bunch of settings removing the need to do so.

    As V14 is EOL upgrade to v15.5
    In case you MA is expired, there is currently this offer available: https://www.3cx.com/blog/news/pbx-upgrade-free/
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.