Snom phones missing 1-2 seconds at start of conversation

Discussion in '3CX Phone System - General' started by chrischevy, Dec 9, 2010.

Thread Status:
Not open for further replies.
  1. chrischevy

    Joined:
    Jun 7, 2010
    Messages:
    74
    Likes Received:
    0
    Hi,

    I already have a ticket opened with Snom but I'm asking here to see if anyone else has this problem.

    After being connected a day or two, there seems to be a problem with all our Snom 300, 320 and 370 phones. When someone places a call, the first 1-2 seconds of the conversation are lost. This mean that our users often miss the "Hello" of the person they are trying to reach, causing some frustration as the person at the other end of the line has to say "Hello" a second time, or sometimes they just hang up.

    If the phone is rebooted, the problem seems to go away for a few days.

    The same thing happens when checking voicemail: the prompt message starts while the phone is still ringing, so the first 1-2 seconds are lost. Sometimes, there is even a full ring after the voicemail prompt has started.

    Here is the answer I got from Snom after sending some packet capture:

    "The difference which I managed to see by comparing the 2 traces was that the phone sends the acknowlidgement packets (ACK) one second later. This might mean that the phone becomes slower with time. We have had similar problems with snom phones used together with 3CX, and we can offer you a fix version for testing. "

    We tried a new version of the firmware (8.4.24) but the problem is still present.

    Has anyone experienced a similar issue with Snom phones ?

    I just configured an old Granstream GXP2000 for testing purposes. I will see in a few days if the same problem appears on this phone.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. jim@itstod.se

    jim@itstod.se New Member

    Joined:
    Apr 7, 2008
    Messages:
    100
    Likes Received:
    0
    I can confirm that we are experiencing exactly the same issue. We have many customers that use snom phones together with 3CX and they all tell us that they have this problem. Rebooting the phone solves it for a couple of days.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. chrischevy

    Joined:
    Jun 7, 2010
    Messages:
    74
    Likes Received:
    0
    Update:

    We are working in close collaboration with Snom to fix this issue. They have a phone configured on our 3CX and we are providing them all the information they need. I will post updates once we have more information.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. puetzbastian

    Joined:
    Dec 16, 2010
    Messages:
    1
    Likes Received:
    0
    We have exactly the same Problem!!
    We activated early audio on our Gateway (Patton).
    We took load from the processor of the snom phones but it doesn´t seem to fix the problem.
    After a few days the problem repeats and we have to restart the phones.
    We also have the Firmware 8.4.18.
    Is there anything new to fix this problem?
     
  5. chrischevy

    Joined:
    Jun 7, 2010
    Messages:
    74
    Likes Received:
    0
    Update:

    The problem is now fixed !

    The option "Use Flash Plugin" in the phone's preferences simply has to be turned off.
    The phones response time to key press seems to be much better also.

    The setting is already in the template:

    <!--# The "with_flash" field specifies whether the phone's Home Page (in its web interface) will actively show incoming and outgoing calls as they happen if the viewing browser supports Macromedia Flash. Valid values are "on"==Enable Live Update, "off"=="Disable Live Update". The provisioning template sets the value to "on"==Enable Live Update.-->
    <with_flash perm="">off</with_flash>
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. complex1

    complex1 Active Member

    Joined:
    Jan 25, 2010
    Messages:
    789
    Likes Received:
    45
    Thank you for your update.
    I appreciate this.

    Strange, snom’s default value is “on”
    http://wiki.snom.com/wiki/index.php/Settings/with_flash
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,128
    Likes Received:
    152
    Wonderful - very intuitive from snom

    <!--# The "with_flash" field specifies whether the phone's Home Page (in its web interface) will actively show incoming and outgoing calls as they happen if the viewing browser supports Macromedia Flash. Valid values are "on"==Enable Live Update, "off"=="Disable Live Update".
    The provisioning template sets the value to "on"==Enable Live Update.-->
    <with_flash perm="">on</with_flash>

    I will update the template for the benefit of the 3CX Community that are still unfortunately stuck with these phones. This was not the case in firmware 7 of the snom phones.

    They definitely have some problem or memory leak in this - this is why rebooting the phone fixes this for a short while whilst still keeping this value on.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,128
    Likes Received:
    152
    Snom template updated - should be available for download from 3CXPhone System updates / Phone provisioning updates.

    Download, go to phones page and select all the snom phones - click re-provision.

    Thanks for whoever managed to nail this issue.

    We have complained so much about it to snom - making captures and ping ponging support tickets here and there. Thanks for this information.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. chrischevy

    Joined:
    Jun 7, 2010
    Messages:
    74
    Likes Received:
    0
    Update from Snom:

    A fix will be included in the next official firmware release. The phones will work correctly even with the flash option ON.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. gfischer

    Joined:
    Sep 19, 2011
    Messages:
    4
    Likes Received:
    0
    hello all,

    i read the threads about missing 1-2 seconds at start of conversation,

    i'm using snom300 and snom320 telephones, and i still got the problem with "delaying calls".

    Snom 300, Firmware: snom300-SIP 8.4.31
    Snom 320, Firmware: snom320-SIP 8.4.32

    i checked our templates and found the option, wich is default set to

    <with_flash perm="">off</with_flash>

    is there another setting to change ?

    please help !
     
  11. nb

    nb Support Team
    Staff Member 3CX Support

    Joined:
    Jun 7, 2007
    Messages:
    2,128
    Likes Received:
    152
    But is this a normal call from A to B? And you still have 2 seconds missing?

    What is the call scenario where you get this problem? External call, Voip Provider call, Queue call?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. gfischer

    Joined:
    Sep 19, 2011
    Messages:
    4
    Likes Received:
    0
    external call is routed to a queue, wich is routed to a phone.. the user get the calls from this one phone...

    so, the user grabs the call from this "queue phone", says "hello, welcome to, my name is " and the other side only hears "name is"...
     
  13. matictec

    matictec New Member

    Joined:
    Mar 31, 2008
    Messages:
    188
    Likes Received:
    0
    We have the same problem on some installations, but also with other phones. We do not find a solution until now.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,825
    Likes Received:
    2
    Start with:
    Remove "Supports replaces" in configuration of "queue phone".
    If doesn't help then:
    "PBX delivers audio"=on
    If doesn't help then:
    "Supports re-INVITE"=off
    Still doesn't help? Then source of call is PSTN gateway...
    Change its configuration to:
    "Supports re-INVITE"=off

    If you use 3CX Phone as "queue phone" and have this problem then you need to perform only last step.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. igor.snezhko

    igor.snezhko Active Member

    Joined:
    Jan 7, 2008
    Messages:
    667
    Likes Received:
    7
    I found, that this is network switch issue, of cable quality issue. Try to use another switch, if any other solution not help.
     
  16. gfischer

    Joined:
    Sep 19, 2011
    Messages:
    4
    Likes Received:
    0
    thanks for the reply stephan,

    where can i find these options ? at the snom interface or on the 3cx phone system interface?
    we practice the "queue" version...


    br
     
  17. SY

    SY Well-Known Member
    3CX Support

    Joined:
    Jan 26, 2007
    Messages:
    1,825
    Likes Received:
    2
    It was about 3CX management console.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.