[Solved] 3CXPhone Motorola Cliq Registration issues

Discussion in 'Android' started by sfire, Jul 7, 2010.

Thread Status:
Not open for further replies.
  1. sfire

    Jul 7, 2010
    Likes Received:

    #1 - WiFI registration with callcentric results in incoming calls only. (Tested on 10+ wifi networks) 3G fully registers
    #2 - Constant and reproducible registration failures. The client will register fine then after a little while it will "fall offline" This happens on 3G and WiFi.
    #3 - Needs to attempt re-registration if it fails. It should keep trying especially if it was able to log in previously.
    #4 - (MINOR) The screen doesn't rotate when I fold out my keyboard. All other apps seem to do this automatically.
    #5 - (MINOR) 3CXPhone doesn't automatically start with the phone.
    #6 - (MINOR) The proximity sensor doesn't seem to work with the Motorola Cliq. When I put the phone to my ear it "presses buttons". I have to use the power switch to turn off the screen and disable touch input.

    All my settings can be found at the bottom of this post.

    Longer Description of problem below:

    I have been using 3CXPhone for the last week or so and have been having some issues with it. I am using callcentric as my VoIP provider and I've been able to get the phone to register with their network just fine as long as I'm in 3G mode. When I enable my WiFI I get a yellow registration ball and can only get incoming calls (outgoing fails).

    I have tried this on multiple wifi networks and each has the same result. If I use a different client (linphone,sipdroid) the wifi works perfectly so I don't understand whats happening with this client. I have un-installed all other VoIP clients from the phone so it shouldn't be a conflict.

    For whatever reason my 3G seems to be getting enabled momentarily when using this client. Whenever this happens I lose my connection to the VoIP provider and the 3CXPhone app simply states "Registration Failed". If I restart the application (exit & relaunch) then it will work again normally. The thing that sucks about this is that the phone will NEVER attempt to re-register once it says "registration failed". This throws a huge monkey wrench in my usage.

    These are my only 2 problems with this application other than that it seems to be flawless. These issues are deal breakers however since both of these issues directly effect the function of the software. If the client isn't registered with my VoIP provider than I cannot get any calls.

    I am willing to provide any assistance I can to get to the bottom of this issue. I will even take video of the client doing this on my phone as it is EASILY reproducible. I will do anything that will help to get these issues fixed as I need a dependable sip client.

    User: 1777XXXXXXX (my username)
    Password: XXXXXXXXX
    Internal Server: callcentric.com
    External Server: callcentric.com
    STUN Server:
    Port: 5060
    Registration Timeout: 300
    Keep-Alive Interval: 15
    DMTF Method: RFC-2833
    Enable NAT: Yes
    Enable ICE: No
    Lock Wifi: When Powered
    Proximity Sensor: yes
    Enable 3G: Yes
    Redirect Normal Calls: No
    Log Call Records: yes
    Record Calls: yes
    Audio Settings:
    Echo Cancellation: yes
    Silence Detection: No
    Play Buffer: -1
    Record Buffer: -1
    Mic Gain: 1
    Audio Codecs:
    G.711 (uLaw): Yes
    G.711 (aLaw): Yes
    GSM: No
    Speex: No
  2. psmadja@gmail.com

    Jul 19, 2010
    Likes Received:
    Re: 3CXPhone Motorola Cliq Registration issues

    I have the same problem.

    I have a Motorola DROID with the French FREE provider line and I can't connect.
    It's really upsetting me as it's working on my PC with the same user details.
    Someone got an idea?

    Thank you.
  3. sfire

    Jul 7, 2010
    Likes Received:
    Re: 3CXPhone Motorola Cliq Registration issues

    I have fixed my issues with 3CXPhone.

    I had to do a software upgrade on the phone itself. I kept getting errors previously when I did it. I got fed up with the VoIP service so I reset the phone to the factory defaults.

    Then after installing the latest Android OS on the phone the VoIP works perfectly.

    I wanted to make sure to leave a note for anyone else who might have the same issue
Thread Status:
Not open for further replies.