[SOLVED] v12 Outgoing SMTP Win2012 DataCenter IIS8

Discussion in '3CX Phone System - General' started by ict11, Mar 9, 2014.

Thread Status:
Not open for further replies.
  1. ict11

    Joined:
    Nov 8, 2012
    Messages:
    2
    Likes Received:
    0
    We are currently hosting eCommerce sites on this box we are testing 3CX v12 on. All IIS8 sites are emailing without issues, how ever 3CX is not. I'm still not sure if 3CX is using IIS or dll (mapi) to send emails. Would be nice if it was IIS btw..

    The SMTP settings have been changed from our Corp server to smtp.gmail.com while testing and none seem to connect via SSL/TLS. Also tried installing a local SMTP on the Win2012 Server with no avail, no error when sending email from the control panel under extensions.

    There is also no detailed logging available to troubleshoot these attempts. The only log file that had some resemblance of info was the CallHistoryService.log which indicates: Failure sending mail, ---> Also is there a flat file that can be configured directly?

    ~jim
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. jpillow

    jpillow Well-Known Member

    Joined:
    Jun 20, 2011
    Messages:
    1,342
    Likes Received:
    0
    Re: v12 Outgoing SMTP Win2012 DataCenter IIS8

    What version 3cx are you using firmware etc... Free, demo, license...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. ict11

    Joined:
    Nov 8, 2012
    Messages:
    2
    Likes Received:
    0
    [SOLVED] Re: v12 Outgoing SMTP Win2012 DataCenter IIS8

    Hey jpillow..

    Lic. ver..

    I have found a workaround for using SSL/TLS.

    As gmail and most secure Corp MX servers use port 587 I did this in the Mail Server settings tab of the form:

    Mail Server: mail.domain.com:587
    reply Address: voicemail@domain.com
    User Name for SMTP Server: username
    Password for accessing SMTP Server: password
    (did not check SSL/TLS)

    Hope this helps others.. would like to see some logging with outgoing mail to a log file with some debugging features... would be helpful.
    Also a port setting for secure connections would be helpful as some corp MX servers use custom port settings.

    cheers!

    ~jim
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. WatIZIT

    Joined:
    Feb 27, 2015
    Messages:
    2
    Likes Received:
    0
    I'm having the same problem, 2nd time this has happened, password/no ssl checked, tried port :587, using V12 on Win2008R2 on AWS, Restarted SMTP Service/3CX & Server, Ports checked, nothing and i needed this today :-((
     
  5. craigreilly

    craigreilly Well-Known Member

    Joined:
    Feb 1, 2012
    Messages:
    3,321
    Likes Received:
    252
    antivirus?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Thread Status:
Not open for further replies.